build libblk statically, disable python3-rgw
This commit is contained in:
parent
b913651251
commit
5fd066d648
11
0005-src-blk-CMakeLists.txt.patch
Normal file
11
0005-src-blk-CMakeLists.txt.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
|
||||
@@ -25,7 +25,7 @@
|
||||
zoned/HMSMRDevice.cc)
|
||||
endif()
|
||||
|
||||
-add_library(blk ${libblk_srcs})
|
||||
+add_library(blk STATIC ${libblk_srcs})
|
||||
target_include_directories(blk PRIVATE "./")
|
||||
|
||||
if(HAVE_LIBAIO)
|
10
ceph.spec
10
ceph.spec
@ -64,7 +64,7 @@
|
||||
#################################################################################
|
||||
Name: ceph
|
||||
Version: 16.1.0
|
||||
Release: 0.6.snapshot%{?dist}
|
||||
Release: 0.7.snapshot%{?dist}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
Epoch: 2
|
||||
%endif
|
||||
@ -87,6 +87,7 @@ Patch0001: 0001-src-common-crc32c_intel_fast.patch
|
||||
Patch0002: 0002-src-common-CMakeLists.txt.patch
|
||||
Patch0003: 0003-src-common-bitstr.h.patch
|
||||
Patch0004: 0004-src-CMakeLists.txt.patch
|
||||
Patch0005: 0005-src-blk-CMakeLists.txt.patch
|
||||
Source1: cmake-modules-BuildBoost.cmake.noautopatch
|
||||
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
||||
ExcludeArch: i686 armv7hl
|
||||
@ -315,7 +316,6 @@ Requires: libcephfs2 = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-rados = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-rbd = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-cephfs = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-rgw = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-ceph-argparse = %{_epoch_prefix}%{version}-%{release}
|
||||
Requires: python%{python3_pkgversion}-ceph-common = %{_epoch_prefix}%{version}-%{release}
|
||||
%if 0%{with jaeger}
|
||||
@ -868,8 +868,6 @@ rm -f %{buildroot}%{_mandir}/man8/cephadm.8*
|
||||
#################################################################################
|
||||
# files and systemd scriptlets
|
||||
#################################################################################
|
||||
%files
|
||||
|
||||
%files common
|
||||
%dir %{_docdir}/ceph
|
||||
%doc %{_docdir}/ceph/sample.ceph.conf
|
||||
@ -1107,6 +1105,10 @@ fi
|
||||
%{_includedir}/rados/objclass.h
|
||||
|
||||
%changelog
|
||||
* Mon Mar 15 2021 Boris Ranto <branto[at]redhat.com> - 2:16.1.0-0.7.snapshot
|
||||
- libblk.so -> libblk.a
|
||||
- remove python3-rgw from ceph-common deps
|
||||
|
||||
* Mon Mar 15 2021 Boris Ranto <branto[at]redhat.com> - 2:16.1.0-0.6.snapshot
|
||||
- disable multiple build options
|
||||
- disable multiple packages
|
||||
|
Loading…
Reference in New Issue
Block a user