16.1.0 RC

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2021-03-25 19:49:46 -04:00
parent 03686a5492
commit 5e9e44ba9d
5 changed files with 8 additions and 115 deletions

View File

@ -1,10 +0,0 @@
--- ceph-15.2.8/src/common/ceph_time.h.orig 2020-12-24 06:23:32.605762289 -0500
+++ ceph-15.2.8/src/common/ceph_time.h 2020-12-24 13:50:14.304877611 -0500
@@ -18,6 +18,7 @@
#include <chrono>
#include <iostream>
#include <string>
+#include <optional>
#include <sys/time.h>
#include "include/ceph_assert.h"

View File

@ -1,22 +0,0 @@
--- ceph-15.2.8/src/CMakeLists.txt.orig 2021-01-25 13:34:31.122206146 -0500
+++ ceph-15.2.8/src/CMakeLists.txt 2021-01-25 13:37:12.863612216 -0500
@@ -23,10 +23,16 @@
set(datadir ${CEPH_INSTALL_DATADIR})
set(prefix ${CMAKE_INSTALL_PREFIX})
-add_definitions("-DHAVE_CONFIG_H -D__CEPH__ -D_REENTRANT -D_THREAD_SAFE -D__STDC_FORMAT_MACROS")
-add_definitions("-D_FILE_OFFSET_BITS=64")
+add_definitions(-DHAVE_CONFIG_H
+ -D__CEPH__
+ -D_REENTRANT
+ -D_THREAD_SAFE
+ -D__STDC_FORMAT_MACROS
+ -D_FILE_OFFSET_BITS=64
+ -DBOOST_ASIO_DISABLE_THREAD_KEYWORD_EXTENSION
+ -DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
if(LINUX)
- add_definitions("-D_GNU_SOURCE")
+ add_definitions(-D_GNU_SOURCE)
endif()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")

View File

@ -1,78 +0,0 @@
--- ceph-16.1.0/src/librbd/AsioEngine.h.orig 2021-01-27 09:52:12.314415539 -0500
+++ ceph-16.1.0/src/librbd/AsioEngine.h 2021-01-27 09:55:35.289955105 -0500
@@ -39,7 +39,8 @@
inline operator boost::asio::io_context&() {
return m_io_context;
}
- inline boost::asio::io_context::executor_type get_executor() {
+ using executor_type = boost::asio::io_context::executor_type;
+ inline executor_type get_executor() {
return m_io_context.get_executor();
}
--- ceph-16.1.0/src/librbd/migration/FileStream.cc.orig 2021-01-27 09:58:21.984505879 -0500
+++ ceph-16.1.0/src/librbd/migration/FileStream.cc 2021-01-27 09:58:48.945241982 -0500
@@ -121,7 +121,8 @@
template <typename I>
FileStream<I>::FileStream(I* image_ctx, const json_spirit::mObject& json_object)
: m_cct(image_ctx->cct), m_asio_engine(image_ctx->asio_engine),
- m_json_object(json_object), m_strand(*m_asio_engine) {
+ m_json_object(json_object),
+ m_strand(boost::asio::make_strand(*m_asio_engine)) {
}
template <typename I>
--- ceph-16.1.0/src/librbd/migration/FileStream.h.orig 2021-01-27 09:59:03.542640537 -0500
+++ ceph-16.1.0/src/librbd/migration/FileStream.h 2021-01-27 09:59:42.054692043 -0500
@@ -6,7 +6,8 @@
#include "include/int_types.h"
#include "librbd/migration/StreamInterface.h"
-#include <boost/asio/io_context_strand.hpp>
+#include <boost/asio/io_context.hpp>
+#include <boost/asio/strand.hpp>
#include <boost/asio/posix/basic_stream_descriptor.hpp>
#include <json_spirit/json_spirit.h>
#include <memory>
@@ -48,7 +49,7 @@
std::shared_ptr<AsioEngine> m_asio_engine;
json_spirit::mObject m_json_object;
- boost::asio::io_context::strand m_strand;
+ boost::asio::strand<boost::asio::io_context::executor_type> m_strand;
#ifdef BOOST_ASIO_HAS_POSIX_STREAM_DESCRIPTOR
std::optional<boost::asio::posix::stream_descriptor> m_stream_descriptor;
--- ceph-16.1.0/src/librbd/migration/HttpClient.cc.orig 2021-01-27 10:00:04.167295789 -0500
+++ ceph-16.1.0/src/librbd/migration/HttpClient.cc 2021-01-27 10:00:34.303118596 -0500
@@ -764,7 +764,8 @@
template <typename I>
HttpClient<I>::HttpClient(I* image_ctx, const std::string& url)
: m_cct(image_ctx->cct), m_image_ctx(image_ctx),
- m_asio_engine(image_ctx->asio_engine), m_url(url), m_strand(*m_asio_engine),
+ m_asio_engine(image_ctx->asio_engine), m_url(url),
+ m_strand(boost::asio::make_strand(*m_asio_engine)),
m_ssl_context(boost::asio::ssl::context::sslv23_client) {
m_ssl_context.set_default_verify_paths();
}
--- ceph-16.1.0/src/librbd/migration/HttpClient.h.orig 2021-01-27 10:00:49.626536973 -0500
+++ ceph-16.1.0/src/librbd/migration/HttpClient.h 2021-01-27 10:01:38.728877629 -0500
@@ -9,7 +9,8 @@
#include "librbd/io/Types.h"
#include "librbd/migration/HttpProcessorInterface.h"
#include "librbd/migration/Types.h"
-#include <boost/asio/io_context_strand.hpp>
+#include <boost/asio/io_context.hpp>
+#include <boost/asio/strand.hpp>
#include <boost/asio/ip/tcp.hpp>
#include <boost/asio/ssl/context.hpp>
#include <boost/beast/version.hpp>
@@ -171,7 +172,7 @@
HttpProcessorInterface* m_http_processor = nullptr;
- boost::asio::io_context::strand m_strand;
+ boost::asio::strand<boost::asio::io_context::executor_type> m_strand;
boost::asio::ssl::context m_ssl_context;
std::unique_ptr<HttpSessionInterface> m_http_session;

View File

@ -126,7 +126,7 @@
################################################################################# #################################################################################
Name: ceph Name: ceph
Version: 16.1.0 Version: 16.1.0
Release: 0.8.snapshot%{?dist} Release: 1%{?dist}
%if 0%{?fedora} || 0%{?rhel} %if 0%{?fedora} || 0%{?rhel}
Epoch: 2 Epoch: 2
%endif %endif
@ -143,8 +143,8 @@ Group: System/Filesystems
%endif %endif
URL: http://ceph.com/ URL: http://ceph.com/
#Source0: %%{?_remote_tarball_prefix}ceph-%%{version}.tar.gz #Source0: %%{?_remote_tarball_prefix}ceph-%%{version}.tar.gz
# https://2.chacra.ceph.com/r/ceph/pacific/abe639e639eb... # https://download.ceph.com/rpm-16.1.0/el8/SRPMS/...
Source0: ceph-16.1.0-944-ge53ee8bd.tar.bz2 Source0: ceph-16.1.0.tar.bz2
Patch0001: 0001-src-common-crc32c_intel_fast.patch Patch0001: 0001-src-common-crc32c_intel_fast.patch
Patch0002: 0002-src-common-CMakeLists.txt.patch Patch0002: 0002-src-common-CMakeLists.txt.patch
Patch0003: 0003-src-common-bitstr.h.patch Patch0003: 0003-src-common-bitstr.h.patch
@ -1194,7 +1194,7 @@ This package provides Ceph default alerts for Prometheus.
# common # common
################################################################################# #################################################################################
%prep %prep
%autosetup -p1 -n ceph-16.1.0-944-ge53ee8bd %autosetup -p1
%ifarch x86_64 %ifarch x86_64
patch -p1 < %{SOURCE1} patch -p1 < %{SOURCE1}
%endif %endif
@ -2455,6 +2455,9 @@ exit 0
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml %config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
%changelog %changelog
* Thu Mar 25 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:16.1.0-1
- 16.1.0 RC
* Tue Mar 23 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:16.1.0-0.8.snapshot * Tue Mar 23 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:16.1.0-0.8.snapshot
- 16.1.0 RC (ceph-16.1.0-944-ge53ee8bd plus fix trailing slash bluestore) - 16.1.0 RC (ceph-16.1.0-944-ge53ee8bd plus fix trailing slash bluestore)

View File

@ -1 +1 @@
SHA512 (ceph-16.1.0-944-ge53ee8bd.tar.bz2) = 6105a008088fb09e0ee456da14bdfe714188f78c3ac22df611b212a34f7a8e13ee8a00fe88698a3633eda8380892297e94530dd9e8736c00dd3d893bd2380b94 SHA512 (ceph-16.1.0.tar.bz2) = 4a0107ac9a1636100294a5e968c9e830966727fc6135380b3406fa79fd7b92b5724764ffd68db5ca5c5a7bfbffd61dbd78854eb20e70ec741e77d2532561a0dc