ceph-18.1.2 RC3
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
1980396784
commit
468a2c36ab
@ -1,6 +1,6 @@
|
||||
--- ceph-17.2.5/src/common/subsys_types.h.orig 2023-01-17 05:29:55.711592884 -0500
|
||||
+++ ceph-17.2.5/src/common/subsys_types.h 2023-01-17 05:31:05.759282197 -0500
|
||||
@@ -53,7 +53,7 @@
|
||||
--- ceph-18.1.2/src/common/subsys_types.h.orig 2023-06-27 15:59:59.000000000 -0400
|
||||
+++ ceph-18.1.2/src/common/subsys_types.h 2023-07-04 19:36:55.941238973 -0400
|
||||
@@ -54,7 +54,7 @@
|
||||
#undef DEFAULT_SUBSYS
|
||||
}
|
||||
|
||||
@ -9,28 +9,8 @@
|
||||
ceph_subsys_get_max_default_level(const std::size_t subidx) {
|
||||
const auto item = ceph_subsys_get_as_array()[subidx];
|
||||
return std::max(item.log_level, item.gather_level);
|
||||
--- ceph-17.2.5/src/msg/async/compression_onwire.h.orig 2023-01-17 07:34:31.923701878 -0500
|
||||
+++ ceph-17.2.5/src/msg/async/compression_onwire.h 2023-01-17 07:35:04.493093534 -0500
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
class TxHandler final : private Handler {
|
||||
public:
|
||||
- TxHandler(CephContext* const cct, CompressorRef compressor, int mode, std::uint64_t min_size)
|
||||
+ TxHandler(CephContext* const cct, CompressorRef compressor, int mode, uint64_t min_size)
|
||||
: Handler(cct, compressor),
|
||||
m_min_size(min_size),
|
||||
m_mode(static_cast<Compressor::CompressionMode>(mode))
|
||||
@@ -97,7 +97,7 @@
|
||||
static rxtx_t create_handler_pair(
|
||||
CephContext* ctx,
|
||||
const CompConnectionMeta& comp_meta,
|
||||
- std::uint64_t compress_min_size);
|
||||
+ uint64_t compress_min_size);
|
||||
};
|
||||
}
|
||||
|
||||
--- ceph-17.2.5/src/msg/async/crypto_onwire.h.orig 2023-01-17 07:35:35.535513714 -0500
|
||||
+++ ceph-17.2.5/src/msg/async/crypto_onwire.h 2023-01-17 07:35:46.578307452 -0500
|
||||
--- ceph-18.1.2/src/msg/async/crypto_onwire.h.orig 2023-06-27 15:59:59.000000000 -0400
|
||||
+++ ceph-18.1.2/src/msg/async/crypto_onwire.h 2023-07-04 19:36:55.957238704 -0400
|
||||
@@ -95,7 +95,7 @@
|
||||
// Transmitter can append extra bytes of ciphertext at the -final step.
|
||||
// This method return how much was added, and thus let client translate
|
||||
@ -40,69 +20,19 @@
|
||||
|
||||
// Instance of RxHandler must be reset before doing any decrypt-update
|
||||
// step. This applies also to situation when decrypt-final was already
|
||||
--- ceph-17.2.5/src/common/Cycles.h.orig 2023-01-17 07:56:19.787662012 -0500
|
||||
+++ ceph-17.2.5/src/common/Cycles.h 2023-01-17 07:56:57.852980655 -0500
|
||||
@@ -29,8 +29,9 @@
|
||||
*/
|
||||
|
||||
|
||||
-#ifndef CEPH_CYCLES_H
|
||||
-#define CEPH_CYCLES_H
|
||||
+#pragma once
|
||||
+
|
||||
+#include <cstdint>
|
||||
|
||||
/**
|
||||
* This class provides static methods that read the fine-grain CPU
|
||||
@@ -112,4 +113,3 @@
|
||||
}
|
||||
};
|
||||
|
||||
-#endif // CEPH_CYCLES_H
|
||||
--- ceph-17.2.5/src/test/librados/op_speed.cc.orig 2023-01-17 08:57:37.078531022 -0500
|
||||
+++ ceph-17.2.5/src/test/librados/op_speed.cc 2023-01-17 08:57:58.259139439 -0500
|
||||
@@ -9,7 +9,7 @@
|
||||
for (int i = 0; i < to_create; ++i) {
|
||||
librados::ObjectReadOperation op;
|
||||
bufferlist bl;
|
||||
- std::uint64_t sz;
|
||||
+ uint64_t sz;
|
||||
struct timespec tm;
|
||||
std::map<std::string, ceph::buffer::list> xattrs;
|
||||
std::map<std::string, ceph::buffer::list> omap;
|
||||
--- ceph-17.2.5/src/test/mon/test_log_rss_usage.cc.orig 2023-01-17 10:14:37.552820230 -0500
|
||||
+++ ceph-17.2.5/src/test/mon/test_log_rss_usage.cc 2023-01-17 10:15:12.319202506 -0500
|
||||
@@ -5,6 +5,7 @@
|
||||
#include <string>
|
||||
#include <iostream>
|
||||
#include <fstream>
|
||||
+#include <cstdint>
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
--- ceph-17.2.5/src/librbd/api/PoolMetadata.h.orig 2023-01-17 13:07:44.701750744 -0500
|
||||
+++ ceph-17.2.5/src/librbd/api/PoolMetadata.h 2023-01-17 13:08:10.300301845 -0500
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
#include <map>
|
||||
#include <string>
|
||||
+#include <cstdint>
|
||||
|
||||
namespace librbd {
|
||||
|
||||
--- ceph-17.2.6/src/rocksdb/table/block_based/data_block_hash_index.h.orig 2023-04-21 17:46:42.186339184 -0400
|
||||
+++ ceph-17.2.6/src/rocksdb/table/block_based/data_block_hash_index.h 2023-04-21 17:47:01.392005151 -0400
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
--- ceph-18.1.2/src/rocksdb/table/block_based/data_block_hash_index.h.orig 2023-05-24 15:55:23.000000000 -0400
|
||||
+++ ceph-18.1.2/src/rocksdb/table/block_based/data_block_hash_index.h 2023-07-04 19:36:55.971238469 -0400
|
||||
@@ -8,6 +8,7 @@
|
||||
#include <cstdint>
|
||||
#include <string>
|
||||
#include <vector>
|
||||
+#include <cstdint>
|
||||
|
||||
#include "rocksdb/slice.h"
|
||||
|
||||
--- ceph-17.2.6/src/rocksdb/util/string_util.h.orig 2023-04-21 18:13:51.060496792 -0400
|
||||
+++ ceph-17.2.6/src/rocksdb/util/string_util.h 2023-04-21 18:14:06.496223220 -0400
|
||||
@@ -10,6 +10,7 @@
|
||||
--- ceph-18.1.2/src/rocksdb/util/string_util.h.orig 2023-05-24 15:55:23.000000000 -0400
|
||||
+++ ceph-18.1.2/src/rocksdb/util/string_util.h 2023-07-04 19:36:55.991238133 -0400
|
||||
@@ -11,6 +11,7 @@
|
||||
#include <string>
|
||||
#include <unordered_map>
|
||||
#include <vector>
|
||||
|
15
ceph.spec
15
ceph.spec
@ -172,8 +172,8 @@
|
||||
# main package definition
|
||||
#################################################################################
|
||||
Name: ceph
|
||||
Version: 18.1.1
|
||||
Release: 0.2%{?dist}
|
||||
Version: 18.1.2
|
||||
Release: 0.1%{?dist}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
Epoch: 2
|
||||
%endif
|
||||
@ -201,8 +201,6 @@ Patch0017: 0017-gcc-12-omnibus.patch
|
||||
Patch0018: 0018-src-rgw-store-dbstore-CMakeLists.txt.patch
|
||||
Patch0020: 0020-src-arrow-cpp-cmake_modules-ThirdpartyToolchain.cmake.patch
|
||||
Patch0024: 0024-gcc-13.patch
|
||||
Patch0025: 0025-src-osd-scrubber-scrub_backend.h.patch
|
||||
Patch0026: 0026-src-osd-scrubber-scrub_backend.cc.patch
|
||||
Patch0029: 0029-src-rgw-rgw_amqp.cc.patch
|
||||
Patch0030: 0030-src-rgw-rgw_asio_client.cc.patch
|
||||
Patch0032: 0032-cmake-modules-BuildBoost.cmake.patch
|
||||
@ -1361,12 +1359,6 @@ export CFLAGS="$RPM_OPT_FLAGS"
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
export LDFLAGS="$RPM_LD_FLAGS"
|
||||
|
||||
# Workaround to https://tracker.ceph.com/issues/56610
|
||||
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
|
||||
export CFLAGS="$RPM_OPT_FLAGS -DFMT_DEPRECATED_OSTREAM"
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS -DFMT_DEPRECATED_OSTREAM"
|
||||
%endif
|
||||
|
||||
%if 0%{with seastar}
|
||||
# seastar uses longjmp() to implement coroutine. and this annoys longjmp_chk()
|
||||
export CXXFLAGS=$(echo $RPM_OPT_FLAGS | sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g')
|
||||
@ -2645,6 +2637,9 @@ exit 0
|
||||
%{_datadir}/snmp/mibs
|
||||
|
||||
%changelog
|
||||
* Fri Jun 30 2023 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:18.1.2-0.1
|
||||
- ceph-18.1.2 RC3
|
||||
|
||||
* Sun Jun 18 2023 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:18.1.1-0.2
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ceph-18.1.1.tar.gz) = 6becab524630c96c12433bac69eaeb3f020e7f4221a5079bef30d1fa4793b97af75d0a58b77750a280a904f87301d7dee8d7feb5fc3be578ab694981c8b1aed1
|
||||
SHA512 (ceph-18.1.2.tar.gz) = e197036d2b5d89b987a5b16b7ee2e976c8efaeec52f6e6fa07e419fe43f5d9b313029f4a3d3f2371e97a1fc36e6c63b0af698f7689055328e7de9263fe98f9d8
|
||||
|
Loading…
Reference in New Issue
Block a user