libblk.so -> libblk.a
libneoradostest-support.so -> libneoradostest-support.a w/ liburing-devel, -DWITH_SYSTEM_LIBURING w/ rocksdb-devel, -DWITH_SYSTEM_LIBURING Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
59dc7d2595
commit
3d9c93f7ab
11
0006-src-blk-CMakeLists.txt.patch
Normal file
11
0006-src-blk-CMakeLists.txt.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
|
||||
@@ -25,7 +25,7 @@
|
||||
zoned/HMSMRDevice.cc)
|
||||
endif()
|
||||
|
||||
-add_library(blk ${libblk_srcs})
|
||||
+add_library(blk STATIC ${libblk_srcs})
|
||||
target_include_directories(blk PRIVATE "./")
|
||||
|
||||
if(HAVE_LIBAIO)
|
@ -1,64 +0,0 @@
|
||||
--- ceph-15.2.8/src/rgw/rgw_asio_frontend.cc.orig 2020-12-16 12:29:50.000000000 -0500
|
||||
+++ ceph-15.2.8/src/rgw/rgw_asio_frontend.cc 2021-01-04 18:20:49.156104233 -0500
|
||||
@@ -2,6 +2,7 @@
|
||||
// vim: ts=8 sw=2 smarttab ft=cpp
|
||||
|
||||
#include <atomic>
|
||||
+#include <ctime>
|
||||
#include <thread>
|
||||
#include <vector>
|
||||
|
||||
@@ -138,6 +139,29 @@
|
||||
return out << h.quote << p->value() << h.quote;
|
||||
}
|
||||
|
||||
+// log fractional seconds in milliseconds
|
||||
+struct log_ms_remainder {
|
||||
+ ceph::coarse_real_time t;
|
||||
+ log_ms_remainder(ceph::coarse_real_time t) : t(t) {}
|
||||
+};
|
||||
+std::ostream& operator<<(std::ostream& out, const log_ms_remainder& m) {
|
||||
+ using namespace std::chrono;
|
||||
+ return out << std::setfill('0') << std::setw(3)
|
||||
+ << duration_cast<milliseconds>(m.t.time_since_epoch()).count() % 1000;
|
||||
+}
|
||||
+
|
||||
+// log time in apache format: day/month/year:hour:minute:second zone
|
||||
+struct log_apache_time {
|
||||
+ ceph::coarse_real_time t;
|
||||
+ log_apache_time(ceph::coarse_real_time t) : t(t) {}
|
||||
+};
|
||||
+std::ostream& operator<<(std::ostream& out, const log_apache_time& a) {
|
||||
+ const auto t = ceph::coarse_real_clock::to_time_t(a.t);
|
||||
+ const auto local = std::localtime(&t);
|
||||
+ return out << std::put_time(local, "%d/%b/%Y:%T.") << log_ms_remainder{a.t}
|
||||
+ << std::put_time(local, " %z");
|
||||
+};
|
||||
+
|
||||
using SharedMutex = ceph::async::SharedMutex<boost::asio::io_context::executor_type>;
|
||||
|
||||
template <typename Stream>
|
||||
@@ -228,16 +252,20 @@
|
||||
RGWRestfulIO client(cct, &real_client_io);
|
||||
auto y = optional_yield{context, yield};
|
||||
int http_ret = 0;
|
||||
+ string user = "-";
|
||||
+ const auto started = ceph::coarse_real_clock::now();
|
||||
+
|
||||
process_request(env.store, env.rest, &req, env.uri_prefix,
|
||||
*env.auth_registry, &client, env.olog, y,
|
||||
scheduler, &http_ret);
|
||||
|
||||
if (cct->_conf->subsys.should_gather(dout_subsys, 1)) {
|
||||
// access log line elements begin per Apache Combined Log Format with additions following
|
||||
- const auto now = ceph::coarse_real_clock::now();
|
||||
- using ceph::operator<<; // for coarse_real_time
|
||||
+ // const auto now = ceph::coarse_real_clock::now();
|
||||
+ // using ceph::operator<<; // for coarse_real_time
|
||||
ldout(cct, 1) << "beast: " << hex << &req << dec << ": "
|
||||
- << remote_endpoint.address() << " - - [" << now << "] \""
|
||||
+ // << remote_endpoint.address() << " - - [" << now << "] \""
|
||||
+ << remote_endpoint.address() << " - " << user << " [" << log_apache_time{started} << "] \""
|
||||
<< message.method_string() << ' ' << message.target() << ' '
|
||||
<< http_version{message.version()} << "\" " << http_ret << ' '
|
||||
<< client.get_bytes_sent() + client.get_bytes_received() << ' '
|
11
0007-src-test-neorados-CMakeLists.txt.patch
Normal file
11
0007-src-test-neorados-CMakeLists.txt.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt.orig 2021-02-01 08:25:18.006965821 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/src/test/neorados/CMakeLists.txt 2021-02-01 08:25:34.244407147 -0500
|
||||
@@ -19,7 +19,7 @@
|
||||
target_link_libraries(ceph_test_neorados_op_speed
|
||||
libneorados fmt::fmt ${unittest_libs})
|
||||
|
||||
-add_library(neoradostest-support common_tests.cc)
|
||||
+add_library(neoradostest-support STATIC common_tests.cc)
|
||||
target_link_libraries(neoradostest-support
|
||||
libneorados fmt::fmt)
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- ceph-15.2.8/src/tools/rbd/action/Bench.cc.orig 2021-01-25 17:08:06.189223814 -0500
|
||||
+++ ceph-15.2.8/src/tools/rbd/action/Bench.cc 2021-01-25 17:08:27.297805754 -0500
|
||||
@@ -10,6 +10,7 @@
|
||||
#include "include/types.h"
|
||||
#include "global/signal_handler.h"
|
||||
#include <iostream>
|
||||
+#include <atomic>
|
||||
#include <boost/accumulators/accumulators.hpp>
|
||||
#include <boost/accumulators/statistics/stats.hpp>
|
||||
#include <boost/accumulators/statistics/rolling_sum.hpp>
|
11
0008-cmake-modules-Finduring.cmake.patch
Normal file
11
0008-cmake-modules-Finduring.cmake.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake.orig 2021-02-01 08:45:39.316108287 -0500
|
||||
+++ ceph-16.1.0-43-g6b74fb5c/cmake/modules/Finduring.cmake 2021-02-01 08:45:59.813665378 -0500
|
||||
@@ -5,7 +5,7 @@
|
||||
# uring_FOUND - True if uring found.
|
||||
|
||||
find_path(URING_INCLUDE_DIR liburing.h)
|
||||
-find_library(URING_LIBRARIES liburing.a liburing)
|
||||
+find_library(URING_LIBRARIES liburing.so liburing)
|
||||
|
||||
include(FindPackageHandleStandardArgs)
|
||||
find_package_handle_standard_args(uring DEFAULT_MSG URING_LIBRARIES URING_INCLUDE_DIR)
|
15
ceph.spec
15
ceph.spec
@ -113,7 +113,7 @@
|
||||
#################################################################################
|
||||
Name: ceph
|
||||
Version: 16.1.0
|
||||
Release: 0.1.snapshot%{?dist}
|
||||
Release: 0.2.snapshot%{?dist}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
Epoch: 2
|
||||
%endif
|
||||
@ -137,6 +137,9 @@ Patch0002: 0002-src-common-CMakeLists.txt.patch
|
||||
Patch0003: 0003-src-common-bitstr.h.patch
|
||||
Patch0004: 0004-src-CMakeLists.txt.patch
|
||||
Patch0005: 0005-src-librbd-migration.patch
|
||||
Patch0006: 0006-src-blk-CMakeLists.txt.patch
|
||||
Patch0007: 0007-src-test-neorados-CMakeLists.txt.patch
|
||||
Patch0008: 0008-cmake-modules-Finduring.cmake.patch
|
||||
Source1: cmake-modules-BuildBoost.cmake.noautopatch
|
||||
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
|
||||
ExcludeArch: i686 armv7hl
|
||||
@ -165,6 +168,8 @@ BuildRequires: cmake > 3.5
|
||||
BuildRequires: cryptsetup
|
||||
BuildRequires: fuse3-devel
|
||||
BuildRequires: fmt-devel
|
||||
BuildRequires: rocksdb-devel
|
||||
BuildRequires: liburing-devel
|
||||
%if 0%{?rhel} == 7
|
||||
# devtoolset offers newer make and valgrind-devel, but the old ones are good
|
||||
# enough.
|
||||
@ -1268,6 +1273,8 @@ cd build
|
||||
-DWITH_OCF=ON \
|
||||
%endif
|
||||
-DWITH_REENTRANT_STRSIGNAL=ON \
|
||||
-DWITH_SYSTEM_ROCKSDB=ON \
|
||||
-DWITH_SYSTEM_LIBURING=ON \
|
||||
-DWITH_SYSTEM_BOOST=ON \
|
||||
%if 0%{with cephfs_shell}
|
||||
-DWITH_CEPHFS_SHELL=ON \
|
||||
@ -2415,6 +2422,12 @@ exit 0
|
||||
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
|
||||
|
||||
%changelog
|
||||
* Mon Feb 1 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:16.1.0-0.2.snapshot
|
||||
- libblk.so -> libblk.a
|
||||
- libneoradostest-support.so -> libneoradostest-support.a
|
||||
- w/ liburing-devel, -DWITH_SYSTEM_LIBURING
|
||||
- w/ rocksdb-devel, -DWITH_SYSTEM_LIBURING
|
||||
|
||||
* Fri Jan 29 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:16.1.0-0.1.snapshot
|
||||
- ceph 16.1.0 RC (ceph-16.1.0-43-g6b74fb5c)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user