New release (1:10.2.2-2)
- fix tcmalloc handling in spec file
This commit is contained in:
parent
dadf49c482
commit
20b0b2e68e
57
0003-fix-tcmalloc-handling-in-spec-file.patch
Normal file
57
0003-fix-tcmalloc-handling-in-spec-file.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
From ff336b26b9d694a59141064ad76e652ecb090882 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Fri, 6 May 2016 13:29:03 +0200
|
||||||
|
Subject: [PATCH] fix tcmalloc handling in spec file
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
- there is no gperftools/tcmalloc on s390(x) yet
|
||||||
|
- explicitly disable tcmalloc when built without
|
||||||
|
|
||||||
|
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||||
|
---
|
||||||
|
ceph.spec.in | 11 ++++++++++-
|
||||||
|
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ceph.spec.in b/ceph.spec.in
|
||||||
|
index 3cf6307..c122fa7 100644
|
||||||
|
--- a/ceph.spec.in
|
||||||
|
+++ b/ceph.spec.in
|
||||||
|
@@ -18,7 +18,12 @@
|
||||||
|
%bcond_without cephfs_java
|
||||||
|
%bcond_with tests
|
||||||
|
%bcond_with xio
|
||||||
|
+%ifnarch s390 s390x
|
||||||
|
%bcond_without tcmalloc
|
||||||
|
+%else
|
||||||
|
+# no gperftools/tcmalloc on s390(x)
|
||||||
|
+%bcond_with tcmalloc
|
||||||
|
+%endif
|
||||||
|
%bcond_without libs_compat
|
||||||
|
%bcond_with lowmem_builder
|
||||||
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
|
@@ -137,7 +142,9 @@ BuildRequires: btrfs-progs
|
||||||
|
BuildRequires: nss-devel
|
||||||
|
BuildRequires: keyutils-libs-devel
|
||||||
|
BuildRequires: libatomic_ops-devel
|
||||||
|
+%if 0%{with tcmalloc}
|
||||||
|
BuildRequires: gperftools-devel
|
||||||
|
+%endif
|
||||||
|
BuildRequires: openldap-devel
|
||||||
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: redhat-lsb-core
|
||||||
|
@@ -660,7 +667,9 @@ export RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed -e 's/i386/i486/'`
|
||||||
|
%endif
|
||||||
|
$CEPH_EXTRA_CONFIGURE_ARGS \
|
||||||
|
%{?_with_ocf} \
|
||||||
|
- %{?_with_tcmalloc} \
|
||||||
|
+%if %{without tcmalloc}
|
||||||
|
+ --without-tcmalloc \
|
||||||
|
+%endif
|
||||||
|
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
|
%if %{with lowmem_builder}
|
||||||
|
--
|
||||||
|
2.7.4
|
||||||
|
|
14
ceph.spec
14
ceph.spec
@ -55,7 +55,7 @@
|
|||||||
#################################################################################
|
#################################################################################
|
||||||
Name: ceph
|
Name: ceph
|
||||||
Version: 10.2.2
|
Version: 10.2.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: User space components of the Ceph file system
|
Summary: User space components of the Ceph file system
|
||||||
License: LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT
|
License: LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT
|
||||||
@ -66,6 +66,7 @@ URL: http://ceph.com/
|
|||||||
Source0: http://ceph.com/download/%{name}-%{version}.tar.gz
|
Source0: http://ceph.com/download/%{name}-%{version}.tar.gz
|
||||||
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
|
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
|
||||||
Patch2: 0002-Do-not-use-momit-leaf-frame-pointer-flag.patch
|
Patch2: 0002-Do-not-use-momit-leaf-frame-pointer-flag.patch
|
||||||
|
Patch3: 0003-fix-tcmalloc-handling-in-spec-file.patch
|
||||||
#################################################################################
|
#################################################################################
|
||||||
# dependencies that apply across all distro families
|
# dependencies that apply across all distro families
|
||||||
#################################################################################
|
#################################################################################
|
||||||
@ -146,7 +147,9 @@ BuildRequires: btrfs-progs
|
|||||||
BuildRequires: nss-devel
|
BuildRequires: nss-devel
|
||||||
BuildRequires: keyutils-libs-devel
|
BuildRequires: keyutils-libs-devel
|
||||||
BuildRequires: libatomic_ops-devel
|
BuildRequires: libatomic_ops-devel
|
||||||
|
%if 0%{with tcmalloc}
|
||||||
BuildRequires: gperftools-devel
|
BuildRequires: gperftools-devel
|
||||||
|
%endif
|
||||||
BuildRequires: openldap-devel
|
BuildRequires: openldap-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: redhat-lsb-core
|
BuildRequires: redhat-lsb-core
|
||||||
@ -623,6 +626,7 @@ python-cephfs instead.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{with cephfs_java}
|
%if 0%{with cephfs_java}
|
||||||
@ -675,7 +679,9 @@ export RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed -e 's/-g /-g1 /'`
|
|||||||
%endif
|
%endif
|
||||||
$CEPH_EXTRA_CONFIGURE_ARGS \
|
$CEPH_EXTRA_CONFIGURE_ARGS \
|
||||||
%{?_with_ocf} \
|
%{?_with_ocf} \
|
||||||
%{?_with_tcmalloc} \
|
%if %{without tcmalloc}
|
||||||
|
--without-tcmalloc \
|
||||||
|
%endif
|
||||||
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
|
||||||
%if %{with lowmem_builder}
|
%if %{with lowmem_builder}
|
||||||
@ -1529,6 +1535,10 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 21 2016 Boris Ranto <branto@redhat.com> - 1:10.2.2-2
|
||||||
|
- New release (1:10.2.2-2)
|
||||||
|
- fix tcmalloc handling in spec file
|
||||||
|
|
||||||
* Mon Jun 20 2016 Boris Ranto <branto@redhat.com> - 1:10.2.2-1
|
* Mon Jun 20 2016 Boris Ranto <branto@redhat.com> - 1:10.2.2-1
|
||||||
- New version (1:10.2.2-1)
|
- New version (1:10.2.2-1)
|
||||||
- Disable erasure_codelib neon build
|
- Disable erasure_codelib neon build
|
||||||
|
Loading…
Reference in New Issue
Block a user