Update to 0.44
Signed-off-by: Jonathan Dieter <jdieter@lesbg.com>
This commit is contained in:
parent
b003ada4bc
commit
0f5f195c33
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ ceph-0.20.tar.gz
|
||||
/ceph-0.37.tar.gz
|
||||
/ceph-0.39.tar.gz
|
||||
/ceph-0.43.tar.bz2
|
||||
/ceph-0.44.tar.bz2
|
||||
|
@ -0,0 +1,52 @@
|
||||
From d3bcac241f25f681a585c2115a79befe43dd7d6c Mon Sep 17 00:00:00 2001
|
||||
From: Jim Schutt <jaschut@sandia.gov>
|
||||
Date: Wed, 21 Mar 2012 10:09:09 -0600
|
||||
Subject: [PATCH] Makefile: fix modules that cannot find pk11pub.h when
|
||||
compiling with NSS on RHEL6
|
||||
|
||||
Signed-off-by: Jim Schutt <jaschut@sandia.gov>
|
||||
Signed-off-by: Sage Weil <sage.weil@dreamhost.com>
|
||||
---
|
||||
src/Makefile.am | 5 ++++-
|
||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index a6e6a95..80802bc 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -48,7 +48,7 @@ if LINUX
|
||||
ceph_osd_LDADD += -ldl
|
||||
endif
|
||||
bin_PROGRAMS += ceph-osd
|
||||
-ceph_osd_CXXFLAGS = ${AM_CXXFLAGS} \
|
||||
+ceph_osd_CXXFLAGS = ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS} \
|
||||
-I$(top_srcdir)/src/leveldb/include
|
||||
|
||||
# mds
|
||||
@@ -111,6 +111,7 @@ osdmaptool_LDADD = $(LIBGLOBAL_LDA)
|
||||
bin_PROGRAMS += monmaptool crushtool osdmaptool
|
||||
|
||||
ceph_dencoder_SOURCES = test/encoding/ceph_dencoder.cc
|
||||
+ceph_dencoder_CXXFLAGS = ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
ceph_dencoder_LDADD = $(LIBGLOBAL_LDA) libosd.la libmds.a libos.la libmon.la
|
||||
bin_PROGRAMS += ceph-dencoder
|
||||
|
||||
@@ -1002,6 +1003,7 @@ libmon_la_SOURCES = \
|
||||
mon/AuthMonitor.cc \
|
||||
mon/Elector.cc \
|
||||
mon/MonitorStore.cc
|
||||
+libmon_la_CXXFLAGS= ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
libmon_la_LIBADD = libglobal.la
|
||||
noinst_LTLIBRARIES += libmon.la
|
||||
|
||||
@@ -1070,6 +1072,7 @@ libosdc_la_SOURCES = \
|
||||
osdc/ObjectCacher.cc \
|
||||
osdc/Filer.cc \
|
||||
osdc/Journaler.cc
|
||||
+libosdc_la_CXXFLAGS= ${CRYPTO_CXXFLAGS} ${AM_CXXFLAGS}
|
||||
libosdc_la_LIBADD = libcommon.la
|
||||
noinst_LTLIBRARIES += libosdc.la
|
||||
|
||||
--
|
||||
1.7.7.6
|
||||
|
22
ceph.spec
22
ceph.spec
@ -1,6 +1,6 @@
|
||||
Name: ceph
|
||||
Version: 0.43
|
||||
Release: 1%{?dist}
|
||||
Version: 0.44
|
||||
Release: 2%{?dist}
|
||||
Summary: User space components of the Ceph file system
|
||||
License: LGPLv2
|
||||
Group: System Environment/Base
|
||||
@ -9,6 +9,10 @@ URL: http://ceph.newdream.net/
|
||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: ceph-init-fix.patch
|
||||
Patch1: ceph.logrotate.patch
|
||||
|
||||
# Upstream patch to make 0.44 build
|
||||
Patch2: 0001-Makefile-fix-modules-that-cannot-find-pk11pub.h-when.patch
|
||||
|
||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
|
||||
# google-perftools is not available on these:
|
||||
@ -80,6 +84,7 @@ file system.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .init
|
||||
%patch1 -p0
|
||||
%patch2 -p1 -b .build
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -88,8 +93,10 @@ file system.
|
||||
%ifarch ppc64 s390 s390x
|
||||
--without-tcmalloc \
|
||||
%endif
|
||||
--without-hadoop --with-radosgw --with-gtk2
|
||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
--without-hadoop --with-radosgw --with-gtk2 \
|
||||
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -238,6 +245,13 @@ fi
|
||||
%{_bindir}/boto_tool
|
||||
|
||||
%changelog
|
||||
* Mon Mar 26 2012 Jonathan Dieter <jdieter@lesbg.com> - 0.44-3
|
||||
- Remove unneeded patch
|
||||
|
||||
* Sun Mar 25 2012 Jonathan Dieter <jdieter@lesbg.com> - 0.44-2
|
||||
- Update to 0.44
|
||||
- Fix build problems
|
||||
|
||||
* Mon Mar 5 2012 Jonathan Dieter <jdieter@lesbg.com> - 0.43-1
|
||||
- Update to 0.43
|
||||
- Remove upstreamed compile fixes patch
|
||||
|
Loading…
Reference in New Issue
Block a user