- fixed rhbz#255001 - icedax --devices segfaults
- fixed rhbz#249357 - Typo in wodim output
This commit is contained in:
parent
3baa22c4fd
commit
f7323e4f81
10
cdrkit.spec
10
cdrkit.spec
@ -1,13 +1,15 @@
|
|||||||
Summary: A collection of CD/DVD utilities
|
Summary: A collection of CD/DVD utilities
|
||||||
Name: cdrkit
|
Name: cdrkit
|
||||||
Version: 1.1.6
|
Version: 1.1.6
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://cdrkit.org/
|
URL: http://cdrkit.org/
|
||||||
Source: http://debburn.alioth.debian.org/cdrkit-%{version}.tar.gz
|
Source: http://debburn.alioth.debian.org/cdrkit-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: genisoimage-dlength.patch
|
Patch1: genisoimage-dlength.patch
|
||||||
|
Patch2: icedax-segfault.patch
|
||||||
|
Patch3: wodim-prtypo.patch
|
||||||
|
|
||||||
BuildRequires: cmake libcap-devel zlib-devel perl
|
BuildRequires: cmake libcap-devel zlib-devel perl
|
||||||
|
|
||||||
@ -69,6 +71,8 @@ rates. Icedax can also be used as a CD player.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .dlength
|
%patch1 -p1 -b .dlength
|
||||||
|
%patch2 -p1 -b .segf
|
||||||
|
%patch3 -p1 -b .prtypo
|
||||||
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
||||||
find doc -type f -print0 | xargs -0 chmod a-x
|
find doc -type f -print0 | xargs -0 chmod a-x
|
||||||
|
|
||||||
@ -205,6 +209,10 @@ fi
|
|||||||
%{_mandir}/man1/readmult.*
|
%{_mandir}/man1/readmult.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
|
||||||
|
- fixed rhbz#255001 - icedax --devices segfaults
|
||||||
|
- fixed rhbz#249357 - Typo in wodim output
|
||||||
|
|
||||||
* Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
|
* Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
|
||||||
- play stupid tricks, to let alternatives make the links and
|
- play stupid tricks, to let alternatives make the links and
|
||||||
rpm not removing them afterwards
|
rpm not removing them afterwards
|
||||||
|
27
icedax-segfault.patch
Normal file
27
icedax-segfault.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
--- cdrkit-1.1.6/icedax/interface.c.segf 2007-09-21 10:34:36.000000000 +0200
|
||||||
|
+++ cdrkit-1.1.6/icedax/interface.c 2007-09-21 10:35:10.000000000 +0200
|
||||||
|
@@ -611,12 +611,6 @@ static int OpenCdRom(char *pdev_name)
|
||||||
|
usal_help(stderr);
|
||||||
|
exit(NO_ERROR);
|
||||||
|
}
|
||||||
|
-
|
||||||
|
- if (global.scandevs) {
|
||||||
|
- list_devices(usalp, stdout, 0);
|
||||||
|
- exit(0);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
/* device name, debug, verboseopen */
|
||||||
|
usalp = usal_open(pdev_name, errstr, sizeof(errstr), 0, 0);
|
||||||
|
|
||||||
|
@@ -661,6 +655,11 @@ static int OpenCdRom(char *pdev_name)
|
||||||
|
dontneedgroup();
|
||||||
|
dontneedroot();
|
||||||
|
|
||||||
|
+ if (global.scandevs) {
|
||||||
|
+ list_devices(usalp, stdout, 0);
|
||||||
|
+ exit(0);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (global.scanbus) {
|
||||||
|
select_target(usalp, stdout);
|
||||||
|
exit(0);
|
11
wodim-prtypo.patch
Normal file
11
wodim-prtypo.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- cdrkit-1.1.6/wodim/wodim.c.prtypo 2007-09-21 11:06:50.000000000 +0200
|
||||||
|
+++ cdrkit-1.1.6/wodim/wodim.c 2007-09-21 11:06:50.000000000 +0200
|
||||||
|
@@ -1485,7 +1485,7 @@ gracewait(cdr_t *dp, BOOL *didgracep)
|
||||||
|
printf("No chance to quit anymore.");
|
||||||
|
goto grace_done;
|
||||||
|
}
|
||||||
|
- printf("Last chance to quit, starting %s write in %d seconds.",
|
||||||
|
+ printf("Last chance to quit, starting %s write in %4d seconds.",
|
||||||
|
(dp->cdr_cmdflags & F_DUMMY)?"dummy":"real", gracetime);
|
||||||
|
flush();
|
||||||
|
signal(SIGINT, intr);
|
Loading…
Reference in New Issue
Block a user