Build libusal as a shared library
This commit is contained in:
parent
8b7640bda6
commit
d3ea117d8b
@ -1,18 +1,33 @@
|
|||||||
diff -up cdrkit-1.1.11/librols/CMakeLists.txt.usalinst cdrkit-1.1.11/librols/CMakeLists.txt
|
diff -up cdrkit-1.1.11/librols/CMakeLists.txt.usalinst cdrkit-1.1.11/librols/CMakeLists.txt
|
||||||
--- cdrkit-1.1.11/librols/CMakeLists.txt.usalinst 2011-02-24 13:55:02.039474881 +0100
|
--- cdrkit-1.1.11/librols/CMakeLists.txt.usalinst 2012-07-31 10:51:30.270669381 +0200
|
||||||
+++ cdrkit-1.1.11/librols/CMakeLists.txt 2011-02-24 13:55:25.077176945 +0100
|
+++ cdrkit-1.1.11/librols/CMakeLists.txt 2012-07-31 10:52:02.365378257 +0200
|
||||||
@@ -5,3 +5,5 @@ SET(LIBROLS_SRCS astoi.c astoll.c astou
|
@@ -3,5 +3,11 @@ INCLUDE_DIRECTORIES(../include ../libhfs
|
||||||
|
|
||||||
ADD_LIBRARY (rols STATIC ${CMAKE_CURRENT_SOURCE_DIR}/../include/xconfig.h ${CMAKE_CURRENT_SOURCE_DIR}/../include/align.h ${LIBROLS_SRCS})
|
SET(LIBROLS_SRCS astoi.c astoll.c astoull.c breakline.c cmpbytes.c comerr.c error.c fexec.c fillbytes.c getargs.c getav0.c getdomainname.c geterrno.c gethostid.c gethostname.c getpagesize.c handlecond.c movebytes.c raisecond.c rename.c saveargs.c seterrno.c spawn.c strcatl.c strdup.c streql.c swabbytes.c usleep.c stdio/cvmod.c stdio/dat.c stdio/fcons.c stdio/fdown.c stdio/fdup.c stdio/ffileread.c stdio/ffilewrite.c stdio/fgetline.c stdio/file_raise.c stdio/fileclose.c stdio/fileluopen.c stdio/filemopen.c stdio/fileopen.c stdio/filepos.c stdio/fileread.c stdio/filereopen.c stdio/fileseek.c stdio/filesize.c stdio/filestat.c stdio/filewrite.c stdio/flag.c stdio/flush.c stdio/fpipe.c stdio/niread.c stdio/niwrite.c stdio/nixread.c stdio/nixwrite.c stdio/openfd.c stdio/peekc.c default.c)
|
||||||
|
|
||||||
+INSTALL(TARGETS rols DESTINATION lib${LIB_SUFFIX})
|
-ADD_LIBRARY (rols STATIC ${CMAKE_CURRENT_SOURCE_DIR}/../include/xconfig.h ${CMAKE_CURRENT_SOURCE_DIR}/../include/align.h ${LIBROLS_SRCS})
|
||||||
|
+ADD_LIBRARY (rols SHARED ${CMAKE_CURRENT_SOURCE_DIR}/../include/xconfig.h ${CMAKE_CURRENT_SOURCE_DIR}/../include/align.h ${LIBROLS_SRCS})
|
||||||
|
+SET_TARGET_PROPERTIES(rols PROPERTIES
|
||||||
|
+ VERSION 0.0.1
|
||||||
|
+ SOVERSION 0
|
||||||
|
+)
|
||||||
+
|
+
|
||||||
|
+INSTALL(TARGETS rols DESTINATION lib${LIB_SUFFIX})
|
||||||
|
|
||||||
diff -up cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst cdrkit-1.1.11/libusal/CMakeLists.txt
|
diff -up cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst cdrkit-1.1.11/libusal/CMakeLists.txt
|
||||||
--- cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst 2011-02-24 13:53:45.432139117 +0100
|
--- cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst 2012-07-31 10:51:30.302670085 +0200
|
||||||
+++ cdrkit-1.1.11/libusal/CMakeLists.txt 2011-02-24 13:53:45.438139303 +0100
|
+++ cdrkit-1.1.11/libusal/CMakeLists.txt 2012-07-31 10:52:09.190528942 +0200
|
||||||
@@ -8,3 +8,5 @@ SET(LIBSCG_SRCS usalsettarget.c usaltime
|
@@ -6,5 +6,12 @@ ADD_DEFINITIONS(-DUSE_RCMD_RSH)
|
||||||
|
#SET(LIBSCG_SRCS rdummy.c usalsettarget.c usaltimes.c scsi-linux-ata.c scsi-linux-pg.c scsi-linux-sg.c scsierrs.c scsihack.c scsihelp.c scsiopen.c scsitransp.c)
|
||||||
|
SET(LIBSCG_SRCS usalsettarget.c usaltimes.c scsierrs.c scsihack.c scsihelp.c scsiopen.c scsitransp.c scsi-remote.c)
|
||||||
LINK_DIRECTORIES(../librols)
|
LINK_DIRECTORIES(../librols)
|
||||||
ADD_LIBRARY (usal STATIC ${LIBSCG_SRCS})
|
-ADD_LIBRARY (usal STATIC ${LIBSCG_SRCS})
|
||||||
|
+ADD_LIBRARY (usal SHARED ${LIBSCG_SRCS})
|
||||||
|
+
|
||||||
TARGET_LINK_LIBRARIES(usal ${SCG_SELF_LIBS})
|
TARGET_LINK_LIBRARIES(usal ${SCG_SELF_LIBS})
|
||||||
|
+SET_TARGET_PROPERTIES(usal PROPERTIES
|
||||||
|
+ VERSION 0.0.1
|
||||||
|
+ SOVERSION 0
|
||||||
|
+)
|
||||||
+INSTALL(TARGETS usal DESTINATION lib${LIB_SUFFIX})
|
+INSTALL(TARGETS usal DESTINATION lib${LIB_SUFFIX})
|
||||||
+INSTALL(FILES usal/scsicdb.h usal/aspi-dos.h usal/usalcmd.h usal/usalio.h usal/scsireg.h usal/usalops.h usal/scsidefs.h usal/spti-wnt.h usal/srb_os2.h usal/scsitransp.h usal/aspi-win32.h usal/scsisense.h usaltimes.h pg.h DESTINATION include/usal)
|
+INSTALL(FILES usal/scsicdb.h usal/aspi-dos.h usal/usalcmd.h usal/usalio.h usal/scsireg.h usal/usalops.h usal/scsidefs.h usal/spti-wnt.h usal/srb_os2.h usal/scsitransp.h usal/aspi-win32.h usal/scsisense.h usaltimes.h pg.h DESTINATION include/usal)
|
||||||
|
33
cdrkit.spec
33
cdrkit.spec
@ -37,6 +37,7 @@ Obsoletes: dvdrecord <= 0:0.1.5
|
|||||||
Provides: dvdrecord = 0:0.1.5.1
|
Provides: dvdrecord = 0:0.1.5.1
|
||||||
Obsoletes: cdrecord < 9:2.01-12
|
Obsoletes: cdrecord < 9:2.01-12
|
||||||
Provides: cdrecord = 9:2.01-12
|
Provides: cdrecord = 9:2.01-12
|
||||||
|
Requires: libusal = %{version}-%{release}
|
||||||
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
|
|
||||||
@ -50,6 +51,7 @@ Summary: Creates an image of an ISO9660 file system
|
|||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Obsoletes: mkisofs < 9:2.01-12
|
Obsoletes: mkisofs < 9:2.01-12
|
||||||
Provides: mkisofs = 9:2.01-12
|
Provides: mkisofs = 9:2.01-12
|
||||||
|
Requires: libusal = %{version}-%{release}
|
||||||
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
|
|
||||||
@ -79,6 +81,7 @@ Group: Applications/Multimedia
|
|||||||
Summary: A utility for sampling/copying .wav files from digital audio CDs
|
Summary: A utility for sampling/copying .wav files from digital audio CDs
|
||||||
Obsoletes: cdda2wav < 9:2.01-12
|
Obsoletes: cdda2wav < 9:2.01-12
|
||||||
Provides: cdda2wav = 9:2.01-12
|
Provides: cdda2wav = 9:2.01-12
|
||||||
|
Requires: libusal = %{version}-%{release}
|
||||||
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
Requires: vorbis-tools
|
Requires: vorbis-tools
|
||||||
@ -90,16 +93,24 @@ read from the CD can be saved as .wav or .sun format sound files.
|
|||||||
Recording formats include stereo/mono, 8/12/16 bits and different
|
Recording formats include stereo/mono, 8/12/16 bits and different
|
||||||
rates. Icedax can also be used as a CD player.
|
rates. Icedax can also be used as a CD player.
|
||||||
|
|
||||||
|
%package -n libusal
|
||||||
|
Summary: Library to communicate with SCSI devices
|
||||||
|
Group: Development/Libraries
|
||||||
|
|
||||||
|
%description -n libusal
|
||||||
|
The libusal package contains C libraries that allows applications
|
||||||
|
to communicate with SCSI devices and is well suitable for writing
|
||||||
|
CD-R media.
|
||||||
|
|
||||||
%package -n libusal-devel
|
%package -n libusal-devel
|
||||||
Summary: Development files for libusal
|
Summary: Development files for libusal
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Provides: libusal-static = %{version}-%{release}
|
Requires: libusal = %{version}-%{release}
|
||||||
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
|
||||||
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
|
||||||
|
|
||||||
%description -n libusal-devel
|
%description -n libusal-devel
|
||||||
The libusal-devel package contains libraries and header files
|
The libusal-devel package contains C libraries and header files
|
||||||
for developing applications that use libusal.
|
for developing applications that use libusal for communication with
|
||||||
|
SCSI devices.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
@ -267,16 +278,22 @@ fi
|
|||||||
%{_bindir}/dirsplit
|
%{_bindir}/dirsplit
|
||||||
%{_mandir}/man1/dirsplit.*
|
%{_mandir}/man1/dirsplit.*
|
||||||
|
|
||||||
%files -n libusal-devel
|
%files -n libusal
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc Changelog COPYING FAQ FORK START
|
%doc Changelog COPYING FAQ FORK START
|
||||||
%{_libdir}/libusal.a
|
%{_libdir}/libusal.so.*
|
||||||
%{_libdir}/librols.a
|
%{_libdir}/librols.so.*
|
||||||
|
|
||||||
|
%files -n libusal-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libusal.so
|
||||||
|
%{_libdir}/librols.so
|
||||||
%{_includedir}/usal
|
%{_includedir}/usal
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Jul 30 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-12
|
* Mon Jul 30 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-12
|
||||||
- Use system cdparanoia instead of old bundled version
|
- Use system cdparanoia instead of old bundled version
|
||||||
|
- Build libusal as a shared library
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-11
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-11
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user