From bc3599b77ad0e09a9453d89595aa588f1e1753f5 Mon Sep 17 00:00:00 2001
From: Frantisek Kluknavsky <fkluknav@redhat.com>
Date: Mon, 25 Feb 2013 12:45:24 +0100
Subject: [PATCH] modified the memset patch, memsetting the whole array

---
 cdrkit-1.1.11-memset.patch | 4 ++--
 cdrkit.spec                | 5 ++++-
 2 files changed, 6 insertions(+), 3 deletions(-)

diff --git a/cdrkit-1.1.11-memset.patch b/cdrkit-1.1.11-memset.patch
index 9e4c5d0..6609159 100644
--- a/cdrkit-1.1.11-memset.patch
+++ b/cdrkit-1.1.11-memset.patch
@@ -1,12 +1,12 @@
 diff -up wrk/genisoimage/jte.c.wrk wrk/genisoimage/jte.c
 --- wrk/genisoimage/jte.c.wrk	2013-02-22 13:24:47.722196877 +0100
-+++ wrk/genisoimage/jte.c	2013-02-22 13:31:50.967667591 +0100
++++ wrk/genisoimage/jte.c	2013-02-25 12:41:45.136653487 +0100
 @@ -280,7 +280,7 @@ extern int list_file_in_jigdo(char *file
      if (!jtemplate_out)
          return 0;
  
 -    memset(md5, 0, sizeof(md5));
-+    memset(md5, 0, sizeof(*md5));
++    memset(md5, 0, 16);
  
      /* Cheaper to check file size first */
      if (size < jte_min_size)
diff --git a/cdrkit.spec b/cdrkit.spec
index b8412b1..7835031 100644
--- a/cdrkit.spec
+++ b/cdrkit.spec
@@ -1,7 +1,7 @@
 Summary: A collection of CD/DVD utilities
 Name: cdrkit
 Version: 1.1.11
-Release: 16%{?dist}
+Release: 17%{?dist}
 License: GPLv2
 Group: Applications/System
 URL: http://cdrkit.org/
@@ -292,6 +292,9 @@ fi
 %{_includedir}/usal
 
 %changelog
+* Mon Feb 25 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.1.11-17
+- modified the memset patch, memsetting the whole array
+
 * Fri Feb 22 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.1.11-16
 - changed or deleted faulty and unneeded memset's that caused build failure with gcc-4.8 -Werror