CMake chages according use of cdparanoia

This commit is contained in:
Honza Horák 2012-07-31 14:30:20 +02:00
parent e31ac12d92
commit 8dfe1e1262
3 changed files with 42 additions and 18 deletions

View File

@ -0,0 +1,9 @@
diff -up cdrkit-1.1.11/CMakeLists.txt.cmakewarn cdrkit-1.1.11/CMakeLists.txt
--- cdrkit-1.1.11/CMakeLists.txt.cmakewarn 2012-07-31 13:11:10.075500531 +0200
+++ cdrkit-1.1.11/CMakeLists.txt 2012-07-31 13:11:41.069108287 +0200
@@ -1,3 +1,5 @@
+cmake_minimum_required(VERSION 2.8)
+cmake_policy(SET CMP0015 OLD)
PROJECT (cdrkit C)
SUBDIRS(include genisoimage wodim libedc libhfs_iso icedax libusal librols libunls readom netscsid 3rd-party/dirsplit)

View File

@ -1,27 +1,39 @@
diff -up cdrkit-1.1.11/CMakeLists.txt.paranoiacdda cdrkit-1.1.11/CMakeLists.txt
--- cdrkit-1.1.11/CMakeLists.txt.paranoiacdda 2012-07-30 16:41:47.206743081 +0200
+++ cdrkit-1.1.11/CMakeLists.txt 2012-07-30 16:41:47.275743077 +0200
--- cdrkit-1.1.11/CMakeLists.txt.paranoiacdda 2012-07-31 14:27:15.166155309 +0200
+++ cdrkit-1.1.11/CMakeLists.txt 2012-07-31 14:27:28.469613175 +0200
@@ -1,3 +1,3 @@
PROJECT (cdrkit C)
-SUBDIRS(include genisoimage wodim libedc libhfs_iso libparanoia icedax libusal librols libunls readom netscsid 3rd-party/dirsplit)
+SUBDIRS(include genisoimage wodim libedc libhfs_iso icedax libusal librols libunls readom netscsid 3rd-party/dirsplit)
diff -up cdrkit-1.1.11/icedax/CMakeLists.txt.paranoiacdda cdrkit-1.1.11/icedax/CMakeLists.txt
--- cdrkit-1.1.11/icedax/CMakeLists.txt.paranoiacdda 2012-07-30 16:41:47.256743078 +0200
+++ cdrkit-1.1.11/icedax/CMakeLists.txt 2012-07-30 16:41:47.265743077 +0200
@@ -1,5 +1,5 @@
--- cdrkit-1.1.11/icedax/CMakeLists.txt.paranoiacdda 2012-07-31 14:27:15.228157411 +0200
+++ cdrkit-1.1.11/icedax/CMakeLists.txt 2012-07-31 14:27:15.239157786 +0200
@@ -1,8 +1,9 @@
PROJECT (icedax C)
-INCLUDE_DIRECTORIES(../include ../wodim ../libparanoia ${CMAKE_BINARY_DIR} ${CMAKE_BINARY_DIR}/include)
+INCLUDE_DIRECTORIES(../include ../wodim ${CMAKE_BINARY_DIR} ${CMAKE_BINARY_DIR}/include)
include(../include/AddScgBits.cmake)
include(../include/AddSchilyBits.cmake)
include(../include/AddNetworkBits.cmake)
@@ -18,12 +18,12 @@ IF(HAVE_LIBOSSAUDIO)
+INCLUDE (CheckLibraryExists)
FIND_FILE (HAVE_SYS_SOUNDCARD_H sys/soundcard.h)
IF(HAVE_SYS_SOUNDCARD_H)
@@ -18,12 +19,20 @@ IF(HAVE_LIBOSSAUDIO)
LIST(APPEND EXTRA_LIBS "ossaudio")
ENDIF(HAVE_LIBOSSAUDIO)
-LIST(APPEND EXTRA_LIBS paranoia)
+LIST(APPEND EXTRA_LIBS cdda_paranoia cdda_interface)
+CHECK_INCLUDE_FILES(cdda/cdda_interface.h HAVE_CDDA_INTERFACE_H)
+CHECK_LIBRARY_EXISTS (cdda_paranoia paranoia_init "" HAVE_LIBPARANOIA)
+IF(HAVE_CDDA_INTERFACE_H AND HAVE_LIBPARANOIA)
+ LIST(APPEND EXTRA_LIBS cdda_paranoia cdda_interface)
+ELSE(HAVE_CDDA_INTERFACE_H AND HAVE_LIBPARANOIA)
+ MESSAGE(FATAL_ERROR "You need cdparanoia library installed")
+ENDIF(HAVE_CDDA_INTERFACE_H AND HAVE_LIBPARANOIA)
+
+LIST(APPEND EXTRA_LIBS)
IF (WIN32)
LIST(APPEND EXTRA_LIBS winmm)
ENDIF (WIN32)
@ -32,8 +44,8 @@ diff -up cdrkit-1.1.11/icedax/CMakeLists.txt.paranoiacdda cdrkit-1.1.11/icedax/C
TARGET_LINK_LIBRARIES(icedax wodimstuff ${EXTRA_LIBS})
SET_TARGET_PROPERTIES(icedax PROPERTIES SKIP_BUILD_RPATH TRUE)
diff -up cdrkit-1.1.11/icedax/global.h.paranoiacdda cdrkit-1.1.11/icedax/global.h
--- cdrkit-1.1.11/icedax/global.h.paranoiacdda 2012-07-30 16:41:47.259743081 +0200
+++ cdrkit-1.1.11/icedax/global.h 2012-07-30 16:41:47.255743077 +0200
--- cdrkit-1.1.11/icedax/global.h.paranoiacdda 2012-07-31 14:27:15.232157548 +0200
+++ cdrkit-1.1.11/icedax/global.h 2012-07-31 14:27:15.226157345 +0200
@@ -17,7 +17,8 @@
#include "md5.h"
#endif
@ -60,8 +72,8 @@ diff -up cdrkit-1.1.11/icedax/global.h.paranoiacdda cdrkit-1.1.11/icedax/global.
int overlap;
int mindynoverlap;
diff -up cdrkit-1.1.11/icedax/icedax.c.paranoiacdda cdrkit-1.1.11/icedax/icedax.c
--- cdrkit-1.1.11/icedax/icedax.c.paranoiacdda 2012-07-30 16:41:47.263743078 +0200
+++ cdrkit-1.1.11/icedax/icedax.c 2012-07-30 16:42:52.902757497 +0200
--- cdrkit-1.1.11/icedax/icedax.c.paranoiacdda 2012-07-31 14:27:15.237157718 +0200
+++ cdrkit-1.1.11/icedax/icedax.c 2012-07-31 14:27:15.238157752 +0200
@@ -120,6 +120,10 @@
#ifdef USE_LAME
#include "mp3.h" /* mp3 file handling */
@ -160,8 +172,8 @@ diff -up cdrkit-1.1.11/icedax/icedax.c.paranoiacdda cdrkit-1.1.11/icedax/icedax.
if (global.paranoia_parms.disable_paranoia) {
diff -up cdrkit-1.1.11/icedax/icedax.h.paranoiacdda cdrkit-1.1.11/icedax/icedax.h
--- cdrkit-1.1.11/icedax/icedax.h.paranoiacdda 2012-07-30 16:41:47.246743079 +0200
+++ cdrkit-1.1.11/icedax/icedax.h 2012-07-30 16:41:47.247743080 +0200
--- cdrkit-1.1.11/icedax/icedax.h.paranoiacdda 2012-07-31 14:27:15.216157005 +0200
+++ cdrkit-1.1.11/icedax/icedax.h 2012-07-31 14:27:15.217157039 +0200
@@ -41,7 +41,7 @@
/* Endianess */
@ -172,8 +184,8 @@ diff -up cdrkit-1.1.11/icedax/icedax.h.paranoiacdda cdrkit-1.1.11/icedax/icedax.
#define BIG 1
diff -up cdrkit-1.1.11/icedax/interface.c.paranoiacdda cdrkit-1.1.11/icedax/interface.c
--- cdrkit-1.1.11/icedax/interface.c.paranoiacdda 2012-07-30 16:41:47.261743079 +0200
+++ cdrkit-1.1.11/icedax/interface.c 2012-07-30 16:41:47.259743081 +0200
--- cdrkit-1.1.11/icedax/interface.c.paranoiacdda 2012-07-31 14:27:15.235157650 +0200
+++ cdrkit-1.1.11/icedax/interface.c 2012-07-31 14:27:15.232157548 +0200
@@ -116,7 +116,7 @@ int (*Play_at)(SCSI *usalp, unsigned in
int (*StopPlay)(SCSI *usalp);
void (*trash_cache)(UINT4 *p, unsigned lSector, unsigned SectorBurstVal);
@ -184,8 +196,8 @@ diff -up cdrkit-1.1.11/icedax/interface.c.paranoiacdda cdrkit-1.1.11/icedax/inte
long cdda_read(void *d, void *buffer, long beginsector, long sectors)
diff -up cdrkit-1.1.11/icedax/toc.c.paranoiacdda cdrkit-1.1.11/icedax/toc.c
--- cdrkit-1.1.11/icedax/toc.c.paranoiacdda 2012-07-30 16:41:47.253743078 +0200
+++ cdrkit-1.1.11/icedax/toc.c 2012-07-30 16:41:47.258743080 +0200
--- cdrkit-1.1.11/icedax/toc.c.paranoiacdda 2012-07-31 14:27:15.225157311 +0200
+++ cdrkit-1.1.11/icedax/toc.c 2012-07-31 14:27:15.230157480 +0200
@@ -379,8 +379,7 @@ static void emit_cddb_form(char *fname_b
static void emit_cdindex_form(char *fname_baseval);
#endif

View File

@ -21,9 +21,9 @@ Patch12: cdrkit-1.1.11-handler.patch
Patch13: cdrkit-1.1.11-dvdman.patch
Patch14: cdrkit-1.1.11-paranoiacdda.patch
Patch15: cdrkit-1.1.11-utf8.patch
Patch16: cdrkit-1.1.11-cmakewarn.patch
BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
BuildRequires: cdparanoia-devel
%description
cdrkit is a collection of CD/DVD utilities.
@ -83,6 +83,8 @@ Requires: libusal = %{version}-%{release}
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
Requires: vorbis-tools
Requires: cdparanoia
BuildRequires: cdparanoia-devel
%description -n icedax
Icedax is a sampling utility for CD-ROM drives that are capable of
@ -127,6 +129,7 @@ SCSI devices.
%patch14 -p1 -b .paranoiacdda
# not using -b since otherwise backup files would be included into rpm
%patch15 -p1
%patch16 -p1 -b .cmakewarn
# we do not want bundled paranoia library
rm -rf libparanoia