Library libusal is installed in order to be used by other apps
(Resolves: #588508) https://bugzilla.redhat.com/show_bug.cgi?id=588508
This commit is contained in:
parent
bba8c6ed7b
commit
84c00532ad
18
cdrkit-1.1.11-usalinst.patch
Normal file
18
cdrkit-1.1.11-usalinst.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -up cdrkit-1.1.11/librols/CMakeLists.txt.usalinst cdrkit-1.1.11/librols/CMakeLists.txt
|
||||||
|
--- cdrkit-1.1.11/librols/CMakeLists.txt.usalinst 2011-02-24 13:55:02.039474881 +0100
|
||||||
|
+++ cdrkit-1.1.11/librols/CMakeLists.txt 2011-02-24 13:55:25.077176945 +0100
|
||||||
|
@@ -5,3 +5,5 @@ SET(LIBROLS_SRCS astoi.c astoll.c astou
|
||||||
|
|
||||||
|
ADD_LIBRARY (rols STATIC ${CMAKE_CURRENT_SOURCE_DIR}/../include/xconfig.h ${CMAKE_CURRENT_SOURCE_DIR}/../include/align.h ${LIBROLS_SRCS})
|
||||||
|
|
||||||
|
+INSTALL(TARGETS rols DESTINATION lib${LIB_SUFFIX})
|
||||||
|
+
|
||||||
|
diff -up cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst cdrkit-1.1.11/libusal/CMakeLists.txt
|
||||||
|
--- cdrkit-1.1.11/libusal/CMakeLists.txt.usalinst 2011-02-24 13:53:45.432139117 +0100
|
||||||
|
+++ cdrkit-1.1.11/libusal/CMakeLists.txt 2011-02-24 13:53:45.438139303 +0100
|
||||||
|
@@ -8,3 +8,5 @@ SET(LIBSCG_SRCS usalsettarget.c usaltime
|
||||||
|
LINK_DIRECTORIES(../librols)
|
||||||
|
ADD_LIBRARY (usal STATIC ${LIBSCG_SRCS})
|
||||||
|
TARGET_LINK_LIBRARIES(usal ${SCG_SELF_LIBS})
|
||||||
|
+INSTALL(TARGETS usal DESTINATION lib${LIB_SUFFIX})
|
||||||
|
+INSTALL(FILES usal/scsicdb.h usal/aspi-dos.h usal/usalcmd.h usal/usalio.h usal/scsireg.h usal/usalops.h usal/scsidefs.h usal/spti-wnt.h usal/srb_os2.h usal/scsitransp.h usal/aspi-win32.h usal/scsisense.h usaltimes.h pg.h DESTINATION include/usal)
|
41
cdrkit.spec
41
cdrkit.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A collection of CD/DVD utilities
|
Summary: A collection of CD/DVD utilities
|
||||||
Name: cdrkit
|
Name: cdrkit
|
||||||
Version: 1.1.11
|
Version: 1.1.11
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://cdrkit.org/
|
URL: http://cdrkit.org/
|
||||||
@ -15,6 +15,7 @@ Patch5: cdrkit-1.1.9-buffer_overflow.patch
|
|||||||
Patch6: cdrkit-1.1.10-build-fix.patch
|
Patch6: cdrkit-1.1.10-build-fix.patch
|
||||||
Patch7: cdrkit-1.1.11-manpagefix.patch
|
Patch7: cdrkit-1.1.11-manpagefix.patch
|
||||||
Patch8: cdrkit-1.1.11-rootstat.patch
|
Patch8: cdrkit-1.1.11-rootstat.patch
|
||||||
|
Patch9: cdrkit-1.1.11-usalinst.patch
|
||||||
|
|
||||||
BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
|
BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
|
||||||
|
|
||||||
@ -39,7 +40,7 @@ works with many different brands of CD recorders, fully supports
|
|||||||
multi-sessions and provides human-readable error messages.
|
multi-sessions and provides human-readable error messages.
|
||||||
|
|
||||||
%package -n genisoimage
|
%package -n genisoimage
|
||||||
Summary: Creates an image of an ISO9660 filesystem
|
Summary: Creates an image of an ISO9660 file system
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Obsoletes: mkisofs < 9:2.01-12
|
Obsoletes: mkisofs < 9:2.01-12
|
||||||
Provides: mkisofs = 9:2.01-12
|
Provides: mkisofs = 9:2.01-12
|
||||||
@ -48,7 +49,7 @@ Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
|||||||
|
|
||||||
%description -n genisoimage
|
%description -n genisoimage
|
||||||
The genisoimage program is used as a pre-mastering program; i.e., it
|
The genisoimage program is used as a pre-mastering program; i.e., it
|
||||||
generates the ISO9660 filesystem. Genisoimage takes a snapshot of
|
generates the ISO9660 file system. Genisoimage takes a snapshot of
|
||||||
a given directory tree and generates a binary image of the tree
|
a given directory tree and generates a binary image of the tree
|
||||||
which will correspond to an ISO9660 filesystem when written to
|
which will correspond to an ISO9660 filesystem when written to
|
||||||
a block device. Genisoimage is used for writing CD-ROMs, and includes
|
a block device. Genisoimage is used for writing CD-ROMs, and includes
|
||||||
@ -58,13 +59,14 @@ Install the genisoimage package if you need a program for writing
|
|||||||
CD-ROMs.
|
CD-ROMs.
|
||||||
|
|
||||||
%package -n dirsplit
|
%package -n dirsplit
|
||||||
Summary: dirsplit utility
|
Summary: Utility to split directories
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Requires: perl >= 4:5.8.1
|
Requires: perl >= 4:5.8.1
|
||||||
Requires: genisoimage = %{version}-%{release}
|
Requires: genisoimage = %{version}-%{release}
|
||||||
|
|
||||||
%description -n dirsplit
|
%description -n dirsplit
|
||||||
dirsplit
|
This utility is used to split directories into chunks before burning.
|
||||||
|
Chunk size is usually set to fit to a CD/DVD.
|
||||||
|
|
||||||
%package -n icedax
|
%package -n icedax
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
@ -82,6 +84,16 @@ read from the CD can be saved as .wav or .sun format sound files.
|
|||||||
Recording formats include stereo/mono, 8/12/16 bits and different
|
Recording formats include stereo/mono, 8/12/16 bits and different
|
||||||
rates. Icedax can also be used as a CD player.
|
rates. Icedax can also be used as a CD player.
|
||||||
|
|
||||||
|
%package -n libusal-devel
|
||||||
|
Summary: Development files for libusal
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
|
Requires(post): %{_sbindir}/alternatives chkconfig coreutils
|
||||||
|
|
||||||
|
%description -n libusal-devel
|
||||||
|
The libusal-devel package contains libraries and header files
|
||||||
|
for developing applications that use libusal.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .werror
|
%patch1 -p1 -b .werror
|
||||||
@ -92,6 +104,7 @@ rates. Icedax can also be used as a CD player.
|
|||||||
%patch6 -p1 -b .build-fix
|
%patch6 -p1 -b .build-fix
|
||||||
%patch7 -p1 -b .manpagefix
|
%patch7 -p1 -b .manpagefix
|
||||||
%patch8 -p1 -b .rootstat
|
%patch8 -p1 -b .rootstat
|
||||||
|
%patch9 -p1 -b .usalinst
|
||||||
|
|
||||||
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
||||||
find doc -type f -print0 | xargs -0 chmod a-x
|
find doc -type f -print0 | xargs -0 chmod a-x
|
||||||
@ -103,9 +116,11 @@ cd fedora
|
|||||||
export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -Wno-unused-but-set-variable -Wno-array-bounds -fno-strict-aliasing"
|
export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -Wno-unused-but-set-variable -Wno-array-bounds -fno-strict-aliasing"
|
||||||
export CXXFLAGS="$CFLAGS"
|
export CXXFLAGS="$CFLAGS"
|
||||||
export FFLAGS="$CFLAGS"
|
export FFLAGS="$CFLAGS"
|
||||||
cmake .. \
|
%cmake CMAKE_VERBOSE=1 \
|
||||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
-DBUILD_SHARED_LIBS:BOOL=ON
|
-DBUILD_SHARED_LIBS:BOOL=ON \
|
||||||
|
..
|
||||||
|
|
||||||
make VERBOSE=1 %{?_smp_mflags}
|
make VERBOSE=1 %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -237,7 +252,19 @@ fi
|
|||||||
%{_bindir}/dirsplit
|
%{_bindir}/dirsplit
|
||||||
%{_mandir}/man1/dirsplit.*
|
%{_mandir}/man1/dirsplit.*
|
||||||
|
|
||||||
|
%files -n libusal-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc Changelog COPYING FAQ FORK START
|
||||||
|
%{_libdir}/libusal.a
|
||||||
|
%{_libdir}/librols.a
|
||||||
|
%{_includedir}/usal
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-4
|
||||||
|
- Library libusal is installed in order to be used by other apps
|
||||||
|
(Resolves: #588508)
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=588508
|
||||||
|
|
||||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-3
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user