genisoimage: fix string overflow breakage when using the -root
This commit is contained in:
parent
40b9284b0c
commit
12fdcf6af2
14
cdrkit-1.1.9-root_option.patch
Normal file
14
cdrkit-1.1.9-root_option.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- cdrkit-1.1.9/genisoimage/genisoimage.c 2009-08-11 13:45:42.491887853 +0200
|
||||||
|
+++ cdrkit-1.1.9-master/genisoimage/genisoimage.c 2009-08-11 15:10:23.382014864 +0200
|
||||||
|
@@ -3117,8 +3117,10 @@ if (check_session == 0)
|
||||||
|
if (reloc_root != NULL) {
|
||||||
|
strcpy(graft_point, reloc_root);
|
||||||
|
len = strlen(graft_point);
|
||||||
|
- if (graft_point[len] != '/')
|
||||||
|
+ if (graft_point[len] != '/'){
|
||||||
|
graft_point[len++] = '/';
|
||||||
|
+ graft_point[len] = '\0';
|
||||||
|
+ }
|
||||||
|
} else {
|
||||||
|
len = 0;
|
||||||
|
}
|
15
cdrkit.spec
15
cdrkit.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A collection of CD/DVD utilities
|
Summary: A collection of CD/DVD utilities
|
||||||
Name: cdrkit
|
Name: cdrkit
|
||||||
Version: 1.1.9
|
Version: 1.1.9
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://cdrkit.org/
|
URL: http://cdrkit.org/
|
||||||
@ -12,6 +12,8 @@ Patch2: cdrkit-1.1.9-efi-boot.patch
|
|||||||
Patch3: cdrkit-1.1.9-types.patch
|
Patch3: cdrkit-1.1.9-types.patch
|
||||||
Patch4: cdrkit-1.1.9-no_mp3.patch
|
Patch4: cdrkit-1.1.9-no_mp3.patch
|
||||||
Patch5: cdrkit-1.1.9-buffer_overflow.patch
|
Patch5: cdrkit-1.1.9-buffer_overflow.patch
|
||||||
|
Patch6: cdrkit-1.1.9-rr_joliet.patch
|
||||||
|
Patch7: cdrkit-1.1.9-root_option.patch
|
||||||
|
|
||||||
BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
|
BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
|
||||||
|
|
||||||
@ -86,6 +88,8 @@ rates. Icedax can also be used as a CD player.
|
|||||||
%patch3 -p1 -b .types
|
%patch3 -p1 -b .types
|
||||||
%patch4 -p1 -b .no_mp3
|
%patch4 -p1 -b .no_mp3
|
||||||
%patch5 -p1 -b .buffer_overflow
|
%patch5 -p1 -b .buffer_overflow
|
||||||
|
%patch6 -p1 -b .rr_joliet
|
||||||
|
%patch7 -p1 -b .root_option
|
||||||
|
|
||||||
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
|
||||||
find doc -type f -print0 | xargs -0 chmod a-x
|
find doc -type f -print0 | xargs -0 chmod a-x
|
||||||
@ -99,10 +103,8 @@ export CXXFLAGS="$CFLAGS"
|
|||||||
export FFLAGS="$CFLAGS"
|
export FFLAGS="$CFLAGS"
|
||||||
cmake .. \
|
cmake .. \
|
||||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||||
-DBUILD_SHARED_LIBS:BOOL=ON \
|
-DBUILD_SHARED_LIBS:BOOL=ON
|
||||||
--debug-output \
|
make VERBOSE=1 %{?_smp_mflags}
|
||||||
--trace
|
|
||||||
make VERBOSE=2 %{?_smp_mflags}
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -230,6 +232,9 @@ fi
|
|||||||
%{_mandir}/man1/dirsplit.*
|
%{_mandir}/man1/dirsplit.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
|
||||||
|
- fix #508449. fix string overflow breakage when using the -root
|
||||||
|
|
||||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user