- Update to latest 1.2.3 release candidate
- Merged with gcdmaster spec file - Added scripts to manage gcdmaster new schemas file - Moved desktop file fix into patch - Added patch to fix gcc 4.4 compile
This commit is contained in:
parent
9d4b4b5903
commit
ec5b1a343c
@ -1 +1 @@
|
|||||||
cdrdao-1.2.2.tar.bz2
|
cdrdao-1.2.3rc2.tar.bz2
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- cdrdao-1.1.7/scsilib/include/btorder.h.endianness 2004-01-20 13:53:42.000000000 +0100
|
|
||||||
+++ cdrdao-1.1.7/scsilib/include/btorder.h 2004-01-20 13:55:24.000000000 +0100
|
|
||||||
@@ -100,6 +100,7 @@
|
|
||||||
# endif
|
|
||||||
|
|
||||||
# if defined(__i386__) || defined(__i386) || defined(i386) || \
|
|
||||||
+ defined(__ia64__) || defined(__ia64) || defined(ia64) || \
|
|
||||||
defined(__alpha__) || defined(__alpha) || defined(alpha) || \
|
|
||||||
defined(__arm__) || defined(__arm) || defined(arm)
|
|
||||||
# define _BIT_FIELDS_LTOH
|
|
16
cdrdao-1.2.2-desktop.patch
Normal file
16
cdrdao-1.2.2-desktop.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- cdrdao-1.2.3rc2/xdao/gcdmaster.desktop~ 2004-06-28 20:05:57.000000000 +0200
|
||||||
|
+++ cdrdao-1.2.3rc2/xdao/gcdmaster.desktop 2009-04-07 09:13:56.000000000 +0200
|
||||||
|
@@ -1,10 +1,10 @@
|
||||||
|
[Desktop Entry]
|
||||||
|
-Encoding=UTF-8
|
||||||
|
Name=Gnome CD Master
|
||||||
|
Comment=Gnome Audio CD editor and burner
|
||||||
|
Exec=gcdmaster %F
|
||||||
|
-Icon=gcdmaster.png
|
||||||
|
+Icon=gcdmaster
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
StartupNotify=true
|
||||||
|
-Categories=GNOME;AudioVideo;Application;X-Fedora;
|
||||||
|
+Categories=GNOME;AudioVideo;X-Fedora;
|
||||||
|
+MimeType=application/x-toc;application/x-cue;application/x-cdrdao-toc;
|
@ -1,22 +0,0 @@
|
|||||||
diff -up cdrdao-1.2.2/trackdb/FormatConverter.cc.gcc43 cdrdao-1.2.2/trackdb/FormatConverter.cc
|
|
||||||
--- cdrdao-1.2.2/trackdb/FormatConverter.cc.gcc43 2008-02-18 13:17:53.000000000 +0100
|
|
||||||
+++ cdrdao-1.2.2/trackdb/FormatConverter.cc 2008-02-18 13:18:11.000000000 +0100
|
|
||||||
@@ -18,6 +18,7 @@
|
|
||||||
*/
|
|
||||||
|
|
||||||
#include <stdlib.h>
|
|
||||||
+#include <string.h>
|
|
||||||
#ifdef HAVE_AO
|
|
||||||
#include <ao/ao.h>
|
|
||||||
#endif
|
|
||||||
diff -up cdrdao-1.2.2/trackdb/TempFileManager.cc.gcc43 cdrdao-1.2.2/trackdb/TempFileManager.cc
|
|
||||||
--- cdrdao-1.2.2/trackdb/TempFileManager.cc.gcc43 2005-04-22 04:01:46.000000000 +0200
|
|
||||||
+++ cdrdao-1.2.2/trackdb/TempFileManager.cc 2008-02-18 13:14:14.000000000 +0100
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <fcntl.h>
|
|
||||||
+#include <string.h>
|
|
||||||
|
|
||||||
#define DEFAULT_TEMP_PATH "/tmp/"
|
|
||||||
|
|
23
cdrdao-1.2.2-gcc44.patch
Normal file
23
cdrdao-1.2.2-gcc44.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- cdrdao-1.2.3rc2/trackdb/TempFileManager.cc~ 2008-02-17 14:05:05.000000000 +0100
|
||||||
|
+++ cdrdao-1.2.3rc2/trackdb/TempFileManager.cc 2009-04-07 09:05:41.000000000 +0200
|
||||||
|
@@ -20,6 +20,7 @@
|
||||||
|
#include "TempFileManager.h"
|
||||||
|
#include "log.h"
|
||||||
|
|
||||||
|
+#include <stdio.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
--- cdrdao-1.2.3rc2/dao/CdrDriver.cc~ 2009-02-21 11:01:32.000000000 +0100
|
||||||
|
+++ cdrdao-1.2.3rc2/dao/CdrDriver.cc 2009-04-07 09:07:14.000000000 +0200
|
||||||
|
@@ -2114,8 +2114,8 @@
|
||||||
|
ret = 1;
|
||||||
|
}
|
||||||
|
else {
|
||||||
|
- if ((caps & CDR_READ_CAP_DATA_RW_RAW|CDR_READ_CAP_DATA_PW_RAW) != 0)
|
||||||
|
- ret = 1;
|
||||||
|
+ if ((caps & (CDR_READ_CAP_DATA_RW_RAW|CDR_READ_CAP_DATA_PW_RAW)) != 0)
|
||||||
|
+ ret = 1;
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
|
147
cdrdao.spec
147
cdrdao.spec
@ -1,28 +1,28 @@
|
|||||||
Summary: Writes audio CD-Rs in disk-at-once (DAO) mode
|
%define rcversion rc2
|
||||||
Name: cdrdao
|
|
||||||
Version: 1.2.2
|
|
||||||
Release: 6
|
|
||||||
License: GPLv2
|
|
||||||
Group: Applications/Multimedia
|
|
||||||
URL: http://cdrdao.sourceforge.net/
|
|
||||||
Source: http://easynews.dl.sourceforge.net/sourceforge/cdrdao/%{name}-%{version}.tar.bz2
|
|
||||||
|
|
||||||
Patch1: mkisofs-changelog.patch
|
|
||||||
Patch2: cdrdao-1.2.2-gcc43.patch
|
|
||||||
Patch9: cdrdao-1.1.7-endianness.patch
|
|
||||||
Patch23: cdrtools-2.01a27-silly-warnings.patch
|
|
||||||
Patch30: cdrtools-2.0-O_EXCL.patch
|
|
||||||
|
|
||||||
|
Summary: Writes audio CD-Rs in disk-at-once (DAO) mode
|
||||||
|
Name: cdrdao
|
||||||
|
Version: 1.2.3
|
||||||
|
Release: 0.%{rcversion}.1
|
||||||
|
License: GPLv2
|
||||||
|
Group: Applications/Multimedia
|
||||||
|
URL: http://cdrdao.sourceforge.net/
|
||||||
|
Source0: %{name}-%{version}%{rcversion}.tar.bz2
|
||||||
|
Patch0: cdrdao-1.2.2-gcc44.patch
|
||||||
|
Patch1: cdrdao-1.2.2-desktop.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
# Only for gcdmaster
|
BuildRequires: gtkmm24-devel
|
||||||
#BuildRequires: libvorbis-devel >= 1.0
|
BuildRequires: libgnomeuimm26-devel
|
||||||
|
BuildRequires: libsigc++20-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libvorbis-devel >= 1.0
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: libao-devel
|
||||||
|
|
||||||
# Only exclude s390
|
# Only exclude s390
|
||||||
ExcludeArch: s390 s390x
|
ExcludeArch: s390 s390x
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Cdrdao records audio CD-Rs in disk-at-once (DAO) mode, based on a
|
Cdrdao records audio CD-Rs in disk-at-once (DAO) mode, based on a
|
||||||
textual description of the CD contents. Recording in DAO mode writes
|
textual description of the CD contents. Recording in DAO mode writes
|
||||||
@ -30,38 +30,117 @@ the complete disc (lead-in, one or more tracks, and lead-out) in a
|
|||||||
single step. DAO allows full control over the length and the contents
|
single step. DAO allows full control over the length and the contents
|
||||||
of pre-gaps, the pause areas between tracks.
|
of pre-gaps, the pause areas between tracks.
|
||||||
|
|
||||||
|
|
||||||
|
%package -n gcdmaster
|
||||||
|
Summary: A Gnome2 Disk-At-Once (DAO) Audio CD writer
|
||||||
|
Group: Applications/Multimedia
|
||||||
|
Requires: cdrdao = %{version}-%{release}
|
||||||
|
|
||||||
|
Requires(post): shared-mime-info desktop-file-utils
|
||||||
|
Requires(postun): shared-mime-info desktop-file-utils
|
||||||
|
Requires(pre): GConf2
|
||||||
|
Requires(post): GConf2
|
||||||
|
Requires(preun): GConf2
|
||||||
|
|
||||||
|
|
||||||
|
%description -n gcdmaster
|
||||||
|
Gcdmaster is a GNOME2 GUI front-end to cdrdao that makes it easy to
|
||||||
|
visualize and manipulate audio information before burning it onto
|
||||||
|
CD. Its features include: cut/copy/paste of sound samples, track marks
|
||||||
|
edition and silence insertion.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}%{rcversion}
|
||||||
chmod a+rX -R .
|
%patch0 -p1 -b .gcc4
|
||||||
%patch1 -p1 -b .changelog
|
%patch1 -p1 -b .desktop
|
||||||
%patch2 -p1 -b .gcc43
|
|
||||||
%patch9 -p1 -b .endian
|
|
||||||
%patch23 -p1 -b .silly
|
|
||||||
%patch30 -p1 -b .excl
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --prefix=%{_prefix}\
|
%configure \
|
||||||
--without-xdao --without-lame
|
--with-xdao \
|
||||||
|
--without-scglib \
|
||||||
|
--with-mp3-support \
|
||||||
|
--without-lame
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
||||||
|
|
||||||
|
desktop-file-install \
|
||||||
|
--vendor "" \
|
||||||
|
--mode 644 \
|
||||||
|
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||||
|
--delete-original \
|
||||||
|
$RPM_BUILD_ROOT%{_datadir}/applications/gcdmaster.desktop
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post -n gcdmaster
|
||||||
|
update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
|
||||||
|
update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
|
||||||
|
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||||
|
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gcdmaster.schemas > /dev/null || :
|
||||||
|
killall -HUP gconfd-2 &>/dev/null || :
|
||||||
|
|
||||||
|
|
||||||
|
%postun -n gcdmaster
|
||||||
|
update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
|
||||||
|
update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
|
||||||
|
if [ "$1" -gt 1 ]; then
|
||||||
|
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||||
|
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >/dev/null || :
|
||||||
|
killall -HUP gconfd-2 &>/dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ "$1" -eq 0 ]; then
|
||||||
|
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||||
|
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gcdmaster.schemas > /dev/null || :
|
||||||
|
killall -HUP gconfd-2 &>/dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-, root, root, -)
|
||||||
%doc COPYING README
|
%doc AUTHORS COPYING README CREDITS ChangeLog
|
||||||
%{_bindir}/*
|
%{_bindir}/cdrdao
|
||||||
%dir %{_datadir}/cdrdao
|
%{_bindir}/*toc*
|
||||||
%{_datadir}/cdrdao/*
|
%{_datadir}/cdrdao
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/cdrdao*
|
||||||
|
%{_mandir}/*/cue2toc*
|
||||||
|
|
||||||
|
|
||||||
|
%files -n gcdmaster
|
||||||
|
%defattr(-, root, root, -)
|
||||||
|
%{_bindir}/gcdmaster
|
||||||
|
%{_datadir}/gcdmaster
|
||||||
|
%{_datadir}/applications/*.desktop
|
||||||
|
%{_datadir}/mime-info/gcdmaster*
|
||||||
|
%{_datadir}/mime/packages/gcdmaster.xml
|
||||||
|
%{_datadir}/application-registry/gcdmaster.applications
|
||||||
|
%{_datadir}/pixmaps/*
|
||||||
|
%{_sysconfdir}/gconf/schemas/gcdmaster.schemas
|
||||||
|
%{_mandir}/man1/gcdmaster*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 7 2009 Denis Leroy <denis@poolshark.org> - 1.2.3-0.rc2.1
|
||||||
|
- Update to latest 1.2.3 release candidate
|
||||||
|
- Merged with gcdmaster spec file
|
||||||
|
- Added scripts to manage gcdmaster new schemas file
|
||||||
|
- Moved desktop file fix into patch
|
||||||
|
- Added patch to fix gcc 4.4 compile
|
||||||
|
|
||||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-6
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,103 +0,0 @@
|
|||||||
--- cdrtools-2.01/scsilib/libscg/oexcl.c.excl 2004-09-22 12:03:23.426676328 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/oexcl.c 2004-09-22 12:03:23.426676328 +0200
|
|
||||||
@@ -0,0 +1,29 @@
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+#include <sys/stat.h>
|
|
||||||
+#include <fcntl.h>
|
|
||||||
+#include <stdio.h>
|
|
||||||
+
|
|
||||||
+int openexcl(const char *device, int mode)
|
|
||||||
+{
|
|
||||||
+ int f, i;
|
|
||||||
+
|
|
||||||
+ f = open(device, mode | O_EXCL);
|
|
||||||
+
|
|
||||||
+ if (f < 0) {
|
|
||||||
+ f = open(device, mode);
|
|
||||||
+
|
|
||||||
+ if (f >= 0) {
|
|
||||||
+ close(f);
|
|
||||||
+ f = -1;
|
|
||||||
+ for (i = 0; (i < 10) && (f == -1); i++) {
|
|
||||||
+ fprintf(stderr, "Error trying to open %s exclusively ... retrying in 1 second.\n", device);
|
|
||||||
+ usleep(1000000 + 100000.0 * rand()/(RAND_MAX+1.0));
|
|
||||||
+ f = open(device, O_RDONLY | O_NONBLOCK | O_EXCL);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return f;
|
|
||||||
+}
|
|
||||||
--- cdrtools-2.01/scsilib/libscg/scsi-linux-ata.c.excl 2004-09-22 12:03:23.423676784 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-ata.c 2004-09-22 12:03:23.427676176 +0200
|
|
||||||
@@ -112,6 +112,7 @@
|
|
||||||
LOCAL void sglog __PR((const char *fmt, ...));
|
|
||||||
|
|
||||||
#include <vadefs.h>
|
|
||||||
+#include "oexcl.h"
|
|
||||||
|
|
||||||
/* VARARGS1 */
|
|
||||||
#ifdef PROTOTYPES
|
|
||||||
@@ -267,7 +268,7 @@
|
|
||||||
starget,
|
|
||||||
slun;
|
|
||||||
|
|
||||||
- f = open(device, O_RDWR | O_NONBLOCK);
|
|
||||||
+ f = openexcl(device, O_RDWR | O_NONBLOCK);
|
|
||||||
|
|
||||||
if (f < 0) {
|
|
||||||
if (scgp->errstr)
|
|
||||||
--- cdrtools-2.01/scsilib/libscg/oexcl.h.excl 2004-09-22 12:03:23.428676024 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/oexcl.h 2004-09-22 12:03:23.428676024 +0200
|
|
||||||
@@ -0,0 +1,5 @@
|
|
||||||
+#ifndef OEXCL_H
|
|
||||||
+
|
|
||||||
+extern int openexcl(const char *device, int mode);
|
|
||||||
+
|
|
||||||
+#endif
|
|
||||||
--- cdrtools-2.01/scsilib/libscg/Targets.excl 2002-10-19 20:33:37.000000000 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/Targets 2004-09-22 12:03:23.428676024 +0200
|
|
||||||
@@ -1,3 +1,3 @@
|
|
||||||
CFILES= scsitransp.c scsihack.c scsiopen.c scgsettarget.c \
|
|
||||||
- scsierrs.c scgtimes.c scsihelp.c \
|
|
||||||
+ scsierrs.c scgtimes.c scsihelp.c oexcl.c \
|
|
||||||
rdummy.c
|
|
||||||
--- cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c.excl 2004-09-22 12:03:23.422676936 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c 2004-09-22 12:12:49.271654816 +0200
|
|
||||||
@@ -79,6 +79,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include "scsi/sg.h"
|
|
||||||
+#include "oexcl.h"
|
|
||||||
|
|
||||||
#undef sense /* conflict in struct cdrom_generic_command */
|
|
||||||
#include <linux/cdrom.h>
|
|
||||||
@@ -94,7 +95,7 @@
|
|
||||||
* Choose your name instead of "schily" and make clear that the version
|
|
||||||
* string is related to a modified source.
|
|
||||||
*/
|
|
||||||
-LOCAL char _scg_trans_version[] = "scsi-linux-sg.c-1.83"; /* The version for this transport*/
|
|
||||||
+LOCAL char _scg_trans_version[] = "scsi-linux-sg.c-1.83-RH"; /* The version for this transport*/
|
|
||||||
|
|
||||||
#ifndef SCSI_IOCTL_GET_BUS_NUMBER
|
|
||||||
#define SCSI_IOCTL_GET_BUS_NUMBER 0x5386
|
|
||||||
@@ -247,7 +249,7 @@
|
|
||||||
* return "schily" for the SCG_AUTHOR request.
|
|
||||||
*/
|
|
||||||
case SCG_AUTHOR:
|
|
||||||
- return (_scg_auth_schily);
|
|
||||||
+ return ("schily - Red Hat");
|
|
||||||
case SCG_SCCS_ID:
|
|
||||||
return (__sccsid);
|
|
||||||
case SCG_KVERSION:
|
|
||||||
@@ -479,7 +483,7 @@
|
|
||||||
b = -1;
|
|
||||||
}
|
|
||||||
/* O_NONBLOCK is dangerous */
|
|
||||||
- f = open(device, O_RDWR | O_NONBLOCK);
|
|
||||||
+ f = openexcl(device, O_RDWR | O_NONBLOCK);
|
|
||||||
/* if (f < 0 && errno == ENOENT)*/
|
|
||||||
/* goto openpg;*/
|
|
||||||
|
|
@ -1,54 +0,0 @@
|
|||||||
--- cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c.silly 2004-05-20 15:42:12.000000000 +0200
|
|
||||||
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c 2004-09-08 11:37:47.670038792 +0200
|
|
||||||
@@ -315,6 +315,10 @@
|
|
||||||
if (device != NULL && *device != '\0') {
|
|
||||||
#ifdef USE_ATA
|
|
||||||
if (strncmp(device, "ATAPI", 5) == 0) {
|
|
||||||
+ if (scgp->overbose) {
|
|
||||||
+ js_fprintf((FILE *)scgp->errfile,
|
|
||||||
+ "Use of ATA is preferred over ATAPI.\n");
|
|
||||||
+ }
|
|
||||||
scgp->ops = &ata_ops;
|
|
||||||
return (SCGO_OPEN(scgp, device));
|
|
||||||
}
|
|
||||||
@@ -336,18 +340,6 @@
|
|
||||||
*/
|
|
||||||
use_ata = TRUE;
|
|
||||||
device = NULL;
|
|
||||||
- if (scgp->overbose) {
|
|
||||||
- /*
|
|
||||||
- * I strongly encourage people who believe that
|
|
||||||
- * they need to patch this message away to read
|
|
||||||
- * the messages in the Solaris USCSI libscg
|
|
||||||
- * layer instead of wetting their tissues while
|
|
||||||
- * being unwilling to look besides their
|
|
||||||
- * own belly button.
|
|
||||||
- */
|
|
||||||
- js_fprintf((FILE *)scgp->errfile,
|
|
||||||
- "Warning: Using badly designed ATAPI via /dev/hd* interface.\n");
|
|
||||||
- }
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -497,20 +489,7 @@
|
|
||||||
if (b < 0 || b > 25)
|
|
||||||
b = -1;
|
|
||||||
}
|
|
||||||
- if (scgp->overbose) {
|
|
||||||
- /*
|
|
||||||
- * Before you patch this away, are you sure that you
|
|
||||||
- * know what you are going to to?
|
|
||||||
- *
|
|
||||||
- * Note that this is a warning that helps users from
|
|
||||||
- * cdda2wav, mkisofs and other programs (that
|
|
||||||
- * distinguish SCSI addresses from file names) from
|
|
||||||
- * getting unexpected results.
|
|
||||||
- */
|
|
||||||
- js_fprintf((FILE *)scgp->errfile,
|
|
||||||
- "Warning: Open by 'devname' is unintentional and not supported.\n");
|
|
||||||
- }
|
|
||||||
- /* O_NONBLOCK is dangerous */
|
|
||||||
+ /* O_NONBLOCK is dangerous */
|
|
||||||
f = open(device, O_RDWR | O_NONBLOCK);
|
|
||||||
/* if (f < 0 && errno == ENOENT)*/
|
|
||||||
/* goto openpg;*/
|
|
@ -1,9 +0,0 @@
|
|||||||
--- cdrtools-1.10/mkisofs/ChangeLog.changelog Sat Apr 7 17:34:04 2001
|
|
||||||
+++ cdrtools-1.10/mkisofs/ChangeLog Thu Apr 19 01:02:24 2001
|
|
||||||
@@ -0,0 +1,6 @@
|
|
||||||
+**************** Packager's Note ******************
|
|
||||||
+Tue Aug 8 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
|
||||||
+ * graft-points are NO LONGER assuemd,
|
|
||||||
+ you must specify '-graft-points'
|
|
||||||
+
|
|
||||||
+
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
f0cbf36907406cb4f4c568f9e6669a34 cdrdao-1.2.2.tar.bz2
|
55966f60e88cbf82bad91f3accfdc50b cdrdao-1.2.3rc2.tar.bz2
|
||||||
|
@ -1,6 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Name=xcdrdao
|
|
||||||
Comment=Writes audio CD-Rs in disk-at-once (DAO) mode.
|
|
||||||
Exec=xcdrdao
|
|
||||||
Terminal=0
|
|
||||||
Type=Application
|
|
Loading…
Reference in New Issue
Block a user