- version 1.2.2
- built without cdrecord-devel now
This commit is contained in:
parent
3b1b08c6f5
commit
c44a22b3d5
10
cdrdao-1.1.7-endianness.patch
Normal file
10
cdrdao-1.1.7-endianness.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- cdrdao-1.1.7/scsilib/include/btorder.h.endianness 2004-01-20 13:53:42.000000000 +0100
|
||||||
|
+++ cdrdao-1.1.7/scsilib/include/btorder.h 2004-01-20 13:55:24.000000000 +0100
|
||||||
|
@@ -100,6 +100,7 @@
|
||||||
|
# endif
|
||||||
|
|
||||||
|
# if defined(__i386__) || defined(__i386) || defined(i386) || \
|
||||||
|
+ defined(__ia64__) || defined(__ia64) || defined(ia64) || \
|
||||||
|
defined(__alpha__) || defined(__alpha) || defined(alpha) || \
|
||||||
|
defined(__arm__) || defined(__arm) || defined(arm)
|
||||||
|
# define _BIT_FIELDS_LTOH
|
24
cdrdao.spec
24
cdrdao.spec
@ -1,15 +1,19 @@
|
|||||||
Summary: Writes audio CD-Rs in disk-at-once (DAO) mode.
|
Summary: Writes audio CD-Rs in disk-at-once (DAO) mode.
|
||||||
Name: cdrdao
|
Name: cdrdao
|
||||||
Version: 1.2.1
|
Version: 1.2.2
|
||||||
Release: 2
|
Release: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
URL: http://cdrdao.sourceforge.net/
|
URL: http://cdrdao.sourceforge.net/
|
||||||
Source: http://easynews.dl.sourceforge.net/sourceforge/cdrdao/%{name}-%{version}.tar.bz2
|
Source: http://easynews.dl.sourceforge.net/sourceforge/cdrdao/%{name}-%{version}.tar.bz2
|
||||||
Source1: xcdrdao.desktop
|
Source1: xcdrdao.desktop
|
||||||
|
|
||||||
|
Patch1: mkisofs-changelog.patch
|
||||||
|
Patch9: cdrdao-1.1.7-endianness.patch
|
||||||
|
Patch23: cdrtools-2.01a27-silly-warnings.patch
|
||||||
|
Patch30: cdrtools-2.0-O_EXCL.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: cdrecord-devel >= 9:2.01
|
|
||||||
BuildRequires: libvorbis-devel >= 1.0
|
BuildRequires: libvorbis-devel >= 1.0
|
||||||
|
|
||||||
# Only exclude s390
|
# Only exclude s390
|
||||||
@ -24,15 +28,17 @@ of pre-gaps, the pause areas between tracks.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
chmod a+rX -R .
|
||||||
|
%patch1 -p1 -b .changelog
|
||||||
|
%patch9 -p1 -b .endian
|
||||||
|
%patch23 -p1 -b .silly
|
||||||
|
%patch30 -p1 -b .excl
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --prefix=%{_prefix}\
|
%configure --prefix=%{_prefix}\
|
||||||
--without-xdao --without-lame \
|
--without-xdao --without-lame \
|
||||||
--with-pcctsbin=%{_prefix}/bin \
|
--with-pcctsbin=%{_prefix}/bin \
|
||||||
--with-pcctsinc=%{_prefix}/include/pccts \
|
--with-pcctsinc=%{_prefix}/include/pccts
|
||||||
--with-scglib=sys \
|
|
||||||
--with-scglib-inc=/usr/include/schily \
|
|
||||||
--with-scglib-lib=/usr/%{_lib}
|
|
||||||
make
|
make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -52,6 +58,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.2.2-1
|
||||||
|
- version 1.2.2
|
||||||
|
- built without cdrecord-devel now
|
||||||
|
|
||||||
* Mon Aug 21 2006 Harald Hoyer <harald@redhat.com> - 1.2.1-1.1
|
* Mon Aug 21 2006 Harald Hoyer <harald@redhat.com> - 1.2.1-1.1
|
||||||
- rebuild with new/old cdrtools
|
- rebuild with new/old cdrtools
|
||||||
|
|
||||||
|
103
cdrtools-2.0-O_EXCL.patch
Normal file
103
cdrtools-2.0-O_EXCL.patch
Normal file
@ -0,0 +1,103 @@
|
|||||||
|
--- cdrtools-2.01/scsilib/libscg/oexcl.c.excl 2004-09-22 12:03:23.426676328 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/oexcl.c 2004-09-22 12:03:23.426676328 +0200
|
||||||
|
@@ -0,0 +1,29 @@
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+#include <sys/stat.h>
|
||||||
|
+#include <fcntl.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
+
|
||||||
|
+int openexcl(const char *device, int mode)
|
||||||
|
+{
|
||||||
|
+ int f, i;
|
||||||
|
+
|
||||||
|
+ f = open(device, mode | O_EXCL);
|
||||||
|
+
|
||||||
|
+ if (f < 0) {
|
||||||
|
+ f = open(device, mode);
|
||||||
|
+
|
||||||
|
+ if (f >= 0) {
|
||||||
|
+ close(f);
|
||||||
|
+ f = -1;
|
||||||
|
+ for (i = 0; (i < 10) && (f == -1); i++) {
|
||||||
|
+ fprintf(stderr, "Error trying to open %s exclusively ... retrying in 1 second.\n", device);
|
||||||
|
+ usleep(1000000 + 100000.0 * rand()/(RAND_MAX+1.0));
|
||||||
|
+ f = open(device, O_RDONLY | O_NONBLOCK | O_EXCL);
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return f;
|
||||||
|
+}
|
||||||
|
--- cdrtools-2.01/scsilib/libscg/scsi-linux-ata.c.excl 2004-09-22 12:03:23.423676784 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-ata.c 2004-09-22 12:03:23.427676176 +0200
|
||||||
|
@@ -112,6 +112,7 @@
|
||||||
|
LOCAL void sglog __PR((const char *fmt, ...));
|
||||||
|
|
||||||
|
#include <vadefs.h>
|
||||||
|
+#include "oexcl.h"
|
||||||
|
|
||||||
|
/* VARARGS1 */
|
||||||
|
#ifdef PROTOTYPES
|
||||||
|
@@ -267,7 +268,7 @@
|
||||||
|
starget,
|
||||||
|
slun;
|
||||||
|
|
||||||
|
- f = open(device, O_RDWR | O_NONBLOCK);
|
||||||
|
+ f = openexcl(device, O_RDWR | O_NONBLOCK);
|
||||||
|
|
||||||
|
if (f < 0) {
|
||||||
|
if (scgp->errstr)
|
||||||
|
--- cdrtools-2.01/scsilib/libscg/oexcl.h.excl 2004-09-22 12:03:23.428676024 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/oexcl.h 2004-09-22 12:03:23.428676024 +0200
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+#ifndef OEXCL_H
|
||||||
|
+
|
||||||
|
+extern int openexcl(const char *device, int mode);
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
--- cdrtools-2.01/scsilib/libscg/Targets.excl 2002-10-19 20:33:37.000000000 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/Targets 2004-09-22 12:03:23.428676024 +0200
|
||||||
|
@@ -1,3 +1,3 @@
|
||||||
|
CFILES= scsitransp.c scsihack.c scsiopen.c scgsettarget.c \
|
||||||
|
- scsierrs.c scgtimes.c scsihelp.c \
|
||||||
|
+ scsierrs.c scgtimes.c scsihelp.c oexcl.c \
|
||||||
|
rdummy.c
|
||||||
|
--- cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c.excl 2004-09-22 12:03:23.422676936 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c 2004-09-22 12:12:49.271654816 +0200
|
||||||
|
@@ -79,6 +79,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include "scsi/sg.h"
|
||||||
|
+#include "oexcl.h"
|
||||||
|
|
||||||
|
#undef sense /* conflict in struct cdrom_generic_command */
|
||||||
|
#include <linux/cdrom.h>
|
||||||
|
@@ -94,7 +95,7 @@
|
||||||
|
* Choose your name instead of "schily" and make clear that the version
|
||||||
|
* string is related to a modified source.
|
||||||
|
*/
|
||||||
|
-LOCAL char _scg_trans_version[] = "scsi-linux-sg.c-1.83"; /* The version for this transport*/
|
||||||
|
+LOCAL char _scg_trans_version[] = "scsi-linux-sg.c-1.83-RH"; /* The version for this transport*/
|
||||||
|
|
||||||
|
#ifndef SCSI_IOCTL_GET_BUS_NUMBER
|
||||||
|
#define SCSI_IOCTL_GET_BUS_NUMBER 0x5386
|
||||||
|
@@ -247,7 +249,7 @@
|
||||||
|
* return "schily" for the SCG_AUTHOR request.
|
||||||
|
*/
|
||||||
|
case SCG_AUTHOR:
|
||||||
|
- return (_scg_auth_schily);
|
||||||
|
+ return ("schily - Red Hat");
|
||||||
|
case SCG_SCCS_ID:
|
||||||
|
return (__sccsid);
|
||||||
|
case SCG_KVERSION:
|
||||||
|
@@ -479,7 +483,7 @@
|
||||||
|
b = -1;
|
||||||
|
}
|
||||||
|
/* O_NONBLOCK is dangerous */
|
||||||
|
- f = open(device, O_RDWR | O_NONBLOCK);
|
||||||
|
+ f = openexcl(device, O_RDWR | O_NONBLOCK);
|
||||||
|
/* if (f < 0 && errno == ENOENT)*/
|
||||||
|
/* goto openpg;*/
|
||||||
|
|
54
cdrtools-2.01a27-silly-warnings.patch
Normal file
54
cdrtools-2.01a27-silly-warnings.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
--- cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c.silly 2004-05-20 15:42:12.000000000 +0200
|
||||||
|
+++ cdrtools-2.01/scsilib/libscg/scsi-linux-sg.c 2004-09-08 11:37:47.670038792 +0200
|
||||||
|
@@ -315,6 +315,10 @@
|
||||||
|
if (device != NULL && *device != '\0') {
|
||||||
|
#ifdef USE_ATA
|
||||||
|
if (strncmp(device, "ATAPI", 5) == 0) {
|
||||||
|
+ if (scgp->overbose) {
|
||||||
|
+ js_fprintf((FILE *)scgp->errfile,
|
||||||
|
+ "Use of ATA is preferred over ATAPI.\n");
|
||||||
|
+ }
|
||||||
|
scgp->ops = &ata_ops;
|
||||||
|
return (SCGO_OPEN(scgp, device));
|
||||||
|
}
|
||||||
|
@@ -336,18 +340,6 @@
|
||||||
|
*/
|
||||||
|
use_ata = TRUE;
|
||||||
|
device = NULL;
|
||||||
|
- if (scgp->overbose) {
|
||||||
|
- /*
|
||||||
|
- * I strongly encourage people who believe that
|
||||||
|
- * they need to patch this message away to read
|
||||||
|
- * the messages in the Solaris USCSI libscg
|
||||||
|
- * layer instead of wetting their tissues while
|
||||||
|
- * being unwilling to look besides their
|
||||||
|
- * own belly button.
|
||||||
|
- */
|
||||||
|
- js_fprintf((FILE *)scgp->errfile,
|
||||||
|
- "Warning: Using badly designed ATAPI via /dev/hd* interface.\n");
|
||||||
|
- }
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -497,20 +489,7 @@
|
||||||
|
if (b < 0 || b > 25)
|
||||||
|
b = -1;
|
||||||
|
}
|
||||||
|
- if (scgp->overbose) {
|
||||||
|
- /*
|
||||||
|
- * Before you patch this away, are you sure that you
|
||||||
|
- * know what you are going to to?
|
||||||
|
- *
|
||||||
|
- * Note that this is a warning that helps users from
|
||||||
|
- * cdda2wav, mkisofs and other programs (that
|
||||||
|
- * distinguish SCSI addresses from file names) from
|
||||||
|
- * getting unexpected results.
|
||||||
|
- */
|
||||||
|
- js_fprintf((FILE *)scgp->errfile,
|
||||||
|
- "Warning: Open by 'devname' is unintentional and not supported.\n");
|
||||||
|
- }
|
||||||
|
- /* O_NONBLOCK is dangerous */
|
||||||
|
+ /* O_NONBLOCK is dangerous */
|
||||||
|
f = open(device, O_RDWR | O_NONBLOCK);
|
||||||
|
/* if (f < 0 && errno == ENOENT)*/
|
||||||
|
/* goto openpg;*/
|
9
mkisofs-changelog.patch
Normal file
9
mkisofs-changelog.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- cdrtools-1.10/mkisofs/ChangeLog.changelog Sat Apr 7 17:34:04 2001
|
||||||
|
+++ cdrtools-1.10/mkisofs/ChangeLog Thu Apr 19 01:02:24 2001
|
||||||
|
@@ -0,0 +1,6 @@
|
||||||
|
+**************** Packager's Note ******************
|
||||||
|
+Tue Aug 8 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||||
|
+ * graft-points are NO LONGER assuemd,
|
||||||
|
+ you must specify '-graft-points'
|
||||||
|
+
|
||||||
|
+
|
Loading…
Reference in New Issue
Block a user