Fix LDFLAGS propagation
Stop building with -O0
This commit is contained in:
parent
fe93f5807e
commit
81b433568a
24
cdparanoia-10.2-ldflags.patch
Normal file
24
cdparanoia-10.2-ldflags.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up cdparanoia-III-10.2/interface/Makefile.in.jx cdparanoia-III-10.2/interface/Makefile.in
|
||||
--- cdparanoia-III-10.2/interface/Makefile.in.jx 2008-08-21 12:08:54.000000000 -0400
|
||||
+++ cdparanoia-III-10.2/interface/Makefile.in 2018-03-07 13:12:53.999947802 -0500
|
||||
@@ -46,7 +46,7 @@ libcdda_interface.a: $(OFILES)
|
||||
$(RANLIB) libcdda_interface.a
|
||||
|
||||
libcdda_interface.so: $(OFILES)
|
||||
- $(CC) -fpic -shared -o libcdda_interface.so.0.$(VERSION) -Wl,-soname -Wl,libcdda_interface.so.0 $(OFILES) $(LIBS)
|
||||
+ $(CC) $(LDFLAGS) -fpic -shared -o libcdda_interface.so.0.$(VERSION) -Wl,-soname -Wl,libcdda_interface.so.0 $(OFILES) $(LIBS)
|
||||
[ -e libcdda_interface.so.0 ] || ln -s libcdda_interface.so.0.$(VERSION) libcdda_interface.so.0
|
||||
[ -e libcdda_interface.so ] || ln -s libcdda_interface.so.0.$(VERSION) libcdda_interface.so
|
||||
|
||||
diff -up cdparanoia-III-10.2/paranoia/Makefile.in.jx cdparanoia-III-10.2/paranoia/Makefile.in
|
||||
--- cdparanoia-III-10.2/paranoia/Makefile.in.jx 2008-09-04 15:02:47.000000000 -0400
|
||||
+++ cdparanoia-III-10.2/paranoia/Makefile.in 2018-03-07 13:12:39.352765050 -0500
|
||||
@@ -44,7 +44,7 @@ libcdda_paranoia.a: $(OFILES)
|
||||
$(RANLIB) libcdda_paranoia.a
|
||||
|
||||
libcdda_paranoia.so: $(OFILES)
|
||||
- $(CC) -fpic -shared -o libcdda_paranoia.so.0.$(VERSION) -Wl,-soname -Wl,libcdda_paranoia.so.0 $(OFILES) -L ../interface -lcdda_interface
|
||||
+ $(CC) $(LDFLAGS) -fpic -shared -o libcdda_paranoia.so.0.$(VERSION) -Wl,-soname -Wl,libcdda_paranoia.so.0 $(OFILES) -L ../interface -lcdda_interface
|
||||
[ -e libcdda_paranoia.so.0 ] || ln -s libcdda_paranoia.so.0.$(VERSION) libcdda_paranoia.so.0
|
||||
[ -e libcdda_paranoia.so ] || ln -s libcdda_paranoia.so.0.$(VERSION) libcdda_paranoia.so
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: Compact Disc Digital Audio (CDDA) extraction tool (or ripper)
|
||||
Name: cdparanoia
|
||||
Version: 10.2
|
||||
Release: 26%{?dist}
|
||||
Release: 27%{?dist}
|
||||
# the app is GPLv2, everything else is LGPLv2
|
||||
License: GPLv2 and LGPLv2
|
||||
Group: Applications/Multimedia
|
||||
@ -17,6 +17,7 @@ Patch1: cdparanoia-10.2-endian.patch
|
||||
Patch2: cdparanoia-10.2-install.patch
|
||||
Patch3: cdparanoia-10.2-format-security.patch
|
||||
Patch4: cdparanoia-use-proper-gnu-config-files.patch
|
||||
Patch5: cdparanoia-10.2-ldflags.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
@ -66,16 +67,16 @@ for developing applications to read CD Digital Audio disks.
|
||||
%patch2 -p1 -b .install
|
||||
%patch3 -p1 -b .fmt-sec
|
||||
%patch4 -p1 -b .config
|
||||
%patch5 -p1 -b .ldflags
|
||||
|
||||
# Update config.guess/sub for newer architectures
|
||||
cp /usr/lib/rpm/redhat/config.* .
|
||||
|
||||
%build
|
||||
%configure --includedir=%{_includedir}/cdda
|
||||
# Using -O0 is mandatory, the build fails otherwise...
|
||||
# Also remove many warnings which we are aware of
|
||||
# Lastly, don't use _smp_mflags since it also makes the build fail
|
||||
make OPT="$RPM_OPT_FLAGS -O0 -Wno-pointer-sign -Wno-unused"
|
||||
make OPT="$RPM_OPT_FLAGS -Wno-pointer-sign -Wno-unused" LDFLAGS="%{?__global_ldflags}"
|
||||
|
||||
|
||||
%install
|
||||
@ -99,6 +100,10 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%{_libdir}/*.a
|
||||
|
||||
%changelog
|
||||
* Wed Mar 07 2018 Adam Jackson <ajax@redhat.com> - 10.2-27
|
||||
- Fix LDFLAGS propagation
|
||||
- Stop building with -O0
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 10.2-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user