Update config.guess config.sub to build on new architectures, Cleanup spec
This commit is contained in:
parent
8b84a5fd0f
commit
355d8d0187
27
cdparanoia-use-proper-gnu-config-files.patch
Normal file
27
cdparanoia-use-proper-gnu-config-files.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
Index: cdparanoia-III-10.2/configure
|
||||||
|
===================================================================
|
||||||
|
--- cdparanoia-III-10.2.orig/configure
|
||||||
|
+++ cdparanoia-III-10.2/configure
|
||||||
|
@@ -1289,9 +1289,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
-cp $srcdir/configure.guess $srcdir/config.guess
|
||||||
|
-cp $srcdir/configure.sub $srcdir/config.sub
|
||||||
|
-
|
||||||
|
ac_aux_dir=
|
||||||
|
for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
|
||||||
|
if test -f $ac_dir/install-sh; then
|
||||||
|
Index: cdparanoia-III-10.2/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- cdparanoia-III-10.2.orig/configure.in
|
||||||
|
+++ cdparanoia-III-10.2/configure.in
|
||||||
|
@@ -1,8 +1,5 @@
|
||||||
|
AC_INIT(interface/interface.c)
|
||||||
|
|
||||||
|
-cp $srcdir/configure.guess $srcdir/config.guess
|
||||||
|
-cp $srcdir/configure.sub $srcdir/config.sub
|
||||||
|
-
|
||||||
|
AC_CANONICAL_HOST
|
||||||
|
|
||||||
|
if test -z "$CC"; then
|
@ -1,11 +1,12 @@
|
|||||||
Summary: Compact Disc Digital Audio (CDDA) extraction tool (or ripper)
|
Summary: Compact Disc Digital Audio (CDDA) extraction tool (or ripper)
|
||||||
Name: cdparanoia
|
Name: cdparanoia
|
||||||
Version: 10.2
|
Version: 10.2
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
# the app is GPLv2, everything else is LGPLv2
|
# the app is GPLv2, everything else is LGPLv2
|
||||||
License: GPLv2 and LGPLv2
|
License: GPLv2 and LGPLv2
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
URL: http://www.xiph.org/paranoia/index.html
|
URL: http://www.xiph.org/paranoia/index.html
|
||||||
|
|
||||||
Source: http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-%{version}.src.tgz
|
Source: http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-%{version}.src.tgz
|
||||||
# Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
|
# Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
|
||||||
# https://trac.xiph.org/changeset/15338
|
# https://trac.xiph.org/changeset/15338
|
||||||
@ -15,9 +16,9 @@ Patch0: cdparanoia-10.2-#463009.patch
|
|||||||
Patch1: cdparanoia-10.2-endian.patch
|
Patch1: cdparanoia-10.2-endian.patch
|
||||||
Patch2: cdparanoia-10.2-install.patch
|
Patch2: cdparanoia-10.2-install.patch
|
||||||
Patch3: cdparanoia-10.2-format-security.patch
|
Patch3: cdparanoia-10.2-format-security.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
Patch4: cdparanoia-use-proper-gnu-config-files.patch
|
||||||
Requires: cdparanoia-libs = %{version}-%{release}
|
|
||||||
Obsoletes: cdparanoia-III <= alpha9.8
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
|
Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
|
||||||
@ -51,7 +52,7 @@ applications which read CD Digital Audio disks.
|
|||||||
%package devel
|
%package devel
|
||||||
Summary: Development tools for libcdda_paranoia (Paranoia III)
|
Summary: Development tools for libcdda_paranoia (Paranoia III)
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: cdparanoia-libs = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
@ -64,6 +65,10 @@ for developing applications to read CD Digital Audio disks.
|
|||||||
%patch1 -p1 -b .endian
|
%patch1 -p1 -b .endian
|
||||||
%patch2 -p1 -b .install
|
%patch2 -p1 -b .install
|
||||||
%patch3 -p1 -b .fmt-sec
|
%patch3 -p1 -b .fmt-sec
|
||||||
|
%patch4 -p1 -b .config
|
||||||
|
|
||||||
|
# Update config.guess/sub for newer architectures
|
||||||
|
cp /usr/lib/rpm/redhat/config.* .
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --includedir=%{_includedir}/cdda
|
%configure --includedir=%{_includedir}/cdda
|
||||||
@ -74,37 +79,32 @@ make OPT="$RPM_OPT_FLAGS -O0 -Wno-pointer-sign -Wno-unused"
|
|||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc COPYING* README
|
%doc COPYING* README
|
||||||
%{_bindir}/cdparanoia
|
%{_bindir}/cdparanoia
|
||||||
%{_mandir}/man1/cdparanoia.1*
|
%{_mandir}/man1/cdparanoia.1*
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_includedir}/cdda/
|
%{_includedir}/cdda/
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
|
|
||||||
%files static
|
%files static
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat May 3 2014 Peter Robinson <pbrobinson@fedoraproject.org> 10.2-16
|
||||||
|
- Update config.guess config.sub to build on new architectures
|
||||||
|
- Cleanup spec
|
||||||
|
|
||||||
* Mon Apr 14 2014 Jaromir Capik <jcapik@redhat.com> - 10.2-15
|
* Mon Apr 14 2014 Jaromir Capik <jcapik@redhat.com> - 10.2-15
|
||||||
- Fixing format-security flaws (#1037011)
|
- Fixing format-security flaws (#1037011)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user