First import after review (#804659)
This commit is contained in:
parent
21221e871a
commit
0c70b069a8
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/cdi-api-1.0.SP4.tar.xz
|
25
cdi-api-1.0.SP4-pom.patch
Normal file
25
cdi-api-1.0.SP4-pom.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
--- cdi-api-1.0.SP4/pom.xml 2010-12-16 14:10:21.000000000 -0500
|
||||||
|
+++ cdi-api-1.0.SP4-work/pom.xml 2012-03-19 09:05:04.611002728 -0400
|
||||||
|
@@ -1,13 +1,6 @@
|
||||||
|
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||||
|
<modelVersion>4.0.0</modelVersion>
|
||||||
|
|
||||||
|
- <parent>
|
||||||
|
- <groupId>org.jboss.weld</groupId>
|
||||||
|
- <artifactId>weld-parent</artifactId>
|
||||||
|
- <version>17</version>
|
||||||
|
- <relativePath />
|
||||||
|
- </parent>
|
||||||
|
-
|
||||||
|
<groupId>javax.enterprise</groupId>
|
||||||
|
<artifactId>cdi-api</artifactId>
|
||||||
|
<packaging>jar</packaging>
|
||||||
|
@@ -70,7 +63,7 @@
|
||||||
|
|
||||||
|
<properties>
|
||||||
|
<atinject.api.version>1</atinject.api.version>
|
||||||
|
- <ejb.api.version>1.0.0.CR2</ejb.api.version>
|
||||||
|
+ <ejb.api.version>1.0.1.Final</ejb.api.version>
|
||||||
|
<jsr250.api.version>1.0</jsr250.api.version>
|
||||||
|
<uel.api.version>2.2</uel.api.version>
|
||||||
|
<interceptor.api.version>1.0.0.Beta1</interceptor.api.version>
|
92
cdi-api.spec
Normal file
92
cdi-api.spec
Normal file
@ -0,0 +1,92 @@
|
|||||||
|
%global namedreltag .SP4
|
||||||
|
%global namedversion %{version}%{?namedreltag}
|
||||||
|
|
||||||
|
Name: cdi-api
|
||||||
|
Version: 1.0
|
||||||
|
Release: 3%{namedreltag}%{?dist}
|
||||||
|
Summary: CDI API
|
||||||
|
Group: Development/Libraries
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: http://seamframework.org/Weld
|
||||||
|
|
||||||
|
# svn export http://anonsvn.jboss.org/repos/weld/cdi-api/tags/1.0-SP4/ cdi-api-1.0.SP4
|
||||||
|
# tar cafJ cdi-api-1.0.SP4.tar.xz cdi-api-1.0.SP4
|
||||||
|
Source0: %{name}-%{namedversion}.tar.xz
|
||||||
|
|
||||||
|
Patch0: %{name}-%{namedversion}-pom.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
BuildRequires: java-devel
|
||||||
|
BuildRequires: maven
|
||||||
|
BuildRequires: maven-compiler-plugin
|
||||||
|
BuildRequires: maven-install-plugin
|
||||||
|
BuildRequires: maven-jar-plugin
|
||||||
|
BuildRequires: maven-javadoc-plugin
|
||||||
|
BuildRequires: maven-surefire-provider-testng
|
||||||
|
BuildRequires: testng
|
||||||
|
BuildRequires: jboss-el-2.2-api
|
||||||
|
BuildRequires: jboss-interceptors-1.1-api
|
||||||
|
BuildRequires: jboss-ejb-3.1-api
|
||||||
|
|
||||||
|
Requires: jpackage-utils
|
||||||
|
Requires: java
|
||||||
|
Requires: jboss-el-2.2-api
|
||||||
|
Requires: jboss-interceptors-1.1-api
|
||||||
|
Requires: jboss-ejb-3.1-api
|
||||||
|
|
||||||
|
%description
|
||||||
|
APIs for JSR-299: Contexts and Dependency Injection for Java EE
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadocs for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
Requires: jpackage-utils
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
This package contains the API documentation for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{namedversion}
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
mvn-rpmbuild install javadoc:aggregate
|
||||||
|
|
||||||
|
%install
|
||||||
|
install -d -m 755 %{buildroot}%{_javadir}
|
||||||
|
install -d -m 755 %{buildroot}%{_mavenpomdir}
|
||||||
|
install -d -m 755 %{buildroot}%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
# JAR
|
||||||
|
install -pm 644 target/cdi-api-%{version}-SP4.jar %{buildroot}%{_javadir}/%{name}.jar
|
||||||
|
|
||||||
|
# POM
|
||||||
|
install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
|
||||||
|
|
||||||
|
# DEPMAP
|
||||||
|
%add_maven_depmap JPP-%{name}.pom %{name}.jar
|
||||||
|
|
||||||
|
# APIDOCS
|
||||||
|
cp -rp target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_mavenpomdir}/*
|
||||||
|
%{_mavendepmapfragdir}/*
|
||||||
|
%{_javadir}/*
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Mar 25 2012 Asaf Shakarchi <asaf@redhat.com> 1.0-3.SP4
|
||||||
|
- Fixed changelog versions.
|
||||||
|
|
||||||
|
* Wed Mar 16 2012 Asaf Shakarchi <asaf@redhat.com> 1.0-2.SP4
|
||||||
|
- Added required dependencies, modified patches and cleaned spec.
|
||||||
|
|
||||||
|
* Mon Feb 20 2012 Marek Goldmann <mgoldman@redhat.com> 1.0-1.SP4
|
||||||
|
- Initial packaging
|
||||||
|
|
Loading…
Reference in New Issue
Block a user