cairo/cairo-1.17.4-meson-xcb.patch
David King cf8a21ba47 Switch to meson
Additionally, use pkgconfig for BuildRequires.
2022-02-15 13:54:37 +00:00

43 lines
1.5 KiB
Diff

From 3468c67fe91f0c37e0ec5d335082653a6fa609b6 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Thu, 25 Feb 2021 01:27:10 +0000
Subject: [PATCH] meson: add xlib-xcb option and disable by default
Just like autotools does.
Closes #438.
---
meson.build | 3 +--
meson_options.txt | 1 +
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index 96dd1abd4..b1759b5f3 100644
--- a/meson.build
+++ b/meson.build
@@ -331,8 +331,7 @@ if xcb_dep.found() and xcb_render_dep.found()
endif
if feature_conf.get('CAIRO_HAS_XCB_SURFACE', 0) == 1 and feature_conf.get('CAIRO_HAS_XLIB_SURFACE', 0) == 1
- # FIXME: automagic
- x11xcb_dep = dependency('x11-xcb', required: false)
+ x11xcb_dep = dependency('x11-xcb', required: get_option('xlib-xcb'))
if x11xcb_dep.found()
deps += [x11xcb_dep]
feature_conf.set('CAIRO_HAS_XLIB_XCB_FUNCTIONS', 1)
diff --git a/meson_options.txt b/meson_options.txt
index 2b4b46f7b..7ec0dc92a 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -18,6 +18,7 @@ option('qt', type : 'feature', value : 'disabled')
option('tee', type : 'feature', value : 'disabled')
option('xcb', type : 'feature', value : 'auto')
option('xlib', type : 'feature', value : 'auto')
+option('xlib-xcb', type : 'feature', value : 'disabled')
#option('xml', type : 'feature', value : 'disabled')
option('zlib', type : 'feature', value : 'auto') # script, ps, pdf, xml surfaces
--
GitLab