add patch from master to fix issues with weston
This commit is contained in:
parent
dba9aa016e
commit
1c9c67fab4
38
cairo-f59b0914f4ddbff0d116c918343a6726d5f4317b.patch
Normal file
38
cairo-f59b0914f4ddbff0d116c918343a6726d5f4317b.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From f59b0914f4ddbff0d116c918343a6726d5f4317b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chris Wilson <chris@chris-wilson.co.uk>
|
||||||
|
Date: Sat, 11 Aug 2012 16:38:36 +0000
|
||||||
|
Subject: egl: s/EGL_KHR_surfaceless_opengl/EGL_KHR_surfaceless_context/
|
||||||
|
|
||||||
|
Mesa changed the name of the extension it invented, so check for the
|
||||||
|
real name and the old name before falling back to pbuffers which are not
|
||||||
|
supported by most EGL implementations.
|
||||||
|
|
||||||
|
References: https://bugs.freedesktop.org/show_bug.cgi?id=53361
|
||||||
|
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
|
||||||
|
---
|
||||||
|
diff --git a/src/cairo-egl-context.c b/src/cairo-egl-context.c
|
||||||
|
index eb1ef29..b24bc80 100644
|
||||||
|
--- a/src/cairo-egl-context.c
|
||||||
|
+++ b/src/cairo-egl-context.c
|
||||||
|
@@ -122,8 +122,10 @@ _egl_make_current_surfaceless(cairo_egl_context_t *ctx)
|
||||||
|
const char *extensions;
|
||||||
|
|
||||||
|
extensions = eglQueryString(ctx->display, EGL_EXTENSIONS);
|
||||||
|
- if (!strstr(extensions, "EGL_KHR_surfaceless_opengl"))
|
||||||
|
+ if (strstr(extensions, "EGL_KHR_surfaceless_context") == NULL &&
|
||||||
|
+ strstr(extensions, "EGL_KHR_surfaceless_opengl") == NULL)
|
||||||
|
return FALSE;
|
||||||
|
+
|
||||||
|
if (!eglMakeCurrent(ctx->display,
|
||||||
|
EGL_NO_SURFACE, EGL_NO_SURFACE, ctx->context))
|
||||||
|
return FALSE;
|
||||||
|
@@ -174,7 +176,6 @@ cairo_egl_device_create (EGLDisplay dpy, EGLContext egl)
|
||||||
|
eglChooseConfig (dpy, config_attribs, &config, 1, &numConfigs);
|
||||||
|
|
||||||
|
ctx->dummy_surface = eglCreatePbufferSurface (dpy, config, attribs);
|
||||||
|
-
|
||||||
|
if (ctx->dummy_surface == NULL) {
|
||||||
|
free (ctx);
|
||||||
|
return _cairo_gl_context_create_in_error (CAIRO_STATUS_NO_MEMORY);
|
||||||
|
--
|
||||||
|
cgit v0.9.0.2-2-gbebe
|
10
cairo.spec
10
cairo.spec
@ -5,11 +5,15 @@
|
|||||||
Summary: A 2D graphics library
|
Summary: A 2D graphics library
|
||||||
Name: cairo
|
Name: cairo
|
||||||
Version: 1.12.2
|
Version: 1.12.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
URL: http://cairographics.org
|
URL: http://cairographics.org
|
||||||
#VCS: git:git://git.freedesktop.org/git/cairo
|
#VCS: git:git://git.freedesktop.org/git/cairo
|
||||||
#Source0: http://cairographics.org/snapshots/%{name}-%{version}.tar.xz
|
#Source0: http://cairographics.org/snapshots/%{name}-%{version}.tar.xz
|
||||||
Source0: http://cairographics.org/releases/%{name}-%{version}.tar.xz
|
Source0: http://cairographics.org/releases/%{name}-%{version}.tar.xz
|
||||||
|
# Patch0 committed to master on 2012-08-11
|
||||||
|
# Background: https://bugs.freedesktop.org/show_bug.cgi?id=53361
|
||||||
|
# Commit: http://cgit.freedesktop.org/cairo/commit/?id=f59b0914f4ddbff0d116c918343a6726d5f4317b
|
||||||
|
Patch0: %{name}-f59b0914f4ddbff0d116c918343a6726d5f4317b.patch
|
||||||
License: LGPLv2 or MPLv1.1
|
License: LGPLv2 or MPLv1.1
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
|
|
||||||
@ -91,6 +95,7 @@ This package contains tools for working with the cairo graphics library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .patch0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static \
|
%configure --disable-static \
|
||||||
@ -185,6 +190,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/cairo/
|
%{_libdir}/cairo/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 18 2012 Thorsten Leemhuis <fedora@leemhuis.info> - 1.12.2-4
|
||||||
|
- add patch from master to fix issues with weston
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.2-3
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.2-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user