Update to 1.15.14
This commit is contained in:
parent
d6806f5a23
commit
104f20186d
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ cairo-1.9.14.tar.gz
|
|||||||
/cairo-1.15.8.tar.xz
|
/cairo-1.15.8.tar.xz
|
||||||
/cairo-1.15.10.tar.xz
|
/cairo-1.15.10.tar.xz
|
||||||
/cairo-1.15.12.tar.xz
|
/cairo-1.15.12.tar.xz
|
||||||
|
/cairo-1.15.14.tar.xz
|
||||||
|
@ -1,51 +0,0 @@
|
|||||||
From 7554822dd0b52d33ec7898e81b59e97164b00142 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Uli Schlachter <psychon@znc.in>
|
|
||||||
Date: Sat, 21 Apr 2018 09:37:06 +0200
|
|
||||||
Subject: [PATCH] Fix assertion failure in the freetype backend
|
|
||||||
|
|
||||||
Fonts are kept in a hash table, so when creating a new font, the code
|
|
||||||
first checks the hash table for an already-existing entry and only then
|
|
||||||
is a new instance really created. There is an assert that checks that
|
|
||||||
the key used for the hash table lookup is the same as the instance that
|
|
||||||
is created later has, because otherwise the hash table was checked
|
|
||||||
incorrectly.
|
|
||||||
|
|
||||||
This assert failed in some conditions.
|
|
||||||
|
|
||||||
Fix this by fixing some places that initialised ft hash keys in a wrong
|
|
||||||
way.
|
|
||||||
|
|
||||||
Patch by Behdad Esfahbod and submitted via bugzilla.
|
|
||||||
|
|
||||||
Source: https://bugs.freedesktop.org/show_bug.cgi?id=105746#c4
|
|
||||||
Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=105746
|
|
||||||
Signed-off-by: Uli Schlachter <psychon@znc.in>
|
|
||||||
---
|
|
||||||
src/cairo-ft-font.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c
|
|
||||||
index 79aef78f5b0d..9b10708988d7 100644
|
|
||||||
--- a/src/cairo-ft-font.c
|
|
||||||
+++ b/src/cairo-ft-font.c
|
|
||||||
@@ -445,7 +445,7 @@ _cairo_ft_unscaled_font_init (cairo_ft_unscaled_font_t *unscaled,
|
|
||||||
|
|
||||||
if (from_face) {
|
|
||||||
unscaled->from_face = TRUE;
|
|
||||||
- _cairo_ft_unscaled_font_init_key (unscaled, TRUE, NULL, face->face_index, face);
|
|
||||||
+ _cairo_ft_unscaled_font_init_key (unscaled, TRUE, NULL, id, face);
|
|
||||||
|
|
||||||
|
|
||||||
unscaled->have_color = FT_HAS_COLOR (face) != 0;
|
|
||||||
@@ -640,7 +640,7 @@ static cairo_status_t
|
|
||||||
_cairo_ft_unscaled_font_create_from_face (FT_Face face,
|
|
||||||
cairo_ft_unscaled_font_t **out)
|
|
||||||
{
|
|
||||||
- return _cairo_ft_unscaled_font_create_internal (TRUE, NULL, 0, face, out);
|
|
||||||
+ return _cairo_ft_unscaled_font_create_internal (TRUE, NULL, face->face_index, face, out);
|
|
||||||
}
|
|
||||||
|
|
||||||
static cairo_bool_t
|
|
||||||
--
|
|
||||||
2.17.0
|
|
||||||
|
|
10
cairo.spec
10
cairo.spec
@ -10,17 +10,14 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: cairo
|
Name: cairo
|
||||||
Version: 1.15.12
|
Version: 1.15.14
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A 2D graphics library
|
Summary: A 2D graphics library
|
||||||
|
|
||||||
License: LGPLv2 or MPLv1.1
|
License: LGPLv2 or MPLv1.1
|
||||||
URL: http://cairographics.org
|
URL: http://cairographics.org
|
||||||
Source0: http://cairographics.org/snapshots/%{name}-%{version}.tar.xz
|
Source0: http://cairographics.org/snapshots/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-Fix-assertion-failure-in-the-freetype-backend.patch
|
|
||||||
|
|
||||||
Patch3: cairo-multilib.patch
|
Patch3: cairo-multilib.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -176,6 +173,9 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
|
|||||||
%{_libdir}/cairo/
|
%{_libdir}/cairo/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 22 2018 Kalev Lember <klember@redhat.com> - 1.15.14-1
|
||||||
|
- Update to 1.15.14
|
||||||
|
|
||||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.12-3
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.12-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cairo-1.15.12.tar.xz) = 97fb2c515f6449c1d84dc3187d11187290a219d39f8168a4367ca43505da80167df93b609a69b7e3938e9d38a2b7db459ad7130d9b5f12ff8c898994dfaa6d7e
|
SHA512 (cairo-1.15.14.tar.xz) = dee0827eac551ca09dc7ab4638932bda63e337707f04573613a3c972e529b69b833730d841488282ba212a234b0b8b34b0a9e94bfdb33d892d79d1c1d9bc5c1b
|
||||||
|
Loading…
Reference in New Issue
Block a user