c2esp/c2esp-drv_only.patch
2013-05-23 15:29:38 +02:00

35 lines
1.0 KiB
Diff

diff -up c2esp26/Makefile.noppd c2esp26/Makefile
--- c2esp26/Makefile.noppd 2013-05-09 16:28:47.000000000 +0200
+++ c2esp26/Makefile 2013-05-09 16:53:13.012203891 +0200
@@ -32,6 +32,7 @@ FILTERBIN := $(DESTDIR)$(shell cups-conf
MANDIR=$(PREFIX)/share/man
DOCDIR=$(PREFIX)/share/doc/c2esp
PPDDIR=$(PREFIX)/share/ppd/c2esp
+DRVDIR=$(DESTDIR)$(shell cups-config --datadir)/drv/c2esp
INSTALL=install
# Programs and libraries
@@ -247,7 +248,7 @@ myopldecode: myopldecode.o
# Installation rules
#
#install: all install-test install-prog install-ppd install-doc
-install: all install-prog install-ppd install-doc
+install: all install-prog install-drv install-doc
#
# Now use your printer configuration GUI to create a new printer if required.
@@ -291,8 +292,11 @@ install-prog:
fi
MODEL=$(DESTDIR)$(shell cups-config --datadir)/model
-PPD=$(DESTDIR)/usr/share/ppd
-VARPPD=/var/lp/ppd
+
+install-drv:
+ $(INSTALL) -d -m 755 $(DRVDIR)
+ $(INSTALL) -c -m 644 $(ESPDRVFILE) $(DRVDIR)
+ $(INSTALL) -c -m 644 $(CDRVFILE) $(DRVDIR)
install-ppd:
#