2.7~rc1
This commit is contained in:
parent
c6898fdc1e
commit
5e2bd54211
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/c2esp26.tar.gz
|
||||
/c2esp27~rc1.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
diff -up c2esp26/Makefile.noppd c2esp26/Makefile
|
||||
--- c2esp26/Makefile.noppd 2013-05-09 16:28:47.000000000 +0200
|
||||
+++ c2esp26/Makefile 2013-05-09 16:53:13.012203891 +0200
|
||||
@@ -32,6 +32,7 @@ FILTERBIN := $(DESTDIR)$(shell cups-conf
|
||||
MANDIR=$(PREFIX)/share/man
|
||||
DOCDIR=$(PREFIX)/share/doc/c2esp
|
||||
PPDDIR=$(PREFIX)/share/ppd/c2esp
|
||||
+DRVDIR=$(DESTDIR)$(shell cups-config --datadir)/drv/c2esp
|
||||
INSTALL=install
|
||||
|
||||
# Programs and libraries
|
||||
@@ -247,7 +248,7 @@ myopldecode: myopldecode.o
|
||||
# Installation rules
|
||||
#
|
||||
#install: all install-test install-prog install-ppd install-doc
|
||||
-install: all install-prog install-ppd install-doc
|
||||
+install: all install-prog install-drv install-doc
|
||||
|
||||
#
|
||||
# Now use your printer configuration GUI to create a new printer if required.
|
||||
@@ -291,8 +292,11 @@ install-prog:
|
||||
fi
|
||||
|
||||
MODEL=$(DESTDIR)$(shell cups-config --datadir)/model
|
||||
-PPD=$(DESTDIR)/usr/share/ppd
|
||||
-VARPPD=/var/lp/ppd
|
||||
+
|
||||
+install-drv:
|
||||
+ $(INSTALL) -d -m 755 $(DRVDIR)
|
||||
+ $(INSTALL) -c -m 644 $(ESPDRVFILE) $(DRVDIR)
|
||||
+ $(INSTALL) -c -m 644 $(CDRVFILE) $(DRVDIR)
|
||||
|
||||
install-ppd:
|
||||
#
|
@ -1,47 +1,12 @@
|
||||
diff -up c2esp26/Makefile.jbig c2esp26/Makefile
|
||||
--- c2esp26/Makefile.jbig 2012-09-06 01:18:06.000000000 +0200
|
||||
+++ c2esp26/Makefile 2013-05-09 15:49:53.845249368 +0200
|
||||
@@ -42,8 +42,6 @@ PROGS=
|
||||
DEVPROGS= myopldecode
|
||||
SCRIPTS= c2esplog
|
||||
FILTERS= c2esp c2espC command2esp
|
||||
-LIBJBG = jbig.o jbig_ar.o
|
||||
-LIBJBG85= jbig85.o jbig_ar.o
|
||||
diff -up c2esp27~rc1/Makefile.jbig c2esp27~rc1/Makefile
|
||||
--- c2esp27~rc1/Makefile.jbig 2013-12-17 01:04:13.000000000 +0100
|
||||
+++ c2esp27~rc1/Makefile 2013-12-19 13:37:36.920169463 +0100
|
||||
@@ -44,7 +44,7 @@ FILTERS= c2esp c2espC command2esp
|
||||
# The jbig library. Debian and derivatives should now have the jbig library -ljbig
|
||||
# -ljbig also contains jbig85
|
||||
LIBJBIG := -ljbig
|
||||
- LIBJBIG85 := -ljbig
|
||||
+ LIBJBIG85 := -ljbig85
|
||||
|
||||
BINPROGS=
|
||||
ESPDRVFILE = KodakESP_15.drv
|
||||
CDRVFILE = KodakESP_C_05.drv
|
||||
@@ -233,8 +231,8 @@ all-done:
|
||||
@echo "Patent warning that used to be here no longer applies"
|
||||
@echo
|
||||
|
||||
-c2esp: c2esp.o c2espcommon.o $(LIBJBG85)
|
||||
- $(CC) $(CFLAGS) -o $@ c2esp.o c2espcommon.o $(LIBCUPSDRIVER) $(LIBCUPSIMAGE) $(LIBJBG85)
|
||||
+c2esp: c2esp.o c2espcommon.o
|
||||
+ $(CC) $(CFLAGS) -o $@ c2esp.o c2espcommon.o $(LIBCUPSDRIVER) $(LIBCUPSIMAGE) -ljbig85
|
||||
|
||||
c2espC: c2espC.o c2espcommon.o
|
||||
$(CC) $(CFLAGS) -o $@ c2espC.o c2espcommon.o $(LIBCUPSDRIVER) $(LIBCUPSIMAGE) -lz
|
||||
@@ -242,8 +240,8 @@ c2espC: c2espC.o c2espcommon.o
|
||||
command2esp: command2esp.o c2espcommon.o
|
||||
$(CC) $(CFLAGS) -o $@ command2esp.o c2espcommon.o $(LIBCUPSDRIVER)
|
||||
|
||||
-myopldecode: myopldecode.o $(LIBJBG)
|
||||
- $(CC) $(CFLAGS) -o $@ $@.o $(LIBJBG) -lz
|
||||
+myopldecode: myopldecode.o
|
||||
+ $(CC) $(CFLAGS) -o $@ $@.o -ljbig -lz
|
||||
|
||||
#
|
||||
# Installation rules
|
||||
@@ -395,11 +393,8 @@ clean:
|
||||
#
|
||||
# Header dependencies
|
||||
#
|
||||
-jbig.o: jbig.h
|
||||
-jbig85.o: jbig85.h
|
||||
-c2esp.o: jbig85.h c2espcommon.h
|
||||
+c2esp.o: c2espcommon.h
|
||||
c2espC.o: c2espcommon.h
|
||||
-myopldecode.o: jbig.h
|
||||
command2esp.o: c2espcommon.h
|
||||
c2espcommon.o: c2espcommon.h
|
||||
|
||||
ESPDRVFILE = KodakESP_16.drv
|
||||
|
25
c2esp.spec
25
c2esp.spec
@ -1,17 +1,17 @@
|
||||
%global version_no_dot 26
|
||||
%global version_no_dot 27
|
||||
%global alphatag rc1
|
||||
|
||||
Name: c2esp
|
||||
Version: 2.6
|
||||
Release: 2%{?dist}
|
||||
Version: 2.7
|
||||
Release: 0.1.%{alphatag}%{?dist}
|
||||
Summary: CUPS driver for Kodak AiO printers
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: http://sourceforge.net/projects/cupsdriverkodak/
|
||||
Source0: http://downloads.sourceforge.net/cupsdriverkodak/c2esp%{version_no_dot}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/cupsdriverkodak/c2esp%{version_no_dot}~%{alphatag}.tar.gz
|
||||
|
||||
Patch0: c2esp-jbig.patch
|
||||
Patch1: c2esp-drv_only.patch
|
||||
|
||||
|
||||
# _cups_serverbin macro
|
||||
BuildRequires: cups-devel
|
||||
@ -25,6 +25,7 @@ BuildRequires: cups-filters-devel
|
||||
# JBIG1 lossless image compression
|
||||
BuildRequires: jbigkit-devel
|
||||
|
||||
# directory structure
|
||||
Requires: cups-filesystem
|
||||
|
||||
%description
|
||||
@ -32,17 +33,10 @@ CUPS filters and drivers for Kodak ESP and Hero all in one printers.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n c2esp%{version_no_dot}
|
||||
%setup -q -n c2esp%{version_no_dot}~%{alphatag}
|
||||
|
||||
# remove bundled jbigkit source files
|
||||
rm -f jbig*
|
||||
%patch0 -p1 -b .jbig
|
||||
|
||||
# remove all PPDs
|
||||
rm -rf ppd/
|
||||
# install drv files instead of PPDs
|
||||
%patch1 -p1 -b .drv_only
|
||||
|
||||
%build
|
||||
# Makefile is not ready for %%{?_smp_mflags} (config.h is a shared resource)
|
||||
CFLAGS="%{optflags}" \
|
||||
@ -67,6 +61,9 @@ rm -f %{buildroot}%{_bindir}/c2esplog
|
||||
%{_datadir}/cups/drv/c2esp
|
||||
|
||||
%changelog
|
||||
* Thu Dec 19 2013 Jiri Popelka <jpopelka@redhat.com> - 2.7-0.1.rc1
|
||||
- 2.7~rc1
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user