import c2esp-2.7-14.el8
This commit is contained in:
commit
4e07fb4a26
1
.c2esp.metadata
Normal file
1
.c2esp.metadata
Normal file
@ -0,0 +1 @@
|
||||
628f76dd61d81b6fcabb458644f0426f4ed34c34 SOURCES/c2esp-27.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/c2esp-27.tar.gz
|
23
SOURCES/c2esp-ftbfs-gcc7.patch
Normal file
23
SOURCES/c2esp-ftbfs-gcc7.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up c2esp-27/src/c2espC.c.ftbfs-gcc7 c2esp-27/src/c2espC.c
|
||||
diff -up c2esp-27/src/c2espcommon.c.ftbfs-gcc7 c2esp-27/src/c2espcommon.c
|
||||
--- c2esp-27/src/c2espcommon.c.ftbfs-gcc7 2017-03-03 14:10:28.018395128 +0100
|
||||
+++ c2esp-27/src/c2espcommon.c 2017-03-03 14:19:26.967383931 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <fcntl.h> //files
|
||||
#include <sys/stat.h> //for chmod
|
||||
#include <time.h> //time functions used for debugging
|
||||
+#include <stdlib.h>
|
||||
|
||||
#if HAVE_CUPSFILTERS_DRIVER_H == 1
|
||||
#include <cupsfilters/driver.h> //has the dither functions
|
||||
diff -up c2esp-27/src/c2espcommon.h.ftbfs-gcc7 c2esp-27/src/c2espcommon.h
|
||||
--- c2esp-27/src/c2espcommon.h.ftbfs-gcc7 2017-03-03 14:25:54.186413550 +0100
|
||||
+++ c2esp-27/src/c2espcommon.h 2017-03-03 14:26:53.105961575 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <cups/sidechannel.h> //FlushBackChannel, and the side channel functions and constants
|
||||
#include <fcntl.h> //files
|
||||
#include <time.h> //time functions used for debugging
|
||||
+#include <stdio.h> //library for stderr, stdout, stdin - because of gcc7, it needed to be included
|
||||
|
||||
/*
|
||||
* Constants...
|
105
SPECS/c2esp.spec
Normal file
105
SPECS/c2esp.spec
Normal file
@ -0,0 +1,105 @@
|
||||
%global version_no_dot 27
|
||||
|
||||
Name: c2esp
|
||||
Version: 2.7
|
||||
Release: 14%{?dist}
|
||||
Summary: CUPS driver for Kodak AiO printers
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://sourceforge.net/projects/cupsdriverkodak/
|
||||
Source0: http://downloads.sourceforge.net/cupsdriverkodak/c2esp-%{version_no_dot}.tar.gz
|
||||
|
||||
Patch01: c2esp-ftbfs-gcc7.patch
|
||||
|
||||
# _cups_serverbin macro
|
||||
BuildRequires: cups-devel
|
||||
|
||||
# postscriptdriver tags
|
||||
BuildRequires: python3-cups cups
|
||||
|
||||
# cupsfilters/image.h
|
||||
BuildRequires: cups-filters-devel
|
||||
|
||||
# JBIG1 lossless image compression
|
||||
BuildRequires: jbigkit-devel
|
||||
|
||||
# Needs gcc for compilation
|
||||
BuildRequires: gcc
|
||||
|
||||
# directory structure
|
||||
Requires: cups-filesystem
|
||||
|
||||
%description
|
||||
CUPS filters and drivers for Kodak ESP and Hero all in one printers.
|
||||
|
||||
%prep
|
||||
%setup -q -n c2esp-%{version_no_dot}
|
||||
%patch01 -p1 -b .ftbfs-gcc7
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{_smp_mflags} -C src/
|
||||
|
||||
%install
|
||||
# do not install doc/ or scripts/
|
||||
make -C src/ install DESTDIR=%{buildroot}
|
||||
|
||||
%files
|
||||
%license doc/COPYING
|
||||
%doc doc/README
|
||||
%{_cups_serverbin}/filter/c2esp
|
||||
%{_cups_serverbin}/filter/c2espC
|
||||
%{_cups_serverbin}/filter/command2esp
|
||||
%{_datadir}/cups/drv/c2esp
|
||||
|
||||
%changelog
|
||||
* Mon Feb 19 2018 Zdenek Dohnal <zdohnal@redhat.com> - 2.7-14
|
||||
- gcc is no longer in buildroot by default
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Mar 03 2017 Zdenek Dohnal <zdohnal@redhat.com> - 2.7-10
|
||||
- 1423287 - c2esp: FTBFS in rawhide
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Nov 26 2015 Jiri Popelka <jpopelka@redhat.com> - 2.7-7
|
||||
- BuildRequires: python3-cups
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Wed Aug 13 2014 Jiri Popelka <jpopelka@redhat.com> - 2.7-4
|
||||
- Rebuilt against jbigkit-2.1
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jan 27 2014 Jiri Popelka <jpopelka@redhat.com> - 2.7-2
|
||||
- upstream updated tarball
|
||||
|
||||
* Sun Dec 29 2013 Jiri Popelka <jpopelka@redhat.com> - 2.7-1
|
||||
- 2.7
|
||||
|
||||
* Thu Dec 19 2013 Jiri Popelka <jpopelka@redhat.com> - 2.7-0.1.rc1
|
||||
- 2.7~rc1
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu May 09 2013 Jiri Popelka <jpopelka@redhat.com> - 2.6-1
|
||||
- initial build
|
Loading…
Reference in New Issue
Block a user