fix bz 513776
This commit is contained in:
parent
4709241faa
commit
e3926697ce
87
c-ares-1.6.0-optflags.patch
Normal file
87
c-ares-1.6.0-optflags.patch
Normal file
@ -0,0 +1,87 @@
|
|||||||
|
diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||||
|
--- c-ares-1.6.0/configure~ 2008-12-10 00:31:08.000000000 +0200
|
||||||
|
+++ c-ares-1.6.0/configure 2009-07-25 20:26:11.000000000 +0300
|
||||||
|
@@ -14950,7 +14950,7 @@ echo "$as_me: WARNING: compiler options
|
||||||
|
ac_var_stripped=""
|
||||||
|
for word1 in $tmp_CFLAGS; do
|
||||||
|
ac_var_strip_word="no"
|
||||||
|
- for word2 in $flags_dbg_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_strip_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -14966,7 +14966,7 @@ echo "$as_me: WARNING: compiler options
|
||||||
|
ac_var_stripped=""
|
||||||
|
for word1 in $tmp_CPPFLAGS; do
|
||||||
|
ac_var_strip_word="no"
|
||||||
|
- for word2 in $flags_dbg_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_strip_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -14982,12 +14982,12 @@ echo "$as_me: WARNING: compiler options
|
||||||
|
if test "$want_debug" = "yes"; then
|
||||||
|
{ echo "$as_me:$LINENO: checking if compiler accepts debug enabling options" >&5
|
||||||
|
echo $ECHO_N "checking if compiler accepts debug enabling options... $ECHO_C" >&6; }
|
||||||
|
- tmp_options="$flags_dbg_yes"
|
||||||
|
+ tmp_options=""
|
||||||
|
fi
|
||||||
|
if test "$want_debug" = "no"; then
|
||||||
|
{ echo "$as_me:$LINENO: checking if compiler accepts debug disabling options" >&5
|
||||||
|
echo $ECHO_N "checking if compiler accepts debug disabling options... $ECHO_C" >&6; }
|
||||||
|
- tmp_options="$flags_dbg_off"
|
||||||
|
+ tmp_options=""
|
||||||
|
fi
|
||||||
|
#
|
||||||
|
CPPFLAGS="$tmp_CPPFLAGS"
|
||||||
|
@@ -15221,7 +15221,7 @@ echo $ECHO_N "checking if compiler optim
|
||||||
|
|
||||||
|
ac_var_match_word="no"
|
||||||
|
for word1 in $tmp_CFLAGS; do
|
||||||
|
- for word2 in $flags_opt_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_match_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -15239,7 +15239,7 @@ echo $ECHO_N "checking if compiler optim
|
||||||
|
|
||||||
|
ac_var_match_word="no"
|
||||||
|
for word1 in $tmp_CPPFLAGS; do
|
||||||
|
- for word2 in $flags_opt_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_match_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -15270,7 +15270,7 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||||
|
ac_var_stripped=""
|
||||||
|
for word1 in $tmp_CFLAGS; do
|
||||||
|
ac_var_strip_word="no"
|
||||||
|
- for word2 in $flags_opt_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_strip_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -15286,7 +15286,7 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||||
|
ac_var_stripped=""
|
||||||
|
for word1 in $tmp_CPPFLAGS; do
|
||||||
|
ac_var_strip_word="no"
|
||||||
|
- for word2 in $flags_opt_all; do
|
||||||
|
+ for word2 in ""; do
|
||||||
|
if test "$word1" = "$word2"; then
|
||||||
|
ac_var_strip_word="yes"
|
||||||
|
fi
|
||||||
|
@@ -15301,12 +15301,12 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||||
|
if test "$want_optimize" = "yes"; then
|
||||||
|
{ echo "$as_me:$LINENO: checking if compiler accepts optimizer enabling options" >&5
|
||||||
|
echo $ECHO_N "checking if compiler accepts optimizer enabling options... $ECHO_C" >&6; }
|
||||||
|
- tmp_options="$flags_opt_yes"
|
||||||
|
+ tmp_options=""
|
||||||
|
fi
|
||||||
|
if test "$want_optimize" = "no"; then
|
||||||
|
{ echo "$as_me:$LINENO: checking if compiler accepts optimizer disabling options" >&5
|
||||||
|
echo $ECHO_N "checking if compiler accepts optimizer disabling options... $ECHO_C" >&6; }
|
||||||
|
- tmp_options="$flags_opt_off"
|
||||||
|
+ tmp_options=""
|
||||||
|
fi
|
||||||
|
CPPFLAGS="$tmp_CPPFLAGS"
|
||||||
|
CFLAGS="$tmp_CFLAGS $tmp_options"
|
23
c-ares.spec
23
c-ares.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: A library that performs asynchronous DNS operations
|
Summary: A library that performs asynchronous DNS operations
|
||||||
Name: c-ares
|
Name: c-ares
|
||||||
Version: 1.6.0
|
Version: 1.6.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://daniel.haxx.se/projects/c-ares/
|
URL: http://c-ares.haxx.se/
|
||||||
Source0: http://daniel.haxx.se/projects/c-ares/c-ares-%{version}.tar.gz
|
Source0: http://c-ares.haxx.se/c-ares-%{version}.tar.gz
|
||||||
Source1: LICENSE
|
Source1: LICENSE
|
||||||
|
Patch0: %{name}-1.6.0-optflags.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -26,17 +27,19 @@ compile applications or shared objects that use c-ares.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .optflags
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
|
f=CHANGES ; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-shared
|
%configure --enable-shared --disable-static \
|
||||||
|
--disable-dependency-tracking
|
||||||
%{__make} %{?_smp_mflags}
|
%{__make} %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
rm -rf $RPM_BUILD_ROOT/%{_libdir}/libcares.la
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libcares.la
|
||||||
rm -rf $RPM_BUILD_ROOT/%{_libdir}/libcares.a
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -59,6 +62,14 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man3/ares_*
|
%{_mandir}/man3/ares_*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 25 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.6.0-3
|
||||||
|
- Patch to make upstream build system honor our CFLAGS and friends.
|
||||||
|
- Don't bother building throwaway static libs.
|
||||||
|
- Disable autotools dependency tracking for cleaner build logs and possible
|
||||||
|
slight build speedup.
|
||||||
|
- Convert docs to UTF-8.
|
||||||
|
- Update URLs.
|
||||||
|
|
||||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-2
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user