Upgrade to upstream release 1.7.5
This commit is contained in:
parent
7d832096ca
commit
e2cb3f70b1
@ -1,7 +1,7 @@
|
||||
diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
--- c-ares-1.7.0/configure.optflags 2009-11-30 16:10:42.000000000 -0500
|
||||
+++ c-ares-1.7.0/configure 2009-12-01 11:36:41.154374899 -0500
|
||||
@@ -13988,7 +13988,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
diff -up ./configure.optflags ./configure
|
||||
--- ./configure.optflags 2011-08-17 08:17:31.000000000 +0200
|
||||
+++ ./configure 2011-08-17 08:24:33.000000000 +0200
|
||||
@@ -14925,7 +14925,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -10,7 +10,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14004,7 +14004,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
@@ -14941,7 +14941,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -19,7 +19,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14020,12 +14020,12 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
@@ -14957,12 +14957,12 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
if test "$want_debug" = "yes"; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts debug enabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts debug enabling options... " >&6; }
|
||||
@ -33,8 +33,8 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
+ tmp_options=""
|
||||
fi
|
||||
#
|
||||
CPPFLAGS="$tmp_CPPFLAGS"
|
||||
@@ -14181,7 +14181,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
if test "$flags_prefer_cppflags" = "yes"; then
|
||||
@@ -15123,7 +15123,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
|
||||
ac_var_match_word="no"
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
@ -43,7 +43,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_match_word="yes"
|
||||
fi
|
||||
@@ -14199,7 +14199,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
@@ -15141,7 +15141,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
|
||||
ac_var_match_word="no"
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
@ -52,7 +52,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_match_word="yes"
|
||||
fi
|
||||
@@ -14230,7 +14230,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
@@ -15172,7 +15172,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -61,7 +61,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14246,7 +14246,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
@@ -15188,7 +15188,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -70,7 +70,7 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14261,12 +14261,12 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
@@ -15203,12 +15203,12 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
if test "$want_optimize" = "yes"; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts optimizer enabling options... " >&6; }
|
||||
@ -83,5 +83,5 @@ diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
- tmp_options="$flags_opt_off"
|
||||
+ tmp_options=""
|
||||
fi
|
||||
CPPFLAGS="$tmp_CPPFLAGS"
|
||||
CFLAGS="$tmp_CFLAGS $tmp_options"
|
||||
if test "$flags_prefer_cppflags" = "yes"; then
|
||||
CPPFLAGS="$tmp_CPPFLAGS $tmp_options"
|
16
c-ares.spec
16
c-ares.spec
@ -1,15 +1,14 @@
|
||||
Summary: A library that performs asynchronous DNS operations
|
||||
Name: c-ares
|
||||
Version: 1.7.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.5
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://c-ares.haxx.se/
|
||||
Source0: http://c-ares.haxx.se/c-ares-%{version}.tar.gz
|
||||
Source0: http://c-ares.haxx.se/download/%{name}-%{version}.tar.gz
|
||||
Source1: LICENSE
|
||||
Patch0: %{name}-1.7.0-optflags.patch
|
||||
Patch0: %{name}-1.7.5-optflags.patch
|
||||
Patch1: c-ares-multilib.patch
|
||||
Patch2: cleanup-avoid-unsafe-typecasts.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -32,7 +31,6 @@ compile applications or shared objects that use c-ares.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .optflags
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1 -b .typecasts
|
||||
cp %{SOURCE1} .
|
||||
f=CHANGES ; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
|
||||
|
||||
@ -69,6 +67,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man3/ares_*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 17 2011 Jakub Hrozek <jhrozek@redhat.com> - 1.7.5-1
|
||||
- New upstream release 1.7.5
|
||||
- Obsoletes patch #2
|
||||
- Rebase patch #1 (optflags) to match the 1.7.5 code
|
||||
- Fixed Source0 URL to point at the upstream tarball
|
||||
|
||||
* Mon Apr 11 2011 Jakub Hrozek <jhrozek@redhat.com> - 1.7.4-3
|
||||
- Apply upstream patch to fix rhbz#695424
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user