update to 1.7.0
This commit is contained in:
parent
0256cfcad9
commit
a07a0f227b
@ -1 +1 @@
|
||||
c-ares-1.6.0.tar.gz
|
||||
c-ares-1.7.0.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
--- c-ares-1.6.0/configure~ 2008-12-10 00:31:08.000000000 +0200
|
||||
+++ c-ares-1.6.0/configure 2009-07-25 20:26:11.000000000 +0300
|
||||
@@ -14950,7 +14950,7 @@ echo "$as_me: WARNING: compiler options
|
||||
diff -up c-ares-1.7.0/configure.optflags c-ares-1.7.0/configure
|
||||
--- c-ares-1.7.0/configure.optflags 2009-11-30 16:10:42.000000000 -0500
|
||||
+++ c-ares-1.7.0/configure 2009-12-01 11:36:41.154374899 -0500
|
||||
@@ -13988,7 +13988,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -10,7 +10,7 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14966,7 +14966,7 @@ echo "$as_me: WARNING: compiler options
|
||||
@@ -14004,7 +14004,7 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -19,22 +19,22 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -14982,12 +14982,12 @@ echo "$as_me: WARNING: compiler options
|
||||
@@ -14020,12 +14020,12 @@ $as_echo "$as_me: WARNING: compiler opti
|
||||
if test "$want_debug" = "yes"; then
|
||||
{ echo "$as_me:$LINENO: checking if compiler accepts debug enabling options" >&5
|
||||
echo $ECHO_N "checking if compiler accepts debug enabling options... $ECHO_C" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts debug enabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts debug enabling options... " >&6; }
|
||||
- tmp_options="$flags_dbg_yes"
|
||||
+ tmp_options=""
|
||||
fi
|
||||
if test "$want_debug" = "no"; then
|
||||
{ echo "$as_me:$LINENO: checking if compiler accepts debug disabling options" >&5
|
||||
echo $ECHO_N "checking if compiler accepts debug disabling options... $ECHO_C" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts debug disabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts debug disabling options... " >&6; }
|
||||
- tmp_options="$flags_dbg_off"
|
||||
+ tmp_options=""
|
||||
fi
|
||||
#
|
||||
CPPFLAGS="$tmp_CPPFLAGS"
|
||||
@@ -15221,7 +15221,7 @@ echo $ECHO_N "checking if compiler optim
|
||||
@@ -14181,7 +14181,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
|
||||
ac_var_match_word="no"
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
@ -43,7 +43,7 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_match_word="yes"
|
||||
fi
|
||||
@@ -15239,7 +15239,7 @@ echo $ECHO_N "checking if compiler optim
|
||||
@@ -14199,7 +14199,7 @@ $as_echo_n "checking if compiler optimiz
|
||||
|
||||
ac_var_match_word="no"
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
@ -52,7 +52,7 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_match_word="yes"
|
||||
fi
|
||||
@@ -15270,7 +15270,7 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||
@@ -14230,7 +14230,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -61,7 +61,7 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -15286,7 +15286,7 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||
@@ -14246,7 +14246,7 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
ac_var_stripped=""
|
||||
for word1 in $tmp_CPPFLAGS; do
|
||||
ac_var_strip_word="no"
|
||||
@ -70,16 +70,16 @@ diff -up c-ares-1.6.0/configure~ c-ares-1.6.0/configure
|
||||
if test "$word1" = "$word2"; then
|
||||
ac_var_strip_word="yes"
|
||||
fi
|
||||
@@ -15301,12 +15301,12 @@ echo "${ECHO_T}$honor_optimize_option" >
|
||||
@@ -14261,12 +14261,12 @@ $as_echo "$honor_optimize_option" >&6; }
|
||||
if test "$want_optimize" = "yes"; then
|
||||
{ echo "$as_me:$LINENO: checking if compiler accepts optimizer enabling options" >&5
|
||||
echo $ECHO_N "checking if compiler accepts optimizer enabling options... $ECHO_C" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts optimizer enabling options... " >&6; }
|
||||
- tmp_options="$flags_opt_yes"
|
||||
+ tmp_options=""
|
||||
fi
|
||||
if test "$want_optimize" = "no"; then
|
||||
{ echo "$as_me:$LINENO: checking if compiler accepts optimizer disabling options" >&5
|
||||
echo $ECHO_N "checking if compiler accepts optimizer disabling options... $ECHO_C" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer disabling options" >&5
|
||||
$as_echo_n "checking if compiler accepts optimizer disabling options... " >&6; }
|
||||
- tmp_options="$flags_opt_off"
|
||||
+ tmp_options=""
|
||||
fi
|
11
c-ares.spec
11
c-ares.spec
@ -1,13 +1,13 @@
|
||||
Summary: A library that performs asynchronous DNS operations
|
||||
Name: c-ares
|
||||
Version: 1.6.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://c-ares.haxx.se/
|
||||
Source0: http://c-ares.haxx.se/c-ares-%{version}.tar.gz
|
||||
Source1: LICENSE
|
||||
Patch0: %{name}-1.6.0-optflags.patch
|
||||
Patch0: %{name}-1.7.0-optflags.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%description
|
||||
@ -55,13 +55,18 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files devel
|
||||
%defattr(-, root, root, 0755)
|
||||
%{_includedir}/ares.h
|
||||
%{_includedir}/ares_build.h
|
||||
%{_includedir}/ares_dns.h
|
||||
%{_includedir}/ares_rules.h
|
||||
%{_includedir}/ares_version.h
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/libcares.pc
|
||||
%{_mandir}/man3/ares_*
|
||||
|
||||
%changelog
|
||||
* Tue Dec 1 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.0-1
|
||||
- update to 1.7.0
|
||||
|
||||
* Sat Jul 25 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.6.0-3
|
||||
- Patch to make upstream build system honor our CFLAGS and friends.
|
||||
- Don't bother building throwaway static libs.
|
||||
|
Loading…
Reference in New Issue
Block a user