Apply an upstream patch to override AC_CONFIG_MACRO_DIR only conditionally
This commit is contained in:
parent
68e2f2a3ed
commit
6e64982dd7
126
0003-configure-fix-automake-1.13-compatibility.patch
Normal file
126
0003-configure-fix-automake-1.13-compatibility.patch
Normal file
@ -0,0 +1,126 @@
|
|||||||
|
From dc6c864108e16ad5821cadcf67d8e8faaab9443c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yang Tse <yangsita@gmail.com>
|
||||||
|
Date: Wed, 23 Jan 2013 16:16:13 +0100
|
||||||
|
Subject: [PATCH] configure: fix automake 1.13 compatibility
|
||||||
|
|
||||||
|
Tested with:
|
||||||
|
|
||||||
|
buildconf: autoconf version 2.69
|
||||||
|
buildconf: autom4te version 2.69
|
||||||
|
buildconf: autoheader version 2.69
|
||||||
|
buildconf: automake version 1.13.1
|
||||||
|
buildconf: aclocal version 1.13.1
|
||||||
|
buildconf: libtool version 2.4
|
||||||
|
buildconf: GNU m4 version 1.4.16
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index d520aa839717920b185c611cfc24e69a89648d03..68ec829e1faf47135f7549008a709a36ef2d18fc 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -5,6 +5,7 @@ AC_INIT([c-ares], [-],
|
||||||
|
[c-ares mailing list: http://cool.haxx.se/mailman/listinfo/c-ares])
|
||||||
|
|
||||||
|
XC_OVR_ZZ50
|
||||||
|
+XC_OVR_ZZ60
|
||||||
|
CARES_OVERRIDE_AUTOCONF
|
||||||
|
|
||||||
|
AC_CONFIG_SRCDIR([ares_ipv6.h])
|
||||||
|
diff --git a/m4/cares-override.m4 b/m4/cares-override.m4
|
||||||
|
index 72f486e8e0e3f0b1feb3ae6a1aa8929026d2056d..524a92694b2ffad57ba1693db901ed6415c9a659 100644
|
||||||
|
--- a/m4/cares-override.m4
|
||||||
|
+++ b/m4/cares-override.m4
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
#***************************************************************************
|
||||||
|
|
||||||
|
# File version for 'aclocal' use. Keep it a single number.
|
||||||
|
-# serial 6
|
||||||
|
+# serial 7
|
||||||
|
|
||||||
|
dnl CARES_OVERRIDE_AUTOCONF
|
||||||
|
dnl -------------------------------------------------
|
||||||
|
@@ -89,12 +89,3 @@ m4_defun([_LT_AC_LIBTOOL_SYS_PATH_SEPARATOR],
|
||||||
|
[CARES_CHECK_PATH_SEPARATOR
|
||||||
|
m4_define([$0],[])])
|
||||||
|
|
||||||
|
-dnl Provide Autoconf's AC_CONFIG_MACRO_DIR (DIR)
|
||||||
|
-dnl -------------------------------------------------
|
||||||
|
-dnl Allow usage of mentioned macro in configure.ac
|
||||||
|
-dnl even with ancient Autoconf versions, such as 2.57,
|
||||||
|
-dnl that do not provide a definition for this macro.
|
||||||
|
-
|
||||||
|
-m4_ifndef([AC_CONFIG_MACRO_DIR],
|
||||||
|
-[AC_DEFUN([AC_CONFIG_MACRO_DIR],[:])])
|
||||||
|
-
|
||||||
|
diff --git a/m4/zz60-xc-ovr.m4 b/m4/zz60-xc-ovr.m4
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000000000000000000000000000000000000..959f1188377c8c478524c21dfd3dc98a7b3d1f59
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/m4/zz60-xc-ovr.m4
|
||||||
|
@@ -0,0 +1,64 @@
|
||||||
|
+#---------------------------------------------------------------------------
|
||||||
|
+#
|
||||||
|
+# zz60-xc-ovr.m4
|
||||||
|
+#
|
||||||
|
+# Copyright (c) 2013 Daniel Stenberg <daniel@haxx.se>
|
||||||
|
+#
|
||||||
|
+# Permission to use, copy, modify, and distribute this software for any
|
||||||
|
+# purpose with or without fee is hereby granted, provided that the above
|
||||||
|
+# copyright notice and this permission notice appear in all copies.
|
||||||
|
+#
|
||||||
|
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
||||||
|
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
||||||
|
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
||||||
|
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
||||||
|
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
||||||
|
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
||||||
|
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||||
|
+#
|
||||||
|
+#---------------------------------------------------------------------------
|
||||||
|
+
|
||||||
|
+# serial 1
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+dnl The funny name of this file is intentional in order to make it
|
||||||
|
+dnl sort alphabetically after any libtool, autoconf or automake
|
||||||
|
+dnl provided .m4 macro file that might get copied into this same
|
||||||
|
+dnl subdirectory. This allows that macro (re)definitions from this
|
||||||
|
+dnl file may override those provided in other files.
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+dnl Override an autoconf provided macro
|
||||||
|
+dnl -------------------------------------------------
|
||||||
|
+dnl This macro overrides the one provided by autoconf
|
||||||
|
+dnl 2.58 or newer, and provides macro definition for
|
||||||
|
+dnl autoconf 2.57 or older which lack it. This allows
|
||||||
|
+dnl using libtool 2.2 or newer, which requires that
|
||||||
|
+dnl this macro is used in configure.ac, with autoconf
|
||||||
|
+dnl 2.57 or older.
|
||||||
|
+
|
||||||
|
+m4_ifdef([AC_CONFIG_MACRO_DIR],
|
||||||
|
+[dnl
|
||||||
|
+m4_undefine([AC_CONFIG_MACRO_DIR])dnl
|
||||||
|
+])
|
||||||
|
+m4_define([AC_CONFIG_MACRO_DIR],[])
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+dnl XC_OVR_ZZ60
|
||||||
|
+dnl -------------------------------------------------
|
||||||
|
+dnl Placing a call to this macro in configure.ac will
|
||||||
|
+dnl make macros in this file visible to other macros
|
||||||
|
+dnl used for same configure script, overriding those
|
||||||
|
+dnl provided elsewhere.
|
||||||
|
+
|
||||||
|
+AC_DEFUN([XC_OVR_ZZ60],
|
||||||
|
+[dnl
|
||||||
|
+AC_BEFORE([$0],[LT_INIT])dnl
|
||||||
|
+AC_BEFORE([$0],[AM_INIT_AUTOMAKE])dnl
|
||||||
|
+AC_BEFORE([$0],[AC_LIBTOOL_WIN32_DLL])dnl
|
||||||
|
+AC_BEFORE([$0],[AC_PROG_LIBTOOL])dnl
|
||||||
|
+dnl
|
||||||
|
+AC_BEFORE([$0],[AC_CONFIG_MACRO_DIR])dnl
|
||||||
|
+AC_BEFORE([$0],[AC_CONFIG_MACRO_DIRS])dnl
|
||||||
|
+])
|
||||||
|
+
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A library that performs asynchronous DNS operations
|
Summary: A library that performs asynchronous DNS operations
|
||||||
Name: c-ares
|
Name: c-ares
|
||||||
Version: 1.9.1
|
Version: 1.9.1
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://c-ares.haxx.se/
|
URL: http://c-ares.haxx.se/
|
||||||
@ -11,6 +11,7 @@ Source1: LICENSE
|
|||||||
Patch0: 0001-Use-RPM-compiler-options.patch
|
Patch0: 0001-Use-RPM-compiler-options.patch
|
||||||
Patch1: c-ares-1.8.0-multilib.patch
|
Patch1: c-ares-1.8.0-multilib.patch
|
||||||
Patch2: 0002-cares-override.m4-provide-AC_CONFIG_MACRO_DIR-defini.patch
|
Patch2: 0002-cares-override.m4-provide-AC_CONFIG_MACRO_DIR-defini.patch
|
||||||
|
Patch3: 0003-configure-fix-automake-1.13-compatibility.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -38,6 +39,7 @@ compile applications or shared objects that use c-ares.
|
|||||||
%patch0 -p1 -b .optflags
|
%patch0 -p1 -b .optflags
|
||||||
%patch1 -p0 -b .multilib
|
%patch1 -p0 -b .multilib
|
||||||
%patch2 -p1 -b .override
|
%patch2 -p1 -b .override
|
||||||
|
%patch3 -p1 -b .autoconf
|
||||||
|
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
f=CHANGES ; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
|
f=CHANGES ; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
|
||||||
@ -76,7 +78,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man3/ares_*
|
%{_mandir}/man3/ares_*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Apr 11 2013 Jakub Hrozek <jhrozek@redhat.com> - 1.9.1-4
|
* Thu Apr 11 2013 Jakub Hrozek <jhrozek@redhat.com> - 1.9.1-6
|
||||||
|
- Apply an upstream patch to override AC_CONFIG_MACRO_DIR only conditionally
|
||||||
|
|
||||||
|
* Thu Apr 11 2013 Jakub Hrozek <jhrozek@redhat.com> - 1.9.1-5
|
||||||
- Apply a patch by Stephen Gallagher to patch autoconf, not configure to
|
- Apply a patch by Stephen Gallagher to patch autoconf, not configure to
|
||||||
allow optflags to be passed in by build environment
|
allow optflags to be passed in by build environment
|
||||||
- Run autoreconf before configure
|
- Run autoreconf before configure
|
||||||
|
Loading…
Reference in New Issue
Block a user