Update to upstream version 1.14.2

Remove byte-buddy-parent subpackage
This commit is contained in:
Marian Koncek 2023-02-23 13:25:51 +01:00
parent a833add13b
commit d96c1809a7
7 changed files with 65 additions and 277 deletions

View File

@ -1,14 +1,14 @@
From 112daf42699caa2e878d4c3f6509fc0dccf7975d Mon Sep 17 00:00:00 2001 From beaed3d4ce80ae695f7f2a3e02e11c39fbb4e1f8 Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com> From: Marian Koncek <mkoncek@redhat.com>
Date: Tue, 9 Nov 2021 11:55:22 +0100 Date: Thu, 23 Feb 2023 13:59:25 +0100
Subject: [PATCH 1/4] Avoid bundling asm Subject: [PATCH] Avoid bundling asm
--- ---
byte-buddy/pom.xml | 53 +++++++++------------------------------------- byte-buddy/pom.xml | 56 +++++++++-------------------------------------
1 file changed, 10 insertions(+), 43 deletions(-) 1 file changed, 11 insertions(+), 45 deletions(-)
diff --git a/byte-buddy/pom.xml b/byte-buddy/pom.xml diff --git a/byte-buddy/pom.xml b/byte-buddy/pom.xml
index c0cec10..6b5494d 100644 index 625e0d6..97ac874 100644
--- a/byte-buddy/pom.xml --- a/byte-buddy/pom.xml
+++ b/byte-buddy/pom.xml +++ b/byte-buddy/pom.xml
@@ -26,8 +26,6 @@ @@ -26,8 +26,6 @@
@ -20,13 +20,15 @@ index c0cec10..6b5494d 100644
<packages.list.external> <packages.list.external>
net.bytebuddy, net.bytebuddy,
net.bytebuddy.agent.builder, net.bytebuddy.agent.builder,
@@ -63,9 +61,6 @@ @@ -62,10 +60,7 @@
net.bytebuddy.utility,
net.bytebuddy.utility.nullability, net.bytebuddy.utility.nullability,
net.bytebuddy.utility.privilege, net.bytebuddy.utility.privilege,
net.bytebuddy.utility.visitor, - net.bytebuddy.utility.visitor,
- ${shade.target}, - ${shade.target},
- ${shade.target}.signature, - ${shade.target}.signature,
- ${shade.target}.commons - ${shade.target}.commons
+ net.bytebuddy.utility.visitor
</packages.list.external> </packages.list.external>
<packages.list.internal> <packages.list.internal>
net.bytebuddy.utility.dispatcher net.bytebuddy.utility.dispatcher
@ -47,7 +49,7 @@ index c0cec10..6b5494d 100644
</dependencies> </dependencies>
<executions> <executions>
<execution> <execution>
@@ -249,44 +254,6 @@ @@ -253,45 +258,6 @@
<createDependencyReducedPom>true</createDependencyReducedPom> <createDependencyReducedPom>true</createDependencyReducedPom>
<createSourcesJar>${bytebuddy.extras}</createSourcesJar> <createSourcesJar>${bytebuddy.extras}</createSourcesJar>
<shadeSourcesContent>true</shadeSourcesContent> <shadeSourcesContent>true</shadeSourcesContent>
@ -62,6 +64,7 @@ index c0cec10..6b5494d 100644
- <artifact>net.bytebuddy:byte-buddy-dep:*</artifact> - <artifact>net.bytebuddy:byte-buddy-dep:*</artifact>
- <excludes> - <excludes>
- <exclude>META-INF/MANIFEST.MF</exclude> - <exclude>META-INF/MANIFEST.MF</exclude>
- <exclude>META-INF/maven/**</exclude>
- </excludes> - </excludes>
- </filter> - </filter>
- <filter> - <filter>
@ -93,5 +96,5 @@ index c0cec10..6b5494d 100644
<transformer implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer"> <transformer implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
<mainClass>net.bytebuddy.build.Plugin$Engine$Default</mainClass> <mainClass>net.bytebuddy.build.Plugin$Engine$Default</mainClass>
-- --
2.35.1 2.39.1

View File

@ -1,19 +1,18 @@
From 7b86e76fe0db78bdedde22a0f021b2acfbe3900f Mon Sep 17 00:00:00 2001 From f7e74e70c82177c5a6b45a9c21e1d3950fb3eca1 Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com> From: Marian Koncek <mkoncek@redhat.com>
Date: Mon, 1 Nov 2021 12:51:02 +0100 Date: Thu, 23 Feb 2023 11:19:59 +0100
Subject: [PATCH 2/4] Remove dependencies Subject: [PATCH] Remove dependencies
--- ---
.../net/bytebuddy/agent/VirtualMachine.java | 2000 +---------------- .../net/bytebuddy/agent/VirtualMachine.java | 2006 +----------------
.../description/type/TypeDescription.java | 3 - .../dynamic/loading/ClassInjector.java | 95 +-
.../dynamic/loading/ClassInjector.java | 106 +- 2 files changed, 2 insertions(+), 2099 deletions(-)
3 files changed, 2 insertions(+), 2107 deletions(-)
diff --git a/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java b/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java diff --git a/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java b/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java
index fc53282..62344df 100644 index 7a748ad..d15d47d 100644
--- a/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java --- a/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java
+++ b/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java +++ b/byte-buddy-agent/src/main/java/net/bytebuddy/agent/VirtualMachine.java
@@ -15,12 +15,6 @@ @@ -15,11 +15,6 @@
*/ */
package net.bytebuddy.agent; package net.bytebuddy.agent;
@ -22,11 +21,10 @@ index fc53282..62344df 100644
-import com.sun.jna.ptr.IntByReference; -import com.sun.jna.ptr.IntByReference;
-import com.sun.jna.win32.StdCallLibrary; -import com.sun.jna.win32.StdCallLibrary;
-import com.sun.jna.win32.W32APIOptions; -import com.sun.jna.win32.W32APIOptions;
-import edu.umd.cs.findbugs.annotations.SuppressFBWarnings; import edu.umd.cs.findbugs.annotations.SuppressFBWarnings;
import net.bytebuddy.agent.utility.nullability.MaybeNull; import net.bytebuddy.agent.utility.nullability.MaybeNull;
import net.bytebuddy.agent.utility.nullability.UnknownNull; import net.bytebuddy.agent.utility.nullability.UnknownNull;
@@ -151,15 +146,7 @@ public interface VirtualMachine {
@@ -151,15 +145,7 @@ public interface VirtualMachine {
* {@inheritDoc} * {@inheritDoc}
*/ */
public Class<? extends VirtualMachine> run() { public Class<? extends VirtualMachine> run() {
@ -43,7 +41,7 @@ index fc53282..62344df 100644
} }
} }
@@ -229,23 +215,6 @@ public interface VirtualMachine { @@ -229,23 +216,6 @@ public interface VirtualMachine {
this.connection = connection; this.connection = connection;
} }
@ -67,15 +65,7 @@ index fc53282..62344df 100644
/** /**
* Attaches to the supplied process id using the supplied connection factory. * Attaches to the supplied process id using the supplied connection factory.
* *
@@ -517,7 +486,6 @@ public interface VirtualMachine { @@ -681,1980 +651,6 @@ public interface VirtualMachine {
/**
* {@inheritDoc}
*/
- @SuppressFBWarnings(value = "DMI_HARDCODED_ABSOLUTE_FILENAME", justification = "File name convention is specified.")
public Connection connect(String processId) throws IOException {
File socket = new File(temporaryDirectory, SOCKET_FILE_PREFIX + processId);
if (!socket.exists()) {
@@ -681,1972 +649,6 @@ public interface VirtualMachine {
*/ */
protected abstract int read(T connection, byte[] buffer) throws IOException; protected abstract int read(T connection, byte[] buffer) throws IOException;
} }
@ -972,6 +962,11 @@ index fc53282..62344df 100644
- private static final String IBM_TEMPORARY_FOLDER = "com.ibm.tools.attach.directory"; - private static final String IBM_TEMPORARY_FOLDER = "com.ibm.tools.attach.directory";
- -
- /** - /**
- * A secure random for generating randomized ids.
- */
- private static final SecureRandom SECURE_RANDOM = new SecureRandom();
-
- /**
- * The socket on which this VM and the target VM communicate. - * The socket on which this VM and the target VM communicate.
- */ - */
- private final Socket socket; - private final Socket socket;
@ -1083,7 +1078,10 @@ index fc53282..62344df 100644
- try { - try {
- serverSocket.setSoTimeout(timeout); - serverSocket.setSoTimeout(timeout);
- File receiver = new File(directory, target.getProperty("vmId")); - File receiver = new File(directory, target.getProperty("vmId"));
- String key = Long.toHexString(new SecureRandom().nextLong()); - String key;
- synchronized (SECURE_RANDOM) {
- key = Long.toHexString(SECURE_RANDOM.nextLong());
- }
- File reply = new File(receiver, "replyInfo"); - File reply = new File(receiver, "replyInfo");
- try { - try {
- if (reply.createNewFile()) { - if (reply.createNewFile()) {
@ -2048,98 +2046,19 @@ index fc53282..62344df 100644
} }
} }
} }
diff --git a/byte-buddy-dep/src/main/java/net/bytebuddy/description/type/TypeDescription.java b/byte-buddy-dep/src/main/java/net/bytebuddy/description/type/TypeDescription.java
index 2285a75..4266130 100644
--- a/byte-buddy-dep/src/main/java/net/bytebuddy/description/type/TypeDescription.java
+++ b/byte-buddy-dep/src/main/java/net/bytebuddy/description/type/TypeDescription.java
@@ -4332,9 +4332,6 @@ public interface TypeDescription extends TypeDefinition, ByteCodeElement, TypeVa
}
@Override
- @SuppressFBWarnings(
- value = {"EQ_CHECK_FOR_OPERAND_NOT_COMPATIBLE_WITH_THIS", "NP_NULL_ON_SOME_PATH_FROM_RETURN_VALUE"},
- justification = "Type check is performed by erasure implementation. Assuming component type for array type.")
public boolean equals(@MaybeNull Object other) {
if (this == other) {
return true;
diff --git a/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java b/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java diff --git a/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java b/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java
index c37c287..cafaeb4 100644 index 5880b2d..9d4b989 100644
--- a/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java --- a/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java
+++ b/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java +++ b/byte-buddy-dep/src/main/java/net/bytebuddy/dynamic/loading/ClassInjector.java
@@ -15,8 +15,6 @@ @@ -15,7 +15,6 @@
*/ */
package net.bytebuddy.dynamic.loading; package net.bytebuddy.dynamic.loading;
-import com.sun.jna.*; -import com.sun.jna.*;
-import edu.umd.cs.findbugs.annotations.SuppressFBWarnings; import edu.umd.cs.findbugs.annotations.SuppressFBWarnings;
import net.bytebuddy.ByteBuddy; import net.bytebuddy.ByteBuddy;
import net.bytebuddy.ClassFileVersion; import net.bytebuddy.ClassFileVersion;
import net.bytebuddy.asm.MemberRemoval; @@ -2777,79 +2776,13 @@ public interface ClassInjector {
@@ -516,7 +514,6 @@ public interface ClassInjector {
/**
* {@inheritDoc}
*/
- @SuppressFBWarnings(value = "REC_CATCH_EXCEPTION", justification = "Exception should not be rethrown but trigger a fallback.")
public Initializable run() {
try {
if (JavaModule.isSupported()) {
@@ -593,7 +590,6 @@ public interface ClassInjector {
* @return A direct dispatcher for class injection.
* @throws Exception If the creation is impossible.
*/
- @SuppressFBWarnings(value = "DP_DO_INSIDE_DO_PRIVILEGED", justification = "Assuring privilege is explicit user responsibility.")
protected static Initializable make() throws Exception {
Method getDefinedPackage;
if (JavaModule.isSupported()) { // Avoid accidental lookup of method with same name in Java 8 J9 VM.
@@ -902,7 +898,6 @@ public interface ClassInjector {
* @return An indirect dispatcher for class creation.
* @throws Exception If the dispatcher cannot be created.
*/
- @SuppressFBWarnings(value = "DP_DO_INSIDE_DO_PRIVILEGED", justification = "Assuring privilege is explicit user responsibility.")
protected static Initializable make() throws Exception {
if (Boolean.parseBoolean(java.lang.System.getProperty(UsingUnsafe.SAFE_PROPERTY, Boolean.toString(GraalImageCode.getCurrent().isDefined())))) {
return new Initializable.Unavailable("Use of Unsafe was disabled by system property");
@@ -1166,7 +1161,6 @@ public interface ClassInjector {
* @return An appropriate initializable.
* @throws Exception If the injector cannot be created.
*/
- @SuppressFBWarnings(value = "DP_DO_INSIDE_DO_PRIVILEGED", justification = "Assuring privilege is explicit user responsibility.")
protected static Initializable make() throws Exception {
if (Boolean.parseBoolean(java.lang.System.getProperty(UsingUnsafe.SAFE_PROPERTY, Boolean.toString(GraalImageCode.getCurrent().isDefined())))) {
return new Initializable.Unavailable("Use of Unsafe was disabled by system property");
@@ -1916,7 +1910,6 @@ public interface ClassInjector {
/**
* {@inheritDoc}
*/
- @SuppressFBWarnings(value = "REC_CATCH_EXCEPTION", justification = "Exception should not be rethrown but trigger a fallback.")
public Initializable run() {
if (Boolean.parseBoolean(java.lang.System.getProperty(SAFE_PROPERTY, Boolean.toString(GraalImageCode.getCurrent().isDefined())))) {
return new Unavailable("Use of Unsafe was disabled by system property");
@@ -2121,7 +2114,6 @@ public interface ClassInjector {
*
* @param accessResolver The access resolver to use.
*/
- @SuppressFBWarnings(value = "REC_CATCH_EXCEPTION", justification = "Exception should not be rethrown but trigger a fallback.")
public Factory(AccessResolver accessResolver) {
Dispatcher.Initializable dispatcher;
if (DISPATCHER.isAvailable()) {
@@ -2179,9 +2171,6 @@ public interface ClassInjector {
* other classes within this class's module.
* @return An appropriate injection strategy.
*/
- @SuppressFBWarnings(
- value = {"REC_CATCH_EXCEPTION", "NP_NULL_ON_SOME_PATH_FROM_RETURN_VALUE"},
- justification = "Exception intends to trigger disabled injection strategy. Modules are assumed if module system is supported.")
public static Factory resolve(Instrumentation instrumentation, boolean local) {
if (ClassInjector.UsingUnsafe.isAvailable() || !JavaModule.isSupported()) {
return new Factory();
@@ -2771,85 +2760,18 @@ public interface ClassInjector {
/**
* {@inheritDoc}
*/
- @SuppressWarnings("deprecation")
public Dispatcher run() {
if (System.getProperty("java.vm.name", "").toUpperCase(Locale.US).contains("J9")) {
return new Unavailable("J9 does not support JNA-based class definition"); return new Unavailable("J9 does not support JNA-based class definition");
} }
try { try {
@ -2220,7 +2139,7 @@ index c37c287..cafaeb4 100644
/** /**
* An unavailable dispatcher for JNA-based class injection. * An unavailable dispatcher for JNA-based class injection.
*/ */
@@ -2884,32 +2806,6 @@ public interface ClassInjector { @@ -2884,32 +2817,6 @@ public interface ClassInjector {
throw new UnsupportedOperationException("JNA is not available and JNA-based injection cannot be used: " + error); throw new UnsupportedOperationException("JNA is not available and JNA-based injection cannot be used: " + error);
} }
} }
@ -2254,5 +2173,5 @@ index c37c287..cafaeb4 100644
} }
} }
-- --
2.35.1 2.39.1

View File

@ -1,43 +0,0 @@
From 4c1537b368b1f293e982d15b478eb4dc88fc1aaf Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com>
Date: Thu, 4 Feb 2021 15:17:13 +0100
Subject: [PATCH 3/4] Remove Java 14 tests
---
.../test/precompiled/SampleRecord.java | 24 -------------------
1 file changed, 24 deletions(-)
delete mode 100644 byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/SampleRecord.java
diff --git a/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/SampleRecord.java b/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/SampleRecord.java
deleted file mode 100644
index 137ce19..0000000
--- a/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/SampleRecord.java
+++ /dev/null
@@ -1,24 +0,0 @@
-/*
- * Copyright 2014 - Present Rafael Winterhalter
- *
- * Licensed under the Apache License, Version 2.0 (the "License");
- * you may not use this file except in compliance with the License.
- * You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing, software
- * distributed under the License is distributed on an "AS IS" BASIS,
- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- * See the License for the specific language governing permissions and
- * limitations under the License.
- */
-package net.bytebuddy.test.precompiled;
-
-import net.bytebuddy.description.type.AbstractTypeDescriptionTest;
-
-import java.util.List;
-
-public record SampleRecord(@AbstractTypeDescriptionTest.SampleAnnotation @TypeAnnotation(42) List<@TypeAnnotation(84) String> foo){
- /* empty */
- }
--
2.35.1

View File

@ -1,59 +0,0 @@
From 88e2f74d1fa33b32feb3f21bdfd30d475682e6fe Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com>
Date: Tue, 9 Nov 2021 12:23:28 +0100
Subject: [PATCH 4/4] Remove JDK 15 sealed classes
---
.../bytebuddy/test/precompiled/Sealed.java | 40 -------------------
1 file changed, 40 deletions(-)
delete mode 100644 byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/Sealed.java
diff --git a/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/Sealed.java b/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/Sealed.java
deleted file mode 100644
index bff4718..0000000
--- a/byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/Sealed.java
+++ /dev/null
@@ -1,40 +0,0 @@
-/*
- * Copyright 2014 - Present Rafael Winterhalter
- *
- * Licensed under the Apache License, Version 2.0 (the "License");
- * you may not use this file except in compliance with the License.
- * You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing, software
- * distributed under the License is distributed on an "AS IS" BASIS,
- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- * See the License for the specific language governing permissions and
- * limitations under the License.
- */
-package net.bytebuddy.test.precompiled;
-
-public sealed
-
-class Sealed permits Sealed.SubNonSealed, Sealed.SubSealed, Sealed.SubFinal {
-
- public static non-sealed
-
- class SubNonSealed extends Sealed {
- /* empty */
- }
-
- public static sealed
-
- class SubSealed extends Sealed permits SubSealed.SubSubFinal {
-
- public static final class SubSubFinal extends SubSealed {
- /* empty */
- }
- }
-
- public static final class SubFinal extends Sealed {
- /* empty */
- }
-}
--
2.35.1

View File

@ -1,20 +1,18 @@
%bcond_with bootstrap %bcond_with bootstrap
Name: byte-buddy Name: byte-buddy
Version: 1.12.10 Version: 1.14.2
Release: 4%{?dist} Release: 1%{?dist}
Summary: Runtime code generation for the Java virtual machine Summary: Runtime code generation for the Java virtual machine
License: ASL 2.0 License: ASL 2.0
URL: http://bytebuddy.net/ URL: http://bytebuddy.net/
# ./generate-tarball.sh Source0: https://github.com/raphw/byte-buddy/archive/refs/tags/byte-buddy-%{version}.tar.gz
Source0: %{name}-%{version}.tar.gz
# Patch the build to avoid bundling inside shaded jars # Patch the build to avoid bundling inside shaded jars
Patch1: 0001-Avoid-bundling-asm.patch Patch1: 0001-Avoid-bundling-asm.patch
Patch2: 0002-Remove-dependencies.patch Patch2: 0002-Remove-dependencies.patch
Patch3: 0003-Remove-Java-14-tests.patch
Patch4: 0004-Remove-JDK-15-sealed-classes.patch
BuildRequires: javapackages-extra
%if %{with bootstrap} %if %{with bootstrap}
BuildRequires: javapackages-bootstrap BuildRequires: javapackages-bootstrap
%else %else
@ -25,6 +23,7 @@ BuildRequires: mvn(net.bytebuddy:byte-buddy)
BuildRequires: mvn(net.bytebuddy:byte-buddy-dep) BuildRequires: mvn(net.bytebuddy:byte-buddy-dep)
BuildRequires: mvn(org.apache.maven:maven-compat) BuildRequires: mvn(org.apache.maven:maven-compat)
BuildRequires: mvn(org.apache.maven.plugin-testing:maven-plugin-testing-harness) BuildRequires: mvn(org.apache.maven.plugin-testing:maven-plugin-testing-harness)
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
BuildRequires: mvn(org.mockito:mockito-core) BuildRequires: mvn(org.mockito:mockito-core)
BuildRequires: mvn(org.ow2.asm:asm-analysis) BuildRequires: mvn(org.ow2.asm:asm-analysis)
BuildRequires: mvn(org.ow2.asm:asm-util) BuildRequires: mvn(org.ow2.asm:asm-util)
@ -80,19 +79,13 @@ This package contains API documentation for %{name}.
%patch1 -p1 %patch1 -p1
%patch2 -p1 %patch2 -p1
%patch3 -p1
%patch4 -p1
rm byte-buddy-agent/src/test/java/net/bytebuddy/agent/VirtualMachineAttachmentTest.java find -name '*.class' -delete
rm byte-buddy-agent/src/test/java/net/bytebuddy/agent/VirtualMachineForOpenJ9Test.java
# Cause pre-compiled stuff to be re-compiled rm byte-buddy-agent/src/test/java/net/bytebuddy/agent/VirtualMachineAttachmentTest.java\
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/build/*.java \ byte-buddy-agent/src/test/java/net/bytebuddy/agent/VirtualMachineForOpenJ9Test.java\
byte-buddy-dep/src/main/java/net/bytebuddy/build byte-buddy-agent/src/test/java/net/bytebuddy/test/utility/JnaRule.java\
mkdir -p byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/ ;
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/*.java \
byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/
rm byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/GenericRecordSample.java
# Don't ship android or benchmark modules # Don't ship android or benchmark modules
%pom_disable_module byte-buddy-android %pom_disable_module byte-buddy-android
@ -109,7 +102,6 @@ rm byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/GenericRecordSamp
%pom_remove_plugin :coveralls-maven-plugin %pom_remove_plugin :coveralls-maven-plugin
%pom_remove_plugin :spotbugs-maven-plugin %pom_remove_plugin :spotbugs-maven-plugin
%pom_remove_plugin :jitwatch-jarscan-maven-plugin %pom_remove_plugin :jitwatch-jarscan-maven-plugin
%pom_remove_plugin :clirr-maven-plugin
%pom_remove_plugin :maven-release-plugin %pom_remove_plugin :maven-release-plugin
%pom_remove_plugin :nexus-staging-maven-plugin %pom_remove_plugin :nexus-staging-maven-plugin
@ -120,27 +112,26 @@ rm byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/GenericRecordSamp
%pom_xpath_set "pom:createSourcesJar" "false" byte-buddy %pom_xpath_set "pom:createSourcesJar" "false" byte-buddy
# Drop build dep on findbugs annotations, used only by the above check plugins # Drop build dep on findbugs annotations, used only by the above check plugins
%pom_remove_dep :findbugs-annotations %pom_remove_dep -r :findbugs-annotations
sed -i -e '/SuppressFBWarnings/d' $(grep -lr SuppressFBWarnings) %java_remove_annotations byte-buddy-agent byte-buddy-dep byte-buddy-maven-plugin -n SuppressFBWarnings
%pom_remove_dep org.ow2.asm:asm-deprecated %pom_remove_dep org.ow2.asm:asm-deprecated
%pom_remove_plugin :maven-shade-plugin byte-buddy %pom_remove_plugin -r :maven-shade-plugin
%pom_remove_plugin :maven-shade-plugin byte-buddy-benchmark %pom_remove_dep -r net.java.dev.jna:jna
%pom_remove_dep -r net.java.dev.jna:jna-platform
%pom_remove_dep net.java.dev.jna:jna byte-buddy %mvn_package :byte-buddy-parent __noinstall
%pom_remove_dep net.java.dev.jna:jna byte-buddy-dep
%pom_remove_dep net.java.dev.jna:jna byte-buddy-agent
%pom_remove_dep net.java.dev.jna:jna-platform byte-buddy
%pom_remove_dep net.java.dev.jna:jna-platform byte-buddy-dep
%pom_remove_dep net.java.dev.jna:jna-platform byte-buddy-agent
%build %build
# Ignore test failures, there seems to be something different about the # Ignore test failures, there seems to be something different about the
# bytecode of our recompiled test resources, expect 6 test failures in # bytecode of our recompiled test resources, expect 6 test failures in
# the byte-buddy-dep module # the byte-buddy-dep module
%mvn_build -s -- -P'java8,!checks' -Dsourcecode.test.version=1.8 -Dmaven.test.failure.ignore=true
# NOTE you can obtain valid profiles for precompilation by:
# xmllint --xpath '//*[local-name()="profile"]/*[local-name()="id"]/text()' byte-buddy-dep/pom.xml | grep 'precompile$' | grep -v 'no-precompile$' | sed 's/\(.*\)/-P\1/'
profiles='-Pjava-8-precompile -Pjava-8-parameters-precompile -Pjava-11-precompile -Pjava-16-precompile -Pjava-17-precompile'
%mvn_build -s -- -P'java8,!checks' "${profiles}" -Dsourcecode.test.version=1.8 -Dmaven.test.failure.ignore=true
%install %install
%mvn_install %mvn_install
@ -154,13 +145,13 @@ sed -i -e '/SuppressFBWarnings/d' $(grep -lr SuppressFBWarnings)
%files maven-plugin -f .mfiles-%{name}-maven-plugin %files maven-plugin -f .mfiles-%{name}-maven-plugin
%files parent -f .mfiles-%{name}-parent
%license LICENSE NOTICE
%files javadoc -f .mfiles-javadoc %files javadoc -f .mfiles-javadoc
%license LICENSE NOTICE %license LICENSE NOTICE
%changelog %changelog
* Thu Feb 23 2023 Marian Koncek <mkoncek@redhat.com> - 1.14.2-1
- Update to upstream version 1.14.2
* Tue Feb 21 2023 Marian Koncek <mkoncek@redhat.com> - 1.12.10-4 * Tue Feb 21 2023 Marian Koncek <mkoncek@redhat.com> - 1.12.10-4
- Enable modulemaker-maven-plugin - Enable modulemaker-maven-plugin

View File

@ -1,23 +0,0 @@
#!/bin/bash
set -e
name=byte-buddy
version="$(sed -n 's/Version:\s*//p' *.spec)"
# RETRIEVE
wget "https://github.com/raphw/byte-buddy/archive/${name}-${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
rm -rf tarball-tmp
mkdir tarball-tmp
pushd tarball-tmp
tar -xf "../${name}-${version}.orig.tar.gz"
# CLEAN TARBALL
find -name '*.jar' -delete
find -name '*.class' -delete
find -name '*.zip' -delete
find -name '*.dll' -delete
tar -czf "../${name}-${version}.tar.gz" *
popd
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"

View File

@ -1 +1 @@
SHA512 (byte-buddy-1.12.10.tar.gz) = 765a6052e34bbe7b3431189670cb67b93630bb54a0dae91bea428eabc3caffe142135669289bdff74b9b57998f58634222b0ddea38a7e29125dcd5dd3f6f3ab2 SHA512 (byte-buddy-1.14.0.tar.gz) = e6ccda287935b5ff7104d5c0e4904b0595918a21bcc90c6ac5b2358cc0371b22a4fcac2a95dde9e377c5d1e43077c8b57ea9520a9093b2380ab53c830f107ced