Update to upstream version 1.10.1

This commit is contained in:
Marian Koncek 2019-09-24 13:06:49 +02:00
parent 56ae310749
commit 5bd1125b8f
5 changed files with 1107 additions and 23 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,5 +1,5 @@
diff --git a/byte-buddy/pom.xml b/byte-buddy/pom.xml
index f16ba74..d7f68b4 100644
index 283da43..aca6bc5 100644
--- a/byte-buddy/pom.xml
+++ b/byte-buddy/pom.xml
@@ -26,8 +26,6 @@
@ -38,9 +38,9 @@ index f16ba74..d7f68b4 100644
</dependencies>
<build>
@@ -99,48 +104,19 @@
@@ -105,36 +110,6 @@
<createDependencyReducedPom>true</createDependencyReducedPom>
<createSourcesJar>true</createSourcesJar>
<createSourcesJar>${bytebuddy.extras}</createSourcesJar>
<shadeSourcesContent>true</shadeSourcesContent>
- <relocations>
- <relocation>
@ -50,6 +50,14 @@ index f16ba74..d7f68b4 100644
- </relocations>
- <filters>
- <filter>
- <artifact>org.ow2.asm:*</artifact>
- <excludes>
- <exclude>**/module-info.class</exclude>
- <exclude>**/LICENSE</exclude>
- <exclude>**/NOTICE</exclude>
- </excludes>
- </filter>
- <filter>
- <artifact>org.ow2.asm:asm-commons</artifact>
- <includes>
- <include>org/objectweb/asm/commons/AnnotationRemapper.class</include>
@ -67,6 +75,8 @@ index f16ba74..d7f68b4 100644
<transformers>
<transformer implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
<mainClass>net.bytebuddy.build.Plugin$Engine$Default</mainClass>
@@ -143,21 +118,14 @@
<resource>META-INF/LICENSE</resource>
</transformer>
</transformers>
+ <artifactSet>

View File

@ -1,14 +1,11 @@
Name: byte-buddy
Version: 1.9.13
Release: 2%{?dist}
Version: 1.10.1
Release: 1%{?dist}
Summary: Runtime code generation for the Java virtual machine
License: ASL 2.0
URL: http://bytebuddy.net/
Source0: https://github.com/raphw/byte-buddy/archive/%{name}-%{version}.tar.gz
# Patch out use of a unixsocket lib that is not in Fedora
Patch0: no-unixsocket.patch
# Patch the build to avoid bundling inside shaded jars
Patch1: avoid-bundling-asm.patch
@ -42,12 +39,6 @@ the code generation utilities that ship with the Java Class Library, Byte Buddy
allows the creation of arbitrary classes and is not limited to implementing
interfaces for the creation of runtime proxies.
%package agent
Summary: Byte Buddy Java agent
%description agent
The Byte Buddy Java agent allows to access the JVM's HotSwap feature.
%package maven-plugin
Summary: Byte Buddy Maven plugin
@ -69,13 +60,8 @@ This package contains API documentation for %{name}.
%prep
%setup -q -n %{name}-%{name}-%{version}
%patch0
%patch1 -p1
# Remove pre-built jars
find -name *.jar -delete
find -name *.class -delete
# Cause pre-compiled stuff to be re-compiled
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/build/*.java \
byte-buddy-dep/src/main/java/net/bytebuddy/build
@ -83,8 +69,12 @@ mkdir -p byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/*.java \
byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/
# This module depends on jna
%pom_disable_module byte-buddy-agent
# Don't ship android or benchmark modules
%pom_disable_module byte-buddy-android
%pom_disable_module byte-buddy-android-test
%pom_disable_module byte-buddy-benchmark
# Don't ship gradle plugin
@ -128,9 +118,6 @@ sed -i -e '/SuppressFBWarnings/d' $(grep -lr SuppressFBWarnings)
%doc README.md release-notes.md
%license LICENSE NOTICE
%files agent -f .mfiles-%{name}-agent
%license LICENSE NOTICE
%files maven-plugin -f .mfiles-%{name}-maven-plugin
%files parent -f .mfiles-%{name}-parent
@ -140,6 +127,9 @@ sed -i -e '/SuppressFBWarnings/d' $(grep -lr SuppressFBWarnings)
%license LICENSE NOTICE
%changelog
* Thu Sep 12 2019 Marian Koncek <mkoncek@redhat.com> - 1.10.1-1
- Update to upstream version 1.10.1
* Wed Jul 10 2019 Marian Koncek <mkoncek@redhat.com> - 1.9.13-2
- Remove the dependency on maven-shade-plugin

22
generate-tarball.sh Executable file
View File

@ -0,0 +1,22 @@
#!/bin/bash
set -e
name=byte-buddy
version="$(sed -n 's/Version:\s*//p' *.spec)"
# RETRIEVE
wget "https://github.com/raphw/byte-buddy/archive/${name}-${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
rm -rf tarball-tmp
mkdir tarball-tmp
cd tarball-tmp
tar xf "../${name}-${version}.orig.tar.gz"
# CLEAN TARBALL
find -name '*.jar' -delete
find -name '*.class' -delete
find -name '*.zip' -delete
tar cf "../${name}-${version}.tar.gz" *
cd ..
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"

View File

@ -1 +1 @@
SHA512 (byte-buddy-1.9.13.tar.gz) = 30ea5fce9eeb9a84e80fc86f5d77eba9bfea939a7de5581481a300c47e85c8206843ef7155672603b26dce6df00c1a5a3fc2a3f38da69a2f33579f7a2790e132
SHA512 (byte-buddy-1.10.1.tar.gz) = bc53e2d16bc4b412538936219d65235380c156cf65cc9f391e3621004867b33079efc99a2915c22b3c9f7a3320d894eb28b6d63a37c526ee642a0dba947954e1