import byte-buddy-1.10.1-2.module+el8.2.0+5087+846a1d03
This commit is contained in:
commit
03072f7c33
1
.byte-buddy.metadata
Normal file
1
.byte-buddy.metadata
Normal file
@ -0,0 +1 @@
|
||||
f22989caeb364be1c4cdccfe48682a63c4147d23 SOURCES/byte-buddy-1.10.1.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/byte-buddy-1.10.1.tar.gz
|
2327
SOURCES/0001-Remove-dependency-on-jna.patch
Normal file
2327
SOURCES/0001-Remove-dependency-on-jna.patch
Normal file
File diff suppressed because it is too large
Load Diff
104
SOURCES/avoid-bundling-asm.patch
Normal file
104
SOURCES/avoid-bundling-asm.patch
Normal file
@ -0,0 +1,104 @@
|
||||
diff --git a/byte-buddy/pom.xml b/byte-buddy/pom.xml
|
||||
index 283da43..aca6bc5 100644
|
||||
--- a/byte-buddy/pom.xml
|
||||
+++ b/byte-buddy/pom.xml
|
||||
@@ -26,8 +26,6 @@
|
||||
-->
|
||||
|
||||
<properties>
|
||||
- <shade.source>org.objectweb.asm</shade.source>
|
||||
- <shade.target>net.bytebuddy.jar.asm</shade.target>
|
||||
<packages.list>
|
||||
net.bytebuddy,
|
||||
net.bytebuddy.agent.builder,
|
||||
@@ -62,9 +60,6 @@
|
||||
net.bytebuddy.utility,
|
||||
net.bytebuddy.utility.privilege,
|
||||
net.bytebuddy.utility.visitor,
|
||||
- ${shade.target},
|
||||
- ${shade.target}.signature,
|
||||
- ${shade.target}.commons
|
||||
</packages.list>
|
||||
</properties>
|
||||
|
||||
@@ -79,6 +74,16 @@
|
||||
<artifactId>byte-buddy-dep</artifactId>
|
||||
<version>${project.version}</version>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.ow2.asm</groupId>
|
||||
+ <artifactId>asm</artifactId>
|
||||
+ <version>${version.asm}</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.ow2.asm</groupId>
|
||||
+ <artifactId>asm-commons</artifactId>
|
||||
+ <version>${version.asm}</version>
|
||||
+ </dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
@@ -105,36 +110,6 @@
|
||||
<createDependencyReducedPom>true</createDependencyReducedPom>
|
||||
<createSourcesJar>${bytebuddy.extras}</createSourcesJar>
|
||||
<shadeSourcesContent>true</shadeSourcesContent>
|
||||
- <relocations>
|
||||
- <relocation>
|
||||
- <pattern>${shade.source}</pattern>
|
||||
- <shadedPattern>${shade.target}</shadedPattern>
|
||||
- </relocation>
|
||||
- </relocations>
|
||||
- <filters>
|
||||
- <filter>
|
||||
- <artifact>org.ow2.asm:*</artifact>
|
||||
- <excludes>
|
||||
- <exclude>**/module-info.class</exclude>
|
||||
- <exclude>**/LICENSE</exclude>
|
||||
- <exclude>**/NOTICE</exclude>
|
||||
- </excludes>
|
||||
- </filter>
|
||||
- <filter>
|
||||
- <artifact>org.ow2.asm:asm-commons</artifact>
|
||||
- <includes>
|
||||
- <include>org/objectweb/asm/commons/AnnotationRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/ClassRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/FieldRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/MethodRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/ModuleHashesAttribute.class</include>
|
||||
- <include>org/objectweb/asm/commons/ModuleRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/Remapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/SignatureRemapper.class</include>
|
||||
- <include>org/objectweb/asm/commons/SimpleRemapper.class</include>
|
||||
- </includes>
|
||||
- </filter>
|
||||
- </filters>
|
||||
<transformers>
|
||||
<transformer implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
|
||||
<mainClass>net.bytebuddy.build.Plugin$Engine$Default</mainClass>
|
||||
@@ -143,21 +118,14 @@
|
||||
<resource>META-INF/LICENSE</resource>
|
||||
</transformer>
|
||||
</transformers>
|
||||
+ <artifactSet>
|
||||
+ <excludes>
|
||||
+ <exclude>org.ow2.asm:*</exclude>
|
||||
+ </excludes>
|
||||
+ </artifactSet>
|
||||
</configuration>
|
||||
</execution>
|
||||
</executions>
|
||||
- <dependencies>
|
||||
- <dependency>
|
||||
- <groupId>org.ow2.asm</groupId>
|
||||
- <artifactId>asm</artifactId>
|
||||
- <version>${version.asm}</version>
|
||||
- </dependency>
|
||||
- <dependency>
|
||||
- <groupId>org.ow2.asm</groupId>
|
||||
- <artifactId>asm-commons</artifactId>
|
||||
- <version>${version.asm}</version>
|
||||
- </dependency>
|
||||
- </dependencies>
|
||||
</plugin>
|
||||
<!-- Disable pitest as it fails for empty modules -->
|
||||
<plugin>
|
178
SPECS/byte-buddy.spec
Normal file
178
SPECS/byte-buddy.spec
Normal file
@ -0,0 +1,178 @@
|
||||
Name: byte-buddy
|
||||
Version: 1.10.1
|
||||
Release: 2%{?dist}
|
||||
Summary: Runtime code generation for the Java virtual machine
|
||||
License: ASL 2.0
|
||||
URL: http://bytebuddy.net/
|
||||
# ./generate-tarball.sh
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
# Patch the build to avoid bundling inside shaded jars
|
||||
Patch1: avoid-bundling-asm.patch
|
||||
Patch2: 0001-Remove-dependency-on-jna.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(net.bytebuddy:byte-buddy)
|
||||
BuildRequires: mvn(net.bytebuddy:byte-buddy-dep)
|
||||
BuildRequires: mvn(net.bytebuddy:byte-buddy-maven-plugin)
|
||||
BuildRequires: mvn(org.apache.maven:maven-compat)
|
||||
BuildRequires: mvn(org.apache.maven.plugin-testing:maven-plugin-testing-harness)
|
||||
BuildRequires: mvn(org.mockito:mockito-core)
|
||||
BuildRequires: mvn(org.ow2.asm:asm-analysis)
|
||||
BuildRequires: mvn(org.ow2.asm:asm-util)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(org.apache.maven:maven-core)
|
||||
BuildRequires: mvn(org.apache.maven:maven-plugin-api)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-plugin-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugin-tools:maven-plugin-annotations)
|
||||
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||
BuildRequires: mvn(org.eclipse.aether:aether-api)
|
||||
BuildRequires: mvn(org.eclipse.aether:aether-util)
|
||||
BuildRequires: mvn(org.ow2.asm:asm)
|
||||
BuildRequires: mvn(org.ow2.asm:asm-commons)
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
Byte Buddy is a code generation library for creating Java classes during the
|
||||
runtime of a Java application and without the help of a compiler. Other than
|
||||
the code generation utilities that ship with the Java Class Library, Byte Buddy
|
||||
allows the creation of arbitrary classes and is not limited to implementing
|
||||
interfaces for the creation of runtime proxies.
|
||||
|
||||
%package agent
|
||||
Summary: Byte Buddy Java agent
|
||||
|
||||
%description agent
|
||||
The Byte Buddy Java agent allows to access the JVM's HotSwap feature.
|
||||
|
||||
%package maven-plugin
|
||||
Summary: Byte Buddy Maven plugin
|
||||
|
||||
%description maven-plugin
|
||||
A plugin for post-processing class files via Byte Buddy in a Maven build.
|
||||
|
||||
%package parent
|
||||
Summary: Byte Buddy parent POM
|
||||
|
||||
%description parent
|
||||
The parent artifact contains configuration information that
|
||||
concern all modules.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
This package contains API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{name}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Cause pre-compiled stuff to be re-compiled
|
||||
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/build/*.java \
|
||||
byte-buddy-dep/src/main/java/net/bytebuddy/build
|
||||
mkdir -p byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/
|
||||
mv byte-buddy-dep/src/precompiled/java/net/bytebuddy/test/precompiled/*.java \
|
||||
byte-buddy-dep/src/test/java/net/bytebuddy/test/precompiled/
|
||||
|
||||
# Don't ship android or benchmark modules
|
||||
%pom_disable_module byte-buddy-android
|
||||
%pom_disable_module byte-buddy-android-test
|
||||
%pom_disable_module byte-buddy-benchmark
|
||||
|
||||
# Don't ship gradle plugin
|
||||
%pom_disable_module byte-buddy-gradle-plugin
|
||||
|
||||
# Remove check plugins unneeded by RPM builds
|
||||
%pom_remove_plugin :jacoco-maven-plugin
|
||||
%pom_remove_plugin :license-maven-plugin
|
||||
%pom_remove_plugin :pitest-maven
|
||||
%pom_remove_plugin :coveralls-maven-plugin
|
||||
%pom_remove_plugin :spotbugs-maven-plugin
|
||||
%pom_remove_plugin :jitwatch-jarscan-maven-plugin
|
||||
%pom_remove_plugin :clirr-maven-plugin
|
||||
%pom_remove_plugin :maven-release-plugin
|
||||
|
||||
# Not interested in shading sources (causes NPE on old versions of shade plugin)
|
||||
%pom_xpath_set "pom:createSourcesJar" "false" byte-buddy
|
||||
|
||||
# Drop build dep on findbugs annotations, used only by the above check plugins
|
||||
%pom_remove_dep :findbugs-annotations
|
||||
sed -i -e '/SuppressFBWarnings/d' $(grep -lr SuppressFBWarnings)
|
||||
|
||||
# Plugin for generating Java 9 module-info file is not in Fedora
|
||||
%pom_remove_plugin -r :modulemaker-maven-plugin
|
||||
|
||||
%pom_remove_dep org.ow2.asm:asm-deprecated
|
||||
|
||||
%pom_remove_plugin :maven-shade-plugin byte-buddy
|
||||
%pom_remove_plugin :maven-shade-plugin byte-buddy-benchmark
|
||||
|
||||
%pom_remove_dep :jna byte-buddy-agent
|
||||
%pom_remove_dep :jna-platform byte-buddy-agent
|
||||
|
||||
%build
|
||||
# Ignore test failures, there seems to be something different about the
|
||||
# bytecode of our recompiled test resources, expect 6 test failures in
|
||||
# the byte-buddy-dep module
|
||||
%mvn_build -s -- -P'java8,!checks' -Dsourcecode.test.version=1.8 -Dmaven.test.failure.ignore=true
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles-%{name} -f .mfiles-%{name}-dep
|
||||
%doc README.md release-notes.md
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%files agent -f .mfiles-%{name}-agent
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%files maven-plugin -f .mfiles-%{name}-maven-plugin
|
||||
|
||||
%files parent -f .mfiles-%{name}-parent
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE NOTICE
|
||||
|
||||
%changelog
|
||||
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.10.1-2
|
||||
- Mass rebuild for javapackages-tools 201902
|
||||
|
||||
* Thu Sep 12 2019 Marian Koncek <mkoncek@redhat.com> - 1.10.1-1
|
||||
- Update to upstream version 1.10.1
|
||||
|
||||
* Wed Jul 10 2019 Marian Koncek <mkoncek@redhat.com> - 1.9.13-2
|
||||
- Remove the dependency on maven-shade-plugin
|
||||
|
||||
* Thu Jun 06 2019 Marian Koncek <mkoncek@redhat.com> - 1.9.13-1
|
||||
- Update to upstream version 1.9.13
|
||||
|
||||
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.9.5-5
|
||||
- Mass rebuild for javapackages-tools 201901
|
||||
|
||||
* Thu Dec 06 2018 Mat Booth <mat.booth@redhat.com> - 1.9.5-4
|
||||
- Prevent NPE in maven-shade-plugin
|
||||
|
||||
* Wed Dec 05 2018 Mat Booth <mat.booth@redhat.com> - 1.9.5-3
|
||||
- Enable test suites
|
||||
|
||||
* Tue Dec 04 2018 Mat Booth <mat.booth@redhat.com> - 1.9.5-2
|
||||
- Full, non-bootstrap build
|
||||
|
||||
* Fri Nov 30 2018 Mat Booth <mat.booth@redhat.com> - 1.9.5-1
|
||||
- Update to latest upstream release
|
||||
- Add a bootstrap mode to break circular self-dependency
|
||||
- Patch out use of optional external unixsocket library that is not present
|
||||
in Fedora
|
||||
- Patch to avoid bundling ASM inside the shaded jar
|
||||
|
||||
* Wed May 25 2016 gil cattaneo <puntogil@libero.it> 1.3.19-1
|
||||
- update to 1.3.19
|
||||
|
||||
* Tue Dec 22 2015 gil cattaneo <puntogil@libero.it> 0.7.7-1
|
||||
- initial rpm
|
Loading…
Reference in New Issue
Block a user