Florian Weimer 2023-01-11 12:10:27 +01:00
parent b06f4d2054
commit e2ea6ac11d
2 changed files with 23 additions and 2 deletions

17
byaccj-c99.patch Normal file
View File

@ -0,0 +1,17 @@
Include <unistd.h> for the unlink function. This avoids an implicit
function declaration, increasing C99 compatibility.
Submitted upstream: <https://sourceforge.net/p/byaccj/patches/5/>
diff --git a/src/main.c b/src/main.c
index 54b5e05ba3aa2946..e4deacd47a3c0d34 100755
--- a/src/main.c
+++ b/src/main.c
@@ -4,6 +4,7 @@
#ifndef __WIN32__ /*rwj -- make portable*/
#include <signal.h>
+#include <unistd.h>
#else
#include <dir.h>
#endif

View File

@ -1,11 +1,12 @@
Summary: Parser Generator with Java Extension Summary: Parser Generator with Java Extension
Name: byaccj Name: byaccj
Version: 1.15 Version: 1.15
Release: 28%{?dist} Release: 29%{?dist}
License: Public Domain License: Public Domain
URL: http://byaccj.sourceforge.net/ URL: http://byaccj.sourceforge.net/
Source0: http://sourceforge.net/projects/byaccj/files/byaccj/1.15/byaccj1.15_src.tar.gz Source0: http://sourceforge.net/projects/byaccj/files/byaccj/1.15/byaccj1.15_src.tar.gz
Patch0: byaccj-c99.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: make BuildRequires: make
@ -23,7 +24,7 @@ generate Java source code, instead. So there finally is a YACC for
Java now! Java now!
%prep %prep
%setup -q -n %{name}%{version} %autosetup -p1 -n %{name}%{version}
chmod -c -x src/* docs/* chmod -c -x src/* docs/*
sed -i -e 's|-arch i386 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -mmacosx-version-min=10.4|$(LDFLAGS)|g' src/Makefile sed -i -e 's|-arch i386 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -mmacosx-version-min=10.4|$(LDFLAGS)|g' src/Makefile
@ -41,6 +42,9 @@ install -p -m 755 src/yacc %{buildroot}%{_bindir}/%{name}
%{_bindir}/%{name} %{_bindir}/%{name}
%changelog %changelog
* Wed Jan 11 2023 Florian Weimer <fweimer@redhat.com> - 1.15-29
- C99 compatibility fix
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.15-28 * Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.15-28
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild