release: butane 0.12.0
This commit is contained in:
parent
e2f7920aa2
commit
e7c62b5f82
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/butane-0.11.0.tar.gz
|
||||
/butane-0.12.0.tar.gz
|
||||
|
@ -1,17 +0,0 @@
|
||||
Fix test failure on 386
|
||||
|
||||
https://github.com/coreos/vcontext/pull/14
|
||||
|
||||
diff --git a/vendor/github.com/coreos/vcontext/report/report.go b/vendor/github.com/coreos/vcontext/report/report.go
|
||||
index 5378e84..618bc75 100644
|
||||
--- a/vendor/github.com/coreos/vcontext/report/report.go
|
||||
+++ b/vendor/github.com/coreos/vcontext/report/report.go
|
||||
@@ -131,7 +131,7 @@ func (r *Report) AddOn(c path.ContextPath, err error, k EntryKind) {
|
||||
}
|
||||
r.Entries = append(r.Entries, Entry{
|
||||
Message: err.Error(),
|
||||
- Context: c,
|
||||
+ Context: c.Copy(),
|
||||
Kind: k,
|
||||
})
|
||||
}
|
38
butane.spec
38
butane.spec
@ -4,7 +4,7 @@
|
||||
# https://github.com/coreos/butane
|
||||
%global goipath github.com/coreos/butane
|
||||
%global gomodulesmode GO111MODULE=on
|
||||
Version: 0.11.0
|
||||
Version: 0.12.0
|
||||
|
||||
%gometa
|
||||
|
||||
@ -23,9 +23,6 @@ Summary: Butane config transpiler
|
||||
License: ASL 2.0
|
||||
URL: %{gourl}
|
||||
Source0: %{gosource}
|
||||
# Fix test failure on 32-bit
|
||||
# https://github.com/coreos/vcontext/pull/14
|
||||
Patch0: butane-0.11.0-fix-vcontext-report-copy.patch
|
||||
|
||||
# Upgrade path from old FCCT package; can be dropped in Fedora 36
|
||||
Provides: fedora-coreos-config-transpiler = %{version}-%{release}
|
||||
@ -38,21 +35,21 @@ Provides: bundled(golang(github.com/clarketm/json)) = 1.14.1
|
||||
Provides: bundled(golang(github.com/coreos/go-semver/semver)) = 0.3.0
|
||||
Provides: bundled(golang(github.com/coreos/go-systemd/unit)) = 0.0.0-20190321100706.git95778dfbb74e
|
||||
Provides: bundled(golang(github.com/coreos/go-systemd/v22/unit)) = 0.0.0-20190321100706.git95778dfbb74e
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/merge)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/shared/errors)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/shared/validations)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/util)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_0/types)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_1/types)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_2/types)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_3_experimental/types)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/validate)) = 2.9.1-20210304043908.git47da4066daa8
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/json)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/path)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/report)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/tree)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/validate)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/yaml)) = 0.0.0-20201120045928.gitb0e13dab675c
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/merge)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/shared/errors)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/shared/validations)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/util)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_0/types)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_1/types)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_2/types)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/v3_3_experimental/types)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/ignition/v2/config/validate)) = 2.9.1-0.20210429055457.git20d5d693f79a
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/json)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/path)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/report)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/tree)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/validate)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/coreos/vcontext/yaml)) = 0.0.0-20210407161507.git4ee6c745c8bd
|
||||
Provides: bundled(golang(github.com/davecgh/go-spew/spew)) = 1.1.1
|
||||
Provides: bundled(golang(github.com/spf13/pflag)) = 1.0.5
|
||||
Provides: bundled(golang(github.com/stretchr/testify/assert)) = 1.5.1
|
||||
@ -120,5 +117,8 @@ install -p -m 0644 ./butane-x86_64-pc-windows-gnu.exe %{buildroot}%{_datadir}/bu
|
||||
%{_datadir}/butane/butane-x86_64-pc-windows-gnu.exe
|
||||
|
||||
%changelog
|
||||
* Tue Jun 08 2021 Sohan Kunkerkar <skunkerk@redhat.com> - 0.12.0-1
|
||||
- New release
|
||||
|
||||
* Tue Apr 06 2021 Benjamin Gilbert <bgilbert@redhat.com> - 0.11.0-1
|
||||
- Initial package
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (butane-0.11.0.tar.gz) = c3c6a86fd953f51bba5188ade762250f32419513797b67f12081f15e56a2a0e505527f4d9841fbe5ae81d86b160e42458b077a41f9392ec7f9049b539364de81
|
||||
SHA512 (butane-0.12.0.tar.gz) = 31bbb51c0ff7938939b9746f5b4b88bc8ffdf0fb2346912d6728f0f7642e5cf038485a2e71f441893abff2d3c5b334f1998d53bc6d24f8872478b7f0dd1be77a
|
||||
|
Loading…
Reference in New Issue
Block a user