import buildah-1.24.2-2.module+el8.6.0+14305+6b14f34e

This commit is contained in:
CentOS Sources 2022-03-29 10:26:32 -04:00 committed by Stepan Oksanichenko
parent 2a6396ae43
commit 856d7498f1
4 changed files with 195 additions and 9 deletions

View File

@ -1 +1 @@
f7aaa151b2f00ce3a1e437704765e23df61446d1 SOURCES/release-1.22-4d20222.tar.gz
bfaa7b5c8d8169ed7a175c1edea673bca9dc184c SOURCES/buildah-1.24.2-ce608bc.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/release-1.22-4d20222.tar.gz
SOURCES/buildah-1.24.2-ce608bc.tar.gz

View File

@ -0,0 +1,45 @@
From eedab4fd872c3be8ab15af767897f92c78a71fde Mon Sep 17 00:00:00 2001
From: Lokesh Mandvekar <lsm5@fedoraproject.org>
Date: Mon, 21 Feb 2022 14:58:40 -0500
Subject: [PATCH] helpers.bash: Use correct syntax
Fixes gating test failure:
```
/usr/share/buildah/test/system/./helpers.bash: line 474: !is_cgroupsv2: command not found
```
Co-authored-by: Yiqiao Pu <ypu@redhat.com>
I'm just the committer.
Signed-off-by: Lokesh Mandvekar <lsm5@fedoraproject.org>
---
tests/helpers.bash | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/tests/helpers.bash b/tests/helpers.bash
index bd2794c974..3e72108bec 100644
--- a/tests/helpers.bash
+++ b/tests/helpers.bash
@@ -433,9 +433,9 @@ function skip_if_rootless() {
##################################
function skip_if_rootless_and_cgroupv1() {
if test "$BUILDAH_ISOLATION" = "rootless"; then
- if !is_cgroupsv2; then
- skip "${1:-test does not work when \$BUILDAH_ISOLATION = rootless} and not cgroupv2"
- fi
+ if ! is_cgroupsv2; then
+ skip "${1:-test does not work when \$BUILDAH_ISOLATION = rootless} and not cgroupv2"
+ fi
fi
}
@@ -471,7 +471,7 @@ function skip_if_cgroupsv2() {
# skip_if_cgroupsv1 # Some tests don't work with cgroupsv1
#######################
function skip_if_cgroupsv1() {
- if !is_cgroupsv2; then
+ if ! is_cgroupsv2; then
skip "${1:-test does not work with cgroups v1}"
fi
}

View File

@ -11,12 +11,13 @@ go build -buildmode pie -compiler gc -tags="rpm_crashtraceback libtrust_openssl
%endif
%global import_path github.com/containers/buildah
%global branch release-1.22
%global commit0 4d2022278696ad2f39b5c95029d8c699db404f37
#%%global branch main
%global commit0 ce608bcecdeb077daab846c83b026c508cff9688
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Epoch: 1
Name: buildah
Version: 1.22.3
Version: 1.24.2
Release: 2%{?dist}
Summary: A command line tool used for creating OCI Images
License: ASL 2.0
@ -26,8 +27,9 @@ ExclusiveArch: %{go_arches}
%if 0%{?branch:1}
Source0: https://%{import_path}/tarball/%{commit0}/%{branch}-%{shortcommit0}.tar.gz
%else
Source0: https://%{import_path}/archive/%{commit0}/%{name}-%{version}-%%{shortcommit0}.tar.gz
Source0: https://%{import_path}/archive/%{commit0}/%{name}-%{version}-%{shortcommit0}.tar.gz
%endif
Patch0: fix-bash-syntax.patch
BuildRequires: golang >= 1.16.6
BuildRequires: git
BuildRequires: glib2-devel
@ -55,7 +57,7 @@ or
%package tests
Summary: Tests for %{name}
Requires: %{name} = %{version}-%{release}
Requires: %{name} = %{epoch}:%{version}-%{release}
Requires: bzip2
Requires: podman
Requires: golang
@ -73,7 +75,7 @@ This package contains system tests for %{name}
%if 0%{?branch:1}
%autosetup -Sgit -n containers-%{name}-%{shortcommit0}
%else
%autosetup -Sgit -n %%{name}-%{commit0}
%autosetup -Sgit -n %{name}-%{commit0}
%endif
sed -i 's/GOMD2MAN =/GOMD2MAN ?=/' docs/Makefile
sed -i '/docs install/d' Makefile
@ -115,7 +117,7 @@ make DESTDIR=%{buildroot} PREFIX=%{_prefix} -C docs install
%license LICENSE
%doc README.md
%{_bindir}/%{name}
%{_mandir}/man1/%{name}*
%{_mandir}/man[15]/*
%dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/%{name}
@ -127,6 +129,145 @@ make DESTDIR=%{buildroot} PREFIX=%{_prefix} -C docs install
%{_datadir}/%{name}/test
%changelog
* Mon Feb 21 2022 Lokesh Mandvekar <lsm5@redhat.com> - 1:1.24.2-2
- Add patch to fix bash symtax for gating tests
- Upstream PR: https://github.com/containers/buildah/pull/3792
- Related: #2001445
* Thu Feb 17 2022 Jindrich Novy <jnovy@redhat.com> - 1:1.24.2-1
- update to https://github.com/containers/buildah/releases/tag/v1.24.2
- Related: #2001445
* Fri Feb 04 2022 Jindrich Novy <jnovy@redhat.com> - 1:1.24.1-1
- update to https://github.com/containers/buildah/releases/tag/v1.24.1
- Related: #2001445
* Wed Feb 02 2022 Jindrich Novy <jnovy@redhat.com> - 1:1.24.0-1
- update to https://github.com/containers/buildah/releases/tag/v1.24.0
- Related: #2001445
* Tue Jan 25 2022 Jindrich Novy <jnovy@redhat.com> - 1:1.23.2-1
- update to the latest content of https://github.com/containers/buildah/tree/release-1.23
(https://github.com/containers/buildah/commit/83a66a7)
- Related: #2001445
* Mon Nov 22 2021 Jindrich Novy <jnovy@redhat.com> - 1:1.23.1-3
- update to the latest content of https://github.com/containers/buildah/tree/release-1.23
(https://github.com/containers/buildah/commit/867c1bc)
- Related: #2001445
* Mon Oct 18 2021 Jindrich Novy <jnovy@redhat.com> - 1:1.23.1-2
- respect Epoch in subpackage dependencies
- Related: #2001445
* Fri Oct 15 2021 Jindrich Novy <jnovy@redhat.com> - 1:1.23.1-1
- bump Epoch to preserve upgrade path
- Related: #2001445
* Wed Oct 13 2021 Jindrich Novy <jnovy@redhat.com> - 1.23.1-0.1
- update to the latest content of https://github.com/containers/buildah/tree/release-1.23
(https://github.com/containers/buildah/commit/87a0565)
- Related: #2001445
* Wed Oct 13 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.18
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/982717a)
- Related: #2001445
* Mon Oct 11 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.17
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/50869a7)
- Related: #2001445
* Fri Oct 08 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.16
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/211972a)
- Related: #2001445
* Thu Oct 07 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.15
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/c044ad6)
- Related: #2001445
* Wed Oct 06 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.14
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/7807a0e)
- Related: #2001445
* Mon Oct 04 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.13
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/0cd9445)
- Related: #2001445
* Fri Oct 01 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.12
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/954c481)
- Related: #2001445
* Thu Sep 30 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.11
- include all man pages
- Related: #2001445
* Thu Sep 30 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.10
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/d2ef199)
- Related: #2001445
* Wed Sep 29 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.9
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/455f2f1)
- Related: #2001445
* Mon Sep 27 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.8
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/8548885)
- Related: #2001445
* Fri Sep 24 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.7
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/9a49348)
- Related: #2001445
* Thu Sep 23 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.6
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/a72aad4)
- Related: #2001445
* Wed Sep 22 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.5
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/b8757e9)
- Related: #2001445
* Tue Sep 21 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.4
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/fb84638)
- Related: #2001445
* Mon Sep 20 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.3
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/f3f3c55)
- Related: #2001445
* Fri Sep 17 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.2
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/753716a)
- Related: #2001445
* Wed Sep 15 2021 Jindrich Novy <jnovy@redhat.com> - 1.24.0-0.1
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/69b3e56)
- Related: #2001445
* Mon Sep 13 2021 Jindrich Novy <jnovy@redhat.com> - 1.23.0-0.2
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/e9bc224)
- Related: #2001445
* Fri Sep 10 2021 Jindrich Novy <jnovy@redhat.com> - 1.23.0-0.1
- update to the latest content of https://github.com/containers/buildah/tree/main
(https://github.com/containers/buildah/commit/a5aba5c)
- Related: #2001445
* Wed Aug 25 2021 Jindrich Novy <jnovy@redhat.com> - 1.22.3-2
- update to the latest content of https://github.com/containers/buildah/tree/release-1.22
(https://github.com/containers/buildah/commit/4d20222)