import buildah-1.24.2-4.el9_0
This commit is contained in:
commit
390324bb95
1
.buildah.metadata
Normal file
1
.buildah.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
09993f8aad3024403e1e2aa76aa3d11d1023cceb SOURCES/release-1.24-7b559a3.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/release-1.24-7b559a3.tar.gz
|
45
SOURCES/fix-bash-syntax.patch
Normal file
45
SOURCES/fix-bash-syntax.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
From eedab4fd872c3be8ab15af767897f92c78a71fde Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lokesh Mandvekar <lsm5@fedoraproject.org>
|
||||||
|
Date: Mon, 21 Feb 2022 14:58:40 -0500
|
||||||
|
Subject: [PATCH] helpers.bash: Use correct syntax
|
||||||
|
|
||||||
|
Fixes gating test failure:
|
||||||
|
```
|
||||||
|
/usr/share/buildah/test/system/./helpers.bash: line 474: !is_cgroupsv2: command not found
|
||||||
|
```
|
||||||
|
|
||||||
|
Co-authored-by: Yiqiao Pu <ypu@redhat.com>
|
||||||
|
|
||||||
|
I'm just the committer.
|
||||||
|
|
||||||
|
Signed-off-by: Lokesh Mandvekar <lsm5@fedoraproject.org>
|
||||||
|
---
|
||||||
|
tests/helpers.bash | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/helpers.bash b/tests/helpers.bash
|
||||||
|
index bd2794c974..3e72108bec 100644
|
||||||
|
--- a/tests/helpers.bash
|
||||||
|
+++ b/tests/helpers.bash
|
||||||
|
@@ -433,9 +433,9 @@ function skip_if_rootless() {
|
||||||
|
##################################
|
||||||
|
function skip_if_rootless_and_cgroupv1() {
|
||||||
|
if test "$BUILDAH_ISOLATION" = "rootless"; then
|
||||||
|
- if !is_cgroupsv2; then
|
||||||
|
- skip "${1:-test does not work when \$BUILDAH_ISOLATION = rootless} and not cgroupv2"
|
||||||
|
- fi
|
||||||
|
+ if ! is_cgroupsv2; then
|
||||||
|
+ skip "${1:-test does not work when \$BUILDAH_ISOLATION = rootless} and not cgroupv2"
|
||||||
|
+ fi
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -471,7 +471,7 @@ function skip_if_cgroupsv2() {
|
||||||
|
# skip_if_cgroupsv1 # Some tests don't work with cgroupsv1
|
||||||
|
#######################
|
||||||
|
function skip_if_cgroupsv1() {
|
||||||
|
- if !is_cgroupsv2; then
|
||||||
|
+ if ! is_cgroupsv2; then
|
||||||
|
skip "${1:-test does not work with cgroups v1}"
|
||||||
|
fi
|
||||||
|
}
|
2504
SPECS/buildah.spec
Normal file
2504
SPECS/buildah.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user