Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/bsh.git#e93dc6afb5a24a87fd328699b5ce7cb4e61169d4
This commit is contained in:
DistroBaker 2021-02-06 11:26:48 +00:00
parent c82432074f
commit dd70a50406
6 changed files with 37 additions and 76 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
bsh-1.3.0-src.tar.bz2 bsh-1.3.0-src.tar.bz2
/2.0b6.tar.gz /2.0b6.tar.gz
/bsh-2.0-b6.tar.gz /bsh-2.0-b6.tar.gz
/bsh-2.1.0.tar.gz

View File

@ -1,35 +1,24 @@
From 62ea7bb2656177fbb61d94b90d9a526990876cb8 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 20 Jul 2020 21:27:20 +0200
Subject: [PATCH 0/1] source / target 1.8
---
build.xml | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/build.xml b/build.xml diff --git a/build.xml b/build.xml
index 4f400dc..0d28a7f 100644 index 8542245..6179cfa 100644
--- a/build.xml --- a/build.xml
+++ b/build.xml +++ b/build.xml
@@ -170,7 +170,8 @@ @@ -178,8 +178,8 @@
deprecation="${deprecation}"
optimize="on"
debug="on" debug="on"
- target="1.5"
+ source="1.8"
+ target="1.8"
includes="**/*.java" includes="**/*.java"
excludes="${excludes},**/bak/**" excludes="${excludes},**/bak/**"
- source="1.6"
- target="1.6"
+ source="1.8"
+ target="1.8"
> >
@@ -213,7 +214,7 @@ <classpath>
<fileset refid="lib-fileset"/>
@@ -255,7 +255,7 @@
destdir="${javadoc-dir}" destdir="${javadoc-dir}"
author="true" author="true"
version="true" version="true"
- source="1.5" - source="1.6"
+ source="1.8" + source="1.8"
use="true" use="true"
windowtitle="BeanShell ${version}" windowtitle="BeanShell ${version}"
doctitle="&lt;h1&gt;BeanShell ${version}&lt;h1&gt;" doctitle="&lt;h1&gt;BeanShell ${version}&lt;h1&gt;"
--
2.26.2

View File

@ -1,9 +0,0 @@
[Desktop Entry]
Name=BeanShell Desktop
Exec=bsh-desktop
Icon=bsh
Terminal=false
Type=Application
StartupWMClass=bsh-Console
Categories=Development;Java;
Version=1.0

View File

@ -28,26 +28,18 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# #
%global reltag b6
%if 0%{?rhel} >= 8
%bcond_with desktop
%else
%bcond_without desktop
%endif
Name: bsh Name: bsh
Version: 2.0 Version: 2.1.0
Release: 22.%{reltag}%{?dist} Release: 1%{?dist}
Epoch: 0 Epoch: 0
Summary: Lightweight Scripting for Java Summary: Lightweight Scripting for Java
URL: http://www.beanshell.org/ URL: http://www.beanshell.org/
# bundled asm is BSD # bundled asm is BSD
# bsf/src/bsh/util/BeanShellBSFEngine.java is public-domain # bsf/src/bsh/util/BeanShellBSFEngine.java is public-domain
License: ASL 2.0 and BSD and Public Domain License: ASL 2.0 and BSD and Public Domain
BuildArch: noarch
# ./generate-tarball.sh # ./generate-tarball.sh
Source0: %{name}-%{version}-%{reltag}.tar.gz Source0: %{name}-%{version}.tar.gz
Source1: %{name}-desktop.desktop
# Remove bundled jars which cannot be easily verified for licensing # Remove bundled jars which cannot be easily verified for licensing
# Remove code marked as SUN PROPRIETARY/CONFIDENTAIL # Remove code marked as SUN PROPRIETARY/CONFIDENTAIL
Source2: generate-tarball.sh Source2: generate-tarball.sh
@ -58,25 +50,23 @@ Patch0: 0000-source-target-1.8.patch
# - remove references to invisible symbols and methods # - remove references to invisible symbols and methods
Patch1: 0001-java-11-compatibility.patch Patch1: 0001-java-11-compatibility.patch
BuildRequires: javapackages-local BuildArch: noarch
BuildRequires: ant BuildRequires: ant
BuildRequires: bsf BuildRequires: bsf
BuildRequires: junit
BuildRequires: javacc
BuildRequires: glassfish-servlet-api BuildRequires: glassfish-servlet-api
%if %{with desktop} BuildRequires: javacc
BuildRequires: ImageMagick BuildRequires: javapackages-local
BuildRequires: desktop-file-utils BuildRequires: junit
%endif
Requires: java-headless
Requires: bsf Requires: bsf
Requires: java-headless
Requires: jline2 Requires: jline2
# Explicit javapackages-tools requires since scripts use # Explicit javapackages-tools requires since scripts use
# /usr/share/java-utils/java-functions # /usr/share/java-utils/java-functions
Requires: javapackages-tools Requires: javapackages-tools
Provides: %{name}-utils = %{epoch}:%{version}-%{release} Provides: %{name}-utils = %{epoch}:%{version}-%{release}
Obsoletes: %{name}-utils < 0:2.0 Obsoletes: %{name}-utils < 0:2.0
Obsoletes: %{name}-demo < 0:2.0 Obsoletes: %{name}-demo < 0:2.0
@ -118,7 +108,7 @@ Summary: API documentation for %{name}
This package provides %{summary}. This package provides %{summary}.
%prep %prep
%setup -q -n beanshell-%{version}%{reltag} %setup -q -n beanshell-%{version}
%patch0 -p1 %patch0 -p1
%patch1 -p1 %patch1 -p1
@ -135,19 +125,10 @@ build-jar-repository lib bsf javacc junit glassfish-servlet-api
ant test dist ant test dist
%install %install
%mvn_artifact pom.xml dist/%{name}-%{version}%{reltag}.jar %mvn_artifact pom.xml dist/%{name}-%{version}.jar
%mvn_install -J javadoc %mvn_install -J javadoc
%if %{with desktop}
# menu entry
desktop-file-install --mode=644 \
--dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
install -d -m 755 %{buildroot}%{_datadir}/pixmaps
convert src/bsh/util/lib/icon.gif \
%{buildroot}%{_datadir}/pixmaps/bsh.png
%endif
install -d -m 755 %{buildroot}%{_datadir}/%{name} install -d -m 755 %{buildroot}%{_datadir}/%{name}
install -d -m 755 %{buildroot}%{_datadir}/%{name}/webapps install -d -m 755 %{buildroot}%{_datadir}/%{name}/webapps
install -m 644 dist/bshservlet.war %{buildroot}%{_datadir}/%{name}/webapps install -m 644 dist/bshservlet.war %{buildroot}%{_datadir}/%{name}/webapps
@ -165,12 +146,9 @@ cat scripts/bshdoc.bsh >> %{buildroot}%{_bindir}/bshdoc
%files -f .mfiles %files -f .mfiles
%license LICENSE NOTICE %license LICENSE NOTICE
%doc README.md src/Changes.html src/CodeMap.html docs/faq/faq.html %doc README.md src/Changes.html src/CodeMap.html docs/faq/faq.html
%attr(0755,root,root) %{_bindir}/%{name}* %attr(0755,root,root) %{_bindir}/%{name}*
%if %{with desktop} %{_datadir}/%{name}/
%{_datadir}/applications/%{name}-desktop.desktop
%{_datadir}/pixmaps/%{name}.png
%endif
%{_datadir}/%{name}
%files manual %files manual
%doc docs/manual/html %doc docs/manual/html
@ -182,6 +160,9 @@ cat scripts/bshdoc.bsh >> %{buildroot}%{_bindir}/bshdoc
%license LICENSE NOTICE %license LICENSE NOTICE
%changelog %changelog
* Mon Feb 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0:2.1.0-1
- Update to version 2.1.0.
* Wed Jan 27 2021 Tomas Popela <tpopela@redhat.com> - 0:2.0-22.b6 * Wed Jan 27 2021 Tomas Popela <tpopela@redhat.com> - 0:2.0-22.b6
- Don't build the desktop support on RHEL 8+ as ImageMagick isn't available there. - Don't build the desktop support on RHEL 8+ as ImageMagick isn't available there.

View File

@ -3,23 +3,22 @@ set -e
name=bsh name=bsh
version="$(sed -n 's/Version:\s*//p' *.spec)" version="$(sed -n 's/Version:\s*//p' *.spec)"
reltag="$(sed -n 's/%global\s*reltag\s*//p' *.spec)"
# RETRIEVE # RETRIEVE
wget "https://github.com/beanshell/beanshell/archive/${version}${reltag}.tar.gz" -O "${name}-${version}-${reltag}.orig.tar.gz" wget "https://github.com/beanshell/beanshell/archive/${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
rm -rf tarball-tmp rm -rf tarball-tmp
mkdir tarball-tmp mkdir tarball-tmp
cd tarball-tmp cd tarball-tmp
tar xf "../${name}-${version}-${reltag}.orig.tar.gz" tar xf "../${name}-${version}.orig.tar.gz"
# CLEAN TARBALL # CLEAN TARBALL
rm -r */lib rm -r */lib
find -name '*.jar' -delete find -name '*.jar' -print -delete
find -name '*.class' -delete find -name '*.class' -print -delete
# Files marked as SUN PROPRIETARY/CONFIDENTAIL # Files marked as SUN PROPRIETARY/CONFIDENTAIL
rm -r */engine/javax-src rm -rv */engine/javax-src
tar cf "../${name}-${version}-${reltag}.tar.gz" * tar cf "../${name}-${version}.tar.gz" *
cd .. cd ..
rm -r tarball-tmp "${name}-${version}-${reltag}.orig.tar.gz" rm -r tarball-tmp "${name}-${version}.orig.tar.gz"

View File

@ -1 +1 @@
SHA512 (bsh-2.0-b6.tar.gz) = 22e920fa78d2117cc27074f12a12246cb2923b1d308736b2ed5fd2faa9bbc8b77b4991abc862097cce4e9de473c17a9d9a85ee5bdab5462f4a92c64c3d49bfc1 SHA512 (bsh-2.1.0.tar.gz) = 4cee4ffc97e0214b0ef3fbfbfacc3ec55e8bbf7b26c36e51fd03f087c9317501e4d975f4b1c4b1d04afd0a9120789c45f8ea9390598e19802bc063d367bd247e