Fix pom filenames (Resolves rhbz#655791)
few more fixes to enable build of documentation (xsl patches)
This commit is contained in:
parent
bb423b33d8
commit
536318dd88
34
bsh-xsl-fixes.patch
Normal file
34
bsh-xsl-fixes.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff --git a/docs/faq/faq.xsl b/docs/faq/faq.xsl
|
||||
index 44615de..341b435 100644
|
||||
--- a/docs/faq/faq.xsl
|
||||
+++ b/docs/faq/faq.xsl
|
||||
@@ -18,7 +18,7 @@
|
||||
<!--xsl:param name="imagedir"/-->
|
||||
|
||||
<!-- Output directives -->
|
||||
-<xsl:output method="xhtml" indent="yes"/>
|
||||
+<xsl:output method="html" indent="yes"/>
|
||||
|
||||
<!--
|
||||
Root
|
||||
diff --git a/docs/manual/xsl/manual.xsl b/docs/manual/xsl/manual.xsl
|
||||
index 3b8208c..d733260 100644
|
||||
--- a/docs/manual/xsl/manual.xsl
|
||||
+++ b/docs/manual/xsl/manual.xsl
|
||||
@@ -1,6 +1,6 @@
|
||||
<xsl:stylesheet
|
||||
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"
|
||||
- xmlns:redirect="org.apache.xalan.xslt.extensions.Redirect"
|
||||
+ xmlns:redirect="http://xml.apache.org/xalan/redirect"
|
||||
extension-element-prefixes="redirect"
|
||||
>
|
||||
|
||||
@@ -29,7 +29,7 @@
|
||||
<xsl:param name="pagesdir"/>
|
||||
|
||||
<!-- Output directives -->
|
||||
-<xsl:output method="xhtml" indent="no"/>
|
||||
+<xsl:output method="html" indent="no"/>
|
||||
|
||||
<!--
|
||||
Root
|
23
bsh.spec
23
bsh.spec
@ -30,7 +30,7 @@
|
||||
|
||||
Name: bsh
|
||||
Version: 1.3.0
|
||||
Release: 15.2%{?dist}
|
||||
Release: 16%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Lightweight Scripting for Java
|
||||
License: SPL or LGPLv2+
|
||||
@ -43,12 +43,13 @@ Source2: bsh-bsf-1.3.0.pom
|
||||
Source3: %{name}-desktop.desktop
|
||||
|
||||
Patch0: %{name}-build.patch
|
||||
#Patch1: %{name}-readline.patch
|
||||
Patch1: %{name}-xsl-fixes.patch
|
||||
BuildRequires: java >= 1:1.6.0
|
||||
BuildRequires: ant, bsf, ant-trax, ImageMagick, desktop-file-utils
|
||||
BuildRequires: servlet
|
||||
Requires: java >= 1:1.6.0
|
||||
Requires: bsf
|
||||
Requires: jpackage-utils >= 0:1.7.2
|
||||
#BuildRequires: libreadline-java
|
||||
URL: http://www.beanshell.org/
|
||||
Group: Development/Libraries
|
||||
BuildArch: noarch
|
||||
@ -98,7 +99,7 @@ Requires: /usr/bin/env
|
||||
Demonstrations and samples for %{name}.
|
||||
|
||||
%package desktop
|
||||
Summary: Desktop integraton for %{name}
|
||||
Summary: Desktop integraton for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
|
||||
@ -108,7 +109,7 @@ Contains a menu entry for %{name}.
|
||||
%prep
|
||||
%setup -q -n BeanShell
|
||||
%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch1 -p1
|
||||
for j in $(find . -name "*.jar"); do
|
||||
mv $j $j.no
|
||||
done
|
||||
@ -128,8 +129,8 @@ ln -sf $(build-classpath servlet)
|
||||
popd
|
||||
ant -Dant.build.javac.source=1.4 dist
|
||||
%ifnarch ppc64 s390x
|
||||
(cd docs/faq && ant -Dant.build.javac.source=1.4)
|
||||
(cd docs/manual && ant -Dant.build.javac.source=1.4)
|
||||
(cd docs/faq && ant -Dant.build.javac.source=1.5)
|
||||
(cd docs/manual && ant -Dant.build.javac.source=1.5)
|
||||
%endif
|
||||
|
||||
%install
|
||||
@ -158,9 +159,9 @@ install -m 644 dist/%{name}-util-%{version}.jar \
|
||||
# poms
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
|
||||
install -pm 644 %{SOURCE1} \
|
||||
$RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}.pom
|
||||
$RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-%{name}.pom
|
||||
install -pm 644 %{SOURCE2} \
|
||||
$RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP.%{name}-bsf.pom
|
||||
$RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-%{name}-bsf.pom
|
||||
|
||||
# manual
|
||||
find docs -name ".cvswrappers" -exec rm -f {} \;
|
||||
@ -321,6 +322,10 @@ fi
|
||||
%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
|
||||
|
||||
%changelog
|
||||
* Thu Nov 25 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.3.0-16
|
||||
- Fix pom filenames (Resolves rhbz#655791)
|
||||
- Fix xsl errors when building docs
|
||||
|
||||
* Sat Jan 9 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.0-15.2
|
||||
- Drop gcj_support.
|
||||
- Fix rpmlint warnings.
|
||||
|
Loading…
Reference in New Issue
Block a user