4.3, Merge review fixes.
This commit is contained in:
parent
4dae1f4b89
commit
ff381fe8b7
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
brltty-4.2.tar.gz
|
||||
/brltty-4.3.tar.gz
|
||||
|
@ -1,18 +1,11 @@
|
||||
2008-09-17 Stepan Kasal <skasal@redhat.com>
|
||||
|
||||
* Programs/Makefile.in (braille-drivers): Add
|
||||
prerequisity `all' to prevent race of this make with nested
|
||||
"make brlapi" when parallel make is used. Recursive make is
|
||||
harmful.
|
||||
|
||||
--- brltty-4.2/Programs/Makefile.in.BAD 2010-05-21 16:27:45.231183660 -0400
|
||||
+++ brltty-4.2/Programs/Makefile.in 2010-05-21 16:27:51.437122063 -0400
|
||||
@@ -484,7 +484,7 @@ apitest.$O:
|
||||
--- brltty-4.3/Programs/Makefile.in~ 2011-10-07 10:03:28.000000000 -0500
|
||||
+++ brltty-4.3/Programs/Makefile.in 2011-10-18 12:54:35.000000000 -0500
|
||||
@@ -526,7 +526,7 @@
|
||||
|
||||
###############################################################################
|
||||
|
||||
-braille-drivers:
|
||||
+braille-drivers: api
|
||||
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
||||
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
||||
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver) || exit 1; \
|
||||
done
|
||||
|
37
brltty.spec
37
brltty.spec
@ -1,5 +1,5 @@
|
||||
%define pkg_version 4.2
|
||||
%define api_version 0.5.5
|
||||
%define pkg_version 4.3
|
||||
%define api_version 0.5.6
|
||||
|
||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
||||
@ -15,14 +15,14 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 4%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://mielke.cc/brltty/
|
||||
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
||||
Patch0: brltty-cppflags.patch
|
||||
Patch1: brltty-autoconf-quote.patch
|
||||
Patch2: brltty-4.2-S_ISCHR.patch
|
||||
#Patch2: brltty-4.2-S_ISCHR.patch
|
||||
Patch3: brltty-parallel.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
@ -38,7 +38,7 @@ for a blind person using a refreshable braille display.
|
||||
It drives the braille display and provides complete
|
||||
screen review functionality.
|
||||
%if %{with_speech_dispatcher}
|
||||
BRLTTY can also work with speech synthetizers; if you want to use it with
|
||||
BRLTTY can also work with speech synthesizers; if you want to use it with
|
||||
Speech Dispatcher, please install also package %{name}-speech-dispatcher.
|
||||
|
||||
%package speech-dispatcher
|
||||
@ -74,7 +74,7 @@ This package provides the AtSpi driver for BRLTTY.
|
||||
Version: %{api_version}
|
||||
Group: Applications/System
|
||||
License: LGPLv2+
|
||||
Summary: Appliation Programming Interface for BRLTTY
|
||||
Summary: Application Programming Interface for BRLTTY
|
||||
Requires: %{name} = %{pkg_version}-%{release}
|
||||
%description -n brlapi
|
||||
This package provides the run-time support for the Application
|
||||
@ -97,7 +97,7 @@ Application Programming Interface to BRLTTY). It enables the
|
||||
implementation of applications which take direct advantage of a
|
||||
refreshable braille display in order to present information in ways
|
||||
which are more appropriate for blind users and/or to provide user
|
||||
interfaces which are more specifically atuned to their needs.
|
||||
interfaces which are more specifically attuned to their needs.
|
||||
|
||||
Install this package if you are developing or maintaining an application
|
||||
which directly accesses a refreshable braille display.
|
||||
@ -127,7 +127,7 @@ Version: %{api_version}
|
||||
Group: Development/System
|
||||
License: LGPLv2+
|
||||
Requires: brlapi = %{api_version}-%{release}
|
||||
## temporary work around, java-devel is not resolved consistently acrss archs
|
||||
## temporary work around, java-devel is not resolved consistently across archs
|
||||
BuildRequires: java-devel
|
||||
#BuildRequires: java-1.5.0-gcj-devel
|
||||
Summary: Java binding for BrlAPI
|
||||
@ -140,7 +140,7 @@ This package provides the Java binding for BrlAPI.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .cppflags
|
||||
%patch1 -p1 -b .quote
|
||||
%patch2 -p1 -b .S_ISCHR
|
||||
#%%patch2 -p1 -b .S_ISCHR
|
||||
%patch3 -p1 -b .parallel
|
||||
|
||||
%build
|
||||
@ -166,6 +166,19 @@ while read file; do
|
||||
mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
|
||||
done
|
||||
|
||||
find . -name '*.sgml' |
|
||||
while read file; do
|
||||
iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
|
||||
done
|
||||
find . -name '*.txt' |
|
||||
while read file; do
|
||||
iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
|
||||
done
|
||||
find . -name 'README*' |
|
||||
while read file; do
|
||||
iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
|
||||
done
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
# does not seem to be parallel safe
|
||||
@ -277,6 +290,12 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 18 2011 Jon Ciesla <limb@jcomserv.net> - 4.3-1
|
||||
- New upstream.
|
||||
- S_ISCHR patch upstreamed.
|
||||
- parallel patch updated.
|
||||
- Cleaned up some file encodings.
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user