- own the tcl subdirectory (#474032)
- set CPPFLAGS to java include dirs, so that the java bindings build with any java implementation (#498964) - add --without-curses; there is no curses package BuildRequired anyway
This commit is contained in:
parent
6c9a6db4d4
commit
f51fa9b93d
24
brltty-cppflags.patch
Normal file
24
brltty-cppflags.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
2009-05-06 Stepan Kasal <skasal@redhat.com>
|
||||||
|
|
||||||
|
* Bindings/Java/Makefile.in: Propagate configure-time CPPFLAGS.
|
||||||
|
|
||||||
|
--- brltty-3.10/Bindings/Java/Makefile.in.cppflags 2008-07-17 00:19:45.000000000 +0200
|
||||||
|
+++ brltty-3.10/Bindings/Java/Makefile.in 2009-05-06 17:33:02.000000000 +0200
|
||||||
|
@@ -36,6 +36,8 @@
|
||||||
|
JAVA_JNI_FLAGS = @JAVA_JNI_FLAGS@
|
||||||
|
JAVA_JNI_DESTDIR = $(INSTALL_ROOT)
|
||||||
|
|
||||||
|
+CPPFLAGS = @CPPFLAGS@
|
||||||
|
+
|
||||||
|
all: jar jni doc
|
||||||
|
|
||||||
|
JAVA_SOURCES = $(SRC_DIR)/Brlapi.java \
|
||||||
|
@@ -56,7 +58,7 @@
|
||||||
|
$(MKLIB:<name>=$(API_NAME)) $@ bindings.$O $(API_LDFLAGS)
|
||||||
|
|
||||||
|
bindings.$O:
|
||||||
|
- $(CC) $(LIBCFLAGS) $(JAVA_JNI_FLAGS) -o $@ -c $(SRC_DIR)/bindings.c
|
||||||
|
+ $(CC) $(CPPFLAGS) $(LIBCFLAGS) $(JAVA_JNI_FLAGS) -o $@ -c $(SRC_DIR)/bindings.c
|
||||||
|
|
||||||
|
JAVA_JAR_FILE = $(API_NAME).jar
|
||||||
|
jar: $(JAVA_JAR_FILE)
|
26
brltty.spec
26
brltty.spec
@ -9,13 +9,14 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
||||||
Patch2: brltty-gnusource.patch
|
Patch2: brltty-gnusource.patch
|
||||||
Patch3: brltty-3.9-autoconf.patch
|
Patch3: brltty-3.9-autoconf.patch
|
||||||
|
Patch4: brltty-cppflags.patch
|
||||||
Patch5: brltty-parallel.patch
|
Patch5: brltty-parallel.patch
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
@ -104,8 +105,9 @@ Version: %{api_version}
|
|||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi = %{api_version}-%{release}
|
||||||
|
## temporary work around, java-devel is not resolved consistently acrss archs
|
||||||
BuildRequires: java-devel
|
BuildRequires: java-devel
|
||||||
#BuildRequires: java-1.7.0-icedtea-devel
|
#BuildRequires: java-1.5.0-gcj-devel
|
||||||
Summary: Java binding for BrlAPI
|
Summary: Java binding for BrlAPI
|
||||||
%description -n brlapi-java
|
%description -n brlapi-java
|
||||||
This package provides the Java binding for BrlAPI.
|
This package provides the Java binding for BrlAPI.
|
||||||
@ -116,11 +118,20 @@ This package provides the Java binding for BrlAPI.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .gnusource
|
%patch2 -p1 -b .gnusource
|
||||||
%patch3 -p1 -b .autoconf
|
%patch3 -p1 -b .autoconf
|
||||||
|
%patch4 -p1 -b .cppflags
|
||||||
%patch5 -p1 -b .parallel
|
%patch5 -p1 -b .parallel
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen
|
./autogen
|
||||||
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
for i in -I/usr/lib/jvm/java/include{,/linux}; do
|
||||||
|
java_inc="$java_inc $i"
|
||||||
|
done
|
||||||
|
# there is no curses packages in BuildRequires, so the package builds
|
||||||
|
# without them in mock; let's express this decision explicitly
|
||||||
|
%configure CPPFLAGS="$java_inc" --without-curses \
|
||||||
|
--with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
||||||
|
cat config.log
|
||||||
|
#exit 1
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
for file in $(find . \( -path ./doc -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o -name \*.patch -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print)
|
for file in $(find . \( -path ./doc -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o -name \*.patch -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print)
|
||||||
@ -201,8 +212,7 @@ exit 0
|
|||||||
|
|
||||||
%files -n tcl-brlapi
|
%files -n tcl-brlapi
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{tcl_sitearch}/brlapi-%{api_version}/libbrlapi_tcl.so
|
%{tcl_sitearch}/brlapi-%{api_version}
|
||||||
%{tcl_sitearch}/brlapi-%{api_version}/pkgIndex.tcl
|
|
||||||
|
|
||||||
%files -n python-brlapi
|
%files -n python-brlapi
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -216,6 +226,12 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 30 2009 Stepan Kasal <skasal@redhat.com> - 3.10-4
|
||||||
|
- own the tcl subdirectory (#474032)
|
||||||
|
- set CPPFLAGS to java include dirs, so that the java bindings build with
|
||||||
|
any java implementation (#498964)
|
||||||
|
- add --without-curses; there is no curses package BuildRequired anyway
|
||||||
|
|
||||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user