sync with devel
This commit is contained in:
parent
46757b8ee8
commit
ef909a2ab2
@ -1 +1 @@
|
||||
brltty-4.0.tar.gz
|
||||
brltty-4.1.tar.gz
|
||||
|
17
brltty-autoconf-quote.patch
Normal file
17
brltty-autoconf-quote.patch
Normal file
@ -0,0 +1,17 @@
|
||||
2009-10-28 Stepan Kasal <skasal@redhat.com>
|
||||
|
||||
* aclocal.m4 (BRLTTY_SUMMARY_END): Use single quotes when
|
||||
passing the value of brltty_summary_lines, so that is not
|
||||
garbled.
|
||||
|
||||
--- brltty-4.1/aclocal.m4.orig 2009-10-08 04:32:49.000000000 +0200
|
||||
+++ brltty-4.1/aclocal.m4 2009-10-28 14:28:30.000000000 +0100
|
||||
@@ -396,7 +396,7 @@
|
||||
AC_DEFUN([BRLTTY_SUMMARY_END], [dnl
|
||||
AC_CONFIG_COMMANDS([brltty-summary],
|
||||
[AC_MSG_NOTICE([${brltty_summary_lines}])],
|
||||
- [brltty_summary_lines="${brltty_summary_lines}"]
|
||||
+ [brltty_summary_lines='${brltty_summary_lines}']
|
||||
)])
|
||||
|
||||
AC_DEFUN([BRLTTY_SUMMARY_ITEM], [dnl
|
62
brltty.spec
62
brltty.spec
@ -1,5 +1,5 @@
|
||||
%define pkg_version 4.0
|
||||
%define api_version 0.5.3
|
||||
%define pkg_version 4.1
|
||||
%define api_version 0.5.4
|
||||
|
||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
||||
@ -9,42 +9,44 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://mielke.cc/brltty/
|
||||
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
||||
Patch4: brltty-cppflags.patch
|
||||
Patch5: brltty-parallel.patch
|
||||
Patch6: brltty-autoconf-quote.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
BuildRequires: byacc, glibc-kernheaders
|
||||
# BuildRequires: ocaml
|
||||
BuildRequires: byacc glibc-kernheaders
|
||||
BuildRequires: autoconf
|
||||
Requires: brlapi = %{api_version}-%{release}
|
||||
|
||||
%description
|
||||
BRLTTY is a background process (daemon) which provides
|
||||
access to the Linux/Unix console (when in text mode)
|
||||
for a blind person using a refreshable braille display.
|
||||
It drives the braille display,
|
||||
and provides complete screen review functionality.
|
||||
It drives the braille display and provides complete
|
||||
screen review functionality.
|
||||
Some speech capability has also been incorporated.
|
||||
|
||||
%package xw
|
||||
Requires: %{name}
|
||||
Summary: XWindow driver for BRLTTY
|
||||
Group: System Environment/Daemons
|
||||
License: GPLv2+
|
||||
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
|
||||
Requires: %{name} = %{pkg_version}-%{release}
|
||||
%description xw
|
||||
This package provides the XWindow driver for BRLTTY.
|
||||
|
||||
%package at-spi
|
||||
Requires: %{name}
|
||||
Summary: AtSpi driver for BRLTTY
|
||||
Group: System Environment/Daemons
|
||||
# The data files are licensed under LGPLv2+, see the README file.
|
||||
License: GPLv2+ and LGPLv2+
|
||||
BuildRequires: at-spi-devel
|
||||
Requires: %{name} = %{pkg_version}-%{release}
|
||||
%description at-spi
|
||||
This package provides the AtSpi driver for BRLTTY.
|
||||
|
||||
@ -117,31 +119,41 @@ This package provides the Java binding for BrlAPI.
|
||||
%setup -q
|
||||
%patch4 -p1 -b .cppflags
|
||||
%patch5 -p1 -b .parallel
|
||||
%patch6 -p1 -b .quote
|
||||
|
||||
%build
|
||||
# Patch6 changes aclocal.m4:
|
||||
autoconf
|
||||
for i in -I/usr/lib/jvm/java/include{,/linux}; do
|
||||
java_inc="$java_inc $i"
|
||||
done
|
||||
# there is no curses packages in BuildRequires, so the package builds
|
||||
# without them in mock; let's express this decision explicitly
|
||||
%configure CPPFLAGS="$java_inc" --without-curses \
|
||||
%configure CPPFLAGS="$java_inc" --disable-stripping --without-curses \
|
||||
--with-data-directory='${datadir}/${PACKAGE_NAME}' \
|
||||
--with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
||||
make %{?_smp_mflags}
|
||||
|
||||
for file in $(find . \( -path ./doc -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o -name \*.patch -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print)
|
||||
do
|
||||
mkdir -p "doc/${file%/*}"
|
||||
cp -rp "${file}" "doc/${file}"
|
||||
find . \( -path ./doc -o -path ./Documents \) -prune -o \
|
||||
\( -name 'README*' -o -name '*.txt' -o -name '*.html' -o \
|
||||
-name '*.sgml' -o -name '*.patch' -o \
|
||||
\( -path './Bootdisks/*' -type f -perm +ugo=x \) \) -print |
|
||||
while read file; do
|
||||
mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
|
||||
done
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make INSTALL_PROGRAM='$(INSTALL_SCRIPT)' install #install-programs install-help install-tables install-drivers install-manpage
|
||||
make %{?_smp_mflags} install
|
||||
mv "$RPM_BUILD_ROOT%{_datadir}/brltty/brltty-pm.conf" \
|
||||
doc/Drivers/Braille/Papenmeier/
|
||||
install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5"
|
||||
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
||||
echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
|
||||
|
||||
# clean up the manuals:
|
||||
rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
|
||||
|
||||
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | \
|
||||
grep -v 'libbrlttybxw.so\|libbrlttyxas.so' | \
|
||||
sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
|
||||
@ -172,7 +184,7 @@ exit 0
|
||||
|
||||
%files -f libs.filelist
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) /etc/brltty.conf
|
||||
%config(noreplace) %{_sysconfdir}/brltty.conf
|
||||
%{_bindir}/brltty
|
||||
%{_bindir}/brltty-*
|
||||
%{_bindir}/vstp
|
||||
@ -180,8 +192,7 @@ exit 0
|
||||
%{_datadir}/brltty
|
||||
%doc LICENSE-GPL LICENSE-LGPL
|
||||
%doc Documents/ChangeLog Documents/TODO
|
||||
%doc Documents/Manual-BRLTTY
|
||||
%doc Bootdisks/rhmkboot Bootdisks/rhmkroot
|
||||
%doc Documents/Manual-BRLTTY/
|
||||
%doc doc/*
|
||||
%doc %{_mandir}/man[15]/brltty.*
|
||||
%doc %{_mandir}/man1/vstp.*
|
||||
@ -196,8 +207,7 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/xbrlapi
|
||||
%{_libdir}/libbrlapi.so.*
|
||||
%doc Documents/Manual-BrlAPI/English/BrlAPI.sgml Documents/Manual-BrlAPI/English/BrlAPI.txt
|
||||
%doc Documents/Manual-BrlAPI/English/BrlAPI*.html
|
||||
%doc Documents/Manual-BrlAPI/
|
||||
%doc Documents/README.Seika
|
||||
%doc %{_mandir}/man1/xbrlapi.*
|
||||
|
||||
@ -226,13 +236,23 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 28 2009 Stepan Kasal <skasal@redhat.com> - 4.1-1
|
||||
- new upstream version
|
||||
- use --disable-stripping instead of make variable override
|
||||
- install the default brltty-pm.conf to docdir only (#526168)
|
||||
- remove the duplicate copies of rhmkboot and rhmkroot from docdir
|
||||
- patch configure so that the dirs in summary are not garbled:
|
||||
brltty-autoconf-quote.patch
|
||||
|
||||
* Tue Oct 20 2009 Stepan Kasal <skasal@redhat.com> - 4.0-2
|
||||
- escape rpm macros in the rpm change log
|
||||
- add requires to bind subpackages from one build together
|
||||
|
||||
* Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
|
||||
- new upstream version
|
||||
- drop upstreamed patches; ./autogen nut needed anymore
|
||||
- drop upstreamed patches; ./autogen not needed anymore
|
||||
- pack the xbrlapi server; move its man page to brlapi package
|
||||
- add man-page for brltty.conf (#526168)
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user