rework parallel patch and reapply
This commit is contained in:
parent
1015788bf6
commit
e2eb4d12d5
@ -5,14 +5,14 @@
|
|||||||
"make brlapi" when parallel make is used. Recursive make is
|
"make brlapi" when parallel make is used. Recursive make is
|
||||||
harmful.
|
harmful.
|
||||||
|
|
||||||
--- brltty-4.0/Programs/Makefile.in.parallel 2009-10-07 20:48:57.000000000 +0200
|
--- brltty-4.2/Programs/Makefile.in.BAD 2010-05-21 16:27:45.231183660 -0400
|
||||||
+++ brltty-4.0/Programs/Makefile.in 2009-10-07 20:50:03.000000000 +0200
|
+++ brltty-4.2/Programs/Makefile.in 2010-05-21 16:27:51.437122063 -0400
|
||||||
@@ -428,7 +428,7 @@
|
@@ -484,7 +484,7 @@ apitest.$O:
|
||||||
|
|
||||||
###############################################################################
|
###############################################################################
|
||||||
|
|
||||||
-braille-drivers: txt2hlp$X
|
-braille-drivers:
|
||||||
+braille-drivers: txt2hlp$X api
|
+braille-drivers: api
|
||||||
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
||||||
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
||||||
done
|
done
|
||||||
|
@ -15,7 +15,7 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
@ -23,6 +23,7 @@ Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
|||||||
Patch0: brltty-cppflags.patch
|
Patch0: brltty-cppflags.patch
|
||||||
Patch1: brltty-autoconf-quote.patch
|
Patch1: brltty-autoconf-quote.patch
|
||||||
Patch2: brltty-4.2-S_ISCHR.patch
|
Patch2: brltty-4.2-S_ISCHR.patch
|
||||||
|
Patch3: brltty-parallel.patch
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
BuildRequires: byacc glibc-kernheaders
|
BuildRequires: byacc glibc-kernheaders
|
||||||
@ -140,6 +141,7 @@ This package provides the Java binding for BrlAPI.
|
|||||||
%patch0 -p1 -b .cppflags
|
%patch0 -p1 -b .cppflags
|
||||||
%patch1 -p1 -b .quote
|
%patch1 -p1 -b .quote
|
||||||
%patch2 -p1 -b .S_ISCHR
|
%patch2 -p1 -b .S_ISCHR
|
||||||
|
%patch3 -p1 -b .parallel
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Patch6 changes aclocal.m4:
|
# Patch6 changes aclocal.m4:
|
||||||
@ -275,6 +277,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-2
|
||||||
|
- rework parallel patch slightly and reapply
|
||||||
|
|
||||||
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
|
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
|
||||||
- update to 4.2
|
- update to 4.2
|
||||||
- drop static lib (bz 556041)
|
- drop static lib (bz 556041)
|
||||||
|
Loading…
Reference in New Issue
Block a user