- update to latest upstream

- added the at-spi driver, tcl and python bindings
- fixed the license tags
This commit is contained in:
Tomas Janousek 2007-08-22 10:47:29 +00:00
parent b3f626f736
commit e2b1266c65
9 changed files with 220 additions and 67 deletions

View File

@ -1 +1 @@
brltty-3.7.2.tar.gz
brltty-3.8.tar.gz

View File

@ -1,11 +0,0 @@
--- brltty-3.7.2/config.mk.in.debuginfo 2005-12-26 13:58:07.000000000 +0100
+++ brltty-3.7.2/config.mk.in 2007-01-30 12:39:10.000000000 +0100
@@ -89,7 +89,7 @@
INSTALL = @INSTALL@
INSTALL_SCRIPT = $(INSTALL)
-INSTALL_PROGRAM = $(INSTALL_SCRIPT) -s
+INSTALL_PROGRAM = $(INSTALL_SCRIPT)
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_DIRECTORY = $(INSTALL) -d

View File

@ -1,11 +0,0 @@
--- brltty-3.7.2/Programs/usb_linux.c.linux-compiler-h 2006-07-12 13:27:57.000000000 +0200
+++ brltty-3.7.2/Programs/usb_linux.c 2006-07-12 13:27:28.000000000 +0200
@@ -30,7 +30,7 @@
#include <sys/stat.h>
#include <sys/vfs.h>
#include <sys/ioctl.h>
-#include <linux/compiler.h>
+// #include <linux/compiler.h>
#include <linux/usbdevice_fs.h>
#ifndef USBDEVFS_DISCONNECT

View File

@ -1,11 +0,0 @@
--- brltty-3.7.2/Programs/api_client.c.vt-buildfix 2005-12-26 13:57:11.000000000 +0100
+++ brltty-3.7.2/Programs/api_client.c 2007-01-25 11:54:44.000000000 +0100
@@ -74,7 +74,7 @@
#ifdef linux
#include <linux/major.h>
-#include <linux/tty.h>
+#include <linux/vt.h>
#define MAXIMUM_VIRTUAL_CONSOLE MAX_NR_CONSOLES
#endif /* linux */

View File

@ -1,11 +0,0 @@
--- brltty-3.7.2/BrailleDrivers/Papenmeier/config.y.yacc-buildfix 2005-12-26 13:57:44.000000000 +0100
+++ brltty-3.7.2/BrailleDrivers/Papenmeier/config.y 2007-03-05 15:31:27.000000000 +0100
@@ -41,7 +41,7 @@
#define YYERROR_VERBOSE
static int yylex(void);
static int yyerror(char*);
-static int yyparse();
+/*static*/ int yyparse();
/* to be called: */
static int parse (void);

16
brltty-3.8-lib64.patch Normal file
View File

@ -0,0 +1,16 @@
Fix the Tcl binding install script -- did not install to /usr/lib64.
Signed-off-by: Tomas Janousek <tjanouse@redhat.com>
---
--- brltty-3.8/Bindings/Tcl/pkgutil.lib64 2007-06-04 15:20:32.000000000 +0200
+++ brltty-3.8/Bindings/Tcl/pkgutil 2007-08-21 15:08:46.000000000 +0200
@@ -31,7 +31,7 @@
}
set directory [eval file join / [lrange $components $rootCount end]]
- if {[string equal [file tail $directory] lib]} {
+ if {[string equal [file tail $directory] lib] || [string equal [file tail $directory] lib64]} {
global optionValues packageName packageVersion
return [file join "$optionValues(root)$directory" "$packageName-$packageVersion"]
}

126
brltty-3.8-openmacro.patch Normal file
View File

@ -0,0 +1,126 @@
Fix the calls to whatever->open to compile with newer glibc.
The glibc upstream has recently defined open as macro to check for incorrect
usage of the third parameter. This is correct, the POSIX standard says that it
may be declared in such a way. The attached patch redefines all those
> whatever->open(...)
calls to
> (whatever->open)(...)
. I also replaced the close calls, since close may be declared as macro too.
Signed-off-by: Tomas Janousek <tjanouse@redhat.com>
---
--- brltty-3.8/Programs/config.c.openmacro 2007-08-21 14:25:42.000000000 +0200
+++ brltty-3.8/Programs/config.c 2007-08-21 14:28:07.000000000 +0200
@@ -1383,13 +1383,13 @@
openBrailleDriver (void) {
initializeBraille();
- if (braille->open(&brl, brailleParameters, brailleDevice)) {
+ if ((braille->open)(&brl, brailleParameters, brailleDevice)) {
if (allocateBrailleBuffer(&brl)) {
brailleOpened = 1;
return 1;
}
- braille->close(&brl);
+ (braille->close)(&brl);
} else {
LogPrint(LOG_DEBUG, "%s: %s -> %s",
gettext("braille driver initialization failed"),
@@ -1403,7 +1403,7 @@
closeBrailleDriver (void) {
brailleOpened = 0;
drainBrailleOutput(&brl, 0);
- braille->close(&brl);
+ (braille->close)(&brl);
if (brl.isCoreBuffer) {
free(brl.buffer);
@@ -1657,7 +1657,7 @@
openSpeechDriver (void) {
initializeSpeech();
- if (speech->open(speechParameters)) {
+ if ((speech->open)(speechParameters)) {
return 1;
} else {
LogPrint(LOG_DEBUG, "speech driver initialization failed: %s",
@@ -1669,7 +1669,7 @@
void
closeSpeechDriver (void) {
- speech->close();
+ (speech->close)();
}
static int
--- brltty-3.8/Programs/tunes.c.openmacro 2007-08-21 14:25:42.000000000 +0200
+++ brltty-3.8/Programs/tunes.c 2007-08-21 14:28:54.000000000 +0200
@@ -480,7 +480,7 @@
}
if (!generator) return 0;
- if (noteGenerator) noteGenerator->close();
+ if (noteGenerator) (noteGenerator->close)();
closeTimer = 0;
noteGenerator = generator;
return 1;
@@ -490,7 +490,7 @@
closeTuneDevice (int force) {
if (closeTimer) {
if (force) closeTimer = 1;
- if (!--closeTimer) noteGenerator->close();
+ if (!--closeTimer) (noteGenerator->close)();
}
}
@@ -499,7 +499,7 @@
int tunePlayed = 0;
if (prefs.alertTunes && tune->elements) {
if (noteGenerator) {
- if (noteGenerator->open(openErrorLevel)) {
+ if ((noteGenerator->open)(openErrorLevel)) {
TuneElement *element = tune->elements;
tunePlayed = 1;
closeTimer = 2000 / updateInterval;
--- brltty-3.8/Programs/brltest.c.openmacro 2007-08-21 14:25:42.000000000 +0200
+++ brltty-3.8/Programs/brltest.c 2007-08-21 14:27:31.000000000 +0200
@@ -161,14 +161,14 @@
initializeBrailleDisplay(&brl);
brl.dataDirectory = opt_dataDirectory;
identifyBrailleDriver(braille, 0); /* start-up messages */
- if (braille->open(&brl, parameterSettings, opt_brailleDevice)) {
+ if ((braille->open)(&brl, parameterSettings, opt_brailleDevice)) {
if (allocateBrailleBuffer(&brl)) {
#ifdef ENABLE_LEARN_MODE
learnMode(&brl, updateInterval, 10000);
#else /* ENABLE_LEARN_MODE */
message("braille test", 0);
#endif /* ENABLE_LEARN_MODE */
- braille->close(&brl); /* finish with the display */
+ (braille->close)(&brl); /* finish with the display */
status = 0;
} else {
LogPrint(LOG_ERR, "can't allocate braille buffer.");
--- brltty-3.8/Programs/spktest.c.openmacro 2007-08-21 14:25:42.000000000 +0200
+++ brltty-3.8/Programs/spktest.c 2007-08-21 14:28:27.000000000 +0200
@@ -163,7 +163,7 @@
if (chdir(opt_dataDirectory) != -1) {
identifySpeechDriver(speech, 0); /* start-up messages */
- if (speech->open(parameterSettings)) {
+ if ((speech->open)(parameterSettings)) {
if (speech->rate) speech->rate(speechRate);
if (speech->volume) speech->volume(speechVolume);
@@ -172,7 +172,7 @@
} else {
processLines(stdin, sayLine, NULL);
}
- speech->close(); /* finish with the display */
+ (speech->close)(); /* finish with the display */
status = 0;
} else {
LogPrint(LOG_ERR, "can't initialize speech driver.");

View File

@ -1,18 +1,22 @@
%define pkg_version 3.8
%define api_version 0.5.0
%define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
Name: brltty
Version: 3.7.2
Release: 3%{?dist}
License: GPL
Version: %{pkg_version}
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Daemons
URL: http://mielke.cc/brltty/
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
Patch0: brltty-3.7.2-linux-compiler-h.patch
Patch1: brltty-3.7.2-vt-buildfix.patch
Patch2: brltty-3.7.2-debuginfo.patch
Patch3: brltty-3.7.2-yacc-buildfix.patch
Patch0: brltty-3.8-openmacro.patch
Patch1: brltty-3.8-lib64.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-InstallRoot
Summary: Braille display driver for Linux/Unix.
Requires(post): coreutils
BuildRequires: byacc, glibc-kernheaders
# BuildRequires: java-devel, ocaml
%description
BRLTTY is a background process (daemon) which provides
@ -26,14 +30,24 @@ Some speech capability has also been incorporated.
Requires: %{name}
Summary: XWindow driver for BRLTTY.
Group: System Environment/Daemons
License: GPLv2+
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
%description xw
This package provides the XWindow driver for BRLTTY.
%package at-spi
Requires: %{name}
Summary: AtSpi driver for BRLTTY.
Group: System Environment/Daemons
License: GPLv2+
BuildRequires: at-spi-devel
%description at-spi
This package provides the AtSpi driver for BRLTTY.
%package -n brlapi
Version: 0.4.1
Version: %{api_version}
Group: Applications/System
License: LGPL
License: LGPLv2+
Summary: Appliation Programming Interface for BRLTTY.
%description -n brlapi
This package provides the run-time support for the Application
@ -43,10 +57,10 @@ Install this package if you have an application which directly accesses
a refreshable braille display.
%package -n brlapi-devel
Version: 0.4.1
Version: %{api_version}
Group: Development/System
License: LGPL
Requires: brlapi = 0.4.1
License: LGPLv2+
Requires: brlapi = %{api_version}
Summary: Headers, static archive, and documentation for BrlAPI.
%description -n brlapi-devel
@ -61,12 +75,32 @@ interfaces which are more specifically atuned to their needs.
Install this package if you are developing or maintaining an application
which directly accesses a refreshable braille display.
%package -n tcl-brlapi
Version: %{api_version}
Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}
BuildRequires: tcl-devel
Summary: Tcl binding for BrlAPI.
%description -n tcl-brlapi
This package provides the Tcl binding for BrlAPI.
%package -n python-brlapi
Version: %{api_version}
Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}
BuildRequires: Pyrex
Summary: Python binding for BrlAPI.
%description -n python-brlapi
This package provides the Python binding for BrlAPI.
%define version %{pkg_version}
%prep
%setup -n brltty-3.7.2
%patch0 -p1 -b .linux-compiler-h
%patch1 -p1 -b .vt-buildfix
%patch2 -p1 -b .debuginfo
%patch3 -p1 -b .yacc-buildfix
%setup
%patch0 -p1 -b .openmacro
%patch1 -p1 -b .lib64
%build
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
@ -79,11 +113,12 @@ do
done
%install
make install #install-programs install-help install-tables install-drivers install-manpage
make INSTALL_PROGRAM='$(INSTALL_SCRIPT)' install #install-programs install-help install-tables install-drivers install-manpage
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
rm -f ${RPM_BUILD_ROOT}/usr/bin/xbrlapi # whatever this is, we exclude it for now
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | grep -v 'libbrlttybxw.so' | \
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | \
grep -v 'libbrlttybxw.so\|libbrlttyxas.so' | \
sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
%clean
@ -115,6 +150,7 @@ exit 0
%config(noreplace) /etc/brltty.conf
%{_bindir}/brltty
%{_bindir}/brltty-*
%{_bindir}/vstp
%dir %{_libdir}/brltty
/etc/brltty
%doc COPYING
@ -126,10 +162,14 @@ exit 0
%files xw
%{_libdir}/brltty/libbrlttybxw.so
%files at-spi
%{_libdir}/brltty/libbrlttyxas.so
%files -n brlapi
%defattr(-,root,root)
%{_libdir}/libbrlapi.so.*
%doc Documents/BrlAPI.sgml Documents/BrlAPI.txt Documents/BrlAPI-HTML
%doc Documents/Manual-BrlAPI/English/BrlAPI.sgml Documents/Manual-BrlAPI/English/BrlAPI.txt
%doc Documents/Manual-BrlAPI/English/BrlAPI*.html
%doc Documents/README.Gnopernicus
%files -n brlapi-devel
@ -137,11 +177,26 @@ exit 0
%{_libdir}/libbrlapi.a
%{_libdir}/libbrlapi.so
%{_includedir}/brltty
%{_includedir}/brlapi*.h
%doc %{_mandir}/man3/*
%doc Documents/BrlAPIref-HTML
%doc Documents/BrlAPIref/html
%files -n tcl-brlapi
%defattr(-,root,root)
%{_libdir}/brlapi-%{api_version}/libbrlapi_tcl.so
%{_libdir}/brlapi-%{api_version}/pkgIndex.tcl
%files -n python-brlapi
%defattr(-,root,root)
%{python_sitearch}/brlapi.so
%changelog
* Tue Aug 21 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-1
- update to latest upstream
- added the at-spi driver, tcl and python bindings
- fixed the license tags
* Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
- added the XWindow driver
- build fix for newer byacc

View File

@ -1 +1 @@
0ae3da8252783a4d20e1ed4e55cede5b brltty-3.7.2.tar.gz
542fa50d1433aa77e151432cc6abeebc brltty-3.8.tar.gz