Improved CFLAGS handling when building Ocaml bindings

This commit is contained in:
Jaroslav Škarvada 2018-12-05 21:51:13 +01:00
parent 281f6b7568
commit cf9159da50
2 changed files with 7 additions and 3 deletions

View File

@ -1,5 +1,5 @@
diff --git a/Bindings/OCaml/Makefile.in b/Bindings/OCaml/Makefile.in
index 47f7201..7d56ef1 100644
index 47f7201..a97f55c 100644
--- a/Bindings/OCaml/Makefile.in
+++ b/Bindings/OCaml/Makefile.in
@@ -55,25 +55,25 @@ OCAML_FILES = $(OCAML_MISC) $(OCAML_CLIBS) $(OCAML_BCLIB) $(OCAML_NCLIB)
@ -26,7 +26,8 @@ index 47f7201..7d56ef1 100644
+ $(OCAMLC) -ccopt "$(CFLAGS)" -o $@ -c brlapi.ml
brlapi.cmx: brlapi.ml brlapi.cmi
$(OCAMLOPT) -o $@ -c brlapi.cmx brlapi.ml
- $(OCAMLOPT) -o $@ -c brlapi.cmx brlapi.ml
+ $(OCAMLOPT) -ccopt "$(CFLAGS)" -o $@ -c brlapi.cmx brlapi.ml
brlapi_stubs.$O: $(SRC_DIR)/brlapi_stubs.c
- $(OCAMLC) -I $(BLD_TOP)$(PGM_DIR) -I $(SRC_TOP)$(PGM_DIR) -c $(SRC_DIR)/brlapi_stubs.c

View File

@ -33,7 +33,7 @@
Name: brltty
Version: %{pkg_version}
Release: 28%{?dist}
Release: 29%{?dist}
License: LGPLv2+
URL: http://brltty.app/
Source0: http://brltty.app/archive/%{name}-%{version}.tar.xz
@ -534,6 +534,9 @@ fi
%{_prefix}/lib/dracut/modules.d/99brltty/
%changelog
* Wed Dec 5 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 5.6-29
- Improved CFLAGS handling when building Ocaml bindings
* Wed Dec 5 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 5.6-28
- Built OCaml bindings with distribution CFLAGS and consolidated patches
- Fixed Cython build requires