New version
Resolves: rhbz#1910328
This commit is contained in:
parent
66fe0b96e8
commit
b952485c37
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ brltty-4.2.tar.gz
|
||||
/brltty-5.6.tar.xz
|
||||
/brltty-6.0.tar.xz
|
||||
/brltty-6.1.tar.xz
|
||||
/brltty-6.3.tar.xz
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff --git a/Documents/brltty.1.in b/Documents/brltty.1.in
|
||||
index 49c392c..59f21bc 100644
|
||||
--- a/Documents/brltty.1.in
|
||||
+++ b/Documents/brltty.1.in
|
||||
@@ -218,6 +218,9 @@ the first available MIDI output port
|
||||
\fB\-n\fR (\fB\-\-no\-daemon\fR)
|
||||
Remain in the foreground (useful for debugging).
|
||||
.TP
|
||||
+\fB\-o \fIname\fB=\fIvalue\fB,\fR... (\fB\-\-override\-preference=\fR)
|
||||
+Explicit preference settings.
|
||||
+.TP
|
||||
\fB\-p \fIdevice\fR (\fB\-\-pcm\-device=\fR)
|
||||
The device to use for digital audio.
|
||||
For ALSA it's \fIname\fR[\fB:\fIargument\fB,\fR...].
|
@ -1,8 +1,8 @@
|
||||
diff --git a/Drivers/Speech/SpeechDispatcher/speech.c b/Drivers/Speech/SpeechDispatcher/speech.c
|
||||
index d73250a..df92708 100644
|
||||
index cc55007..a2fcc0d 100644
|
||||
--- a/Drivers/Speech/SpeechDispatcher/speech.c
|
||||
+++ b/Drivers/Speech/SpeechDispatcher/speech.c
|
||||
@@ -34,7 +34,7 @@ typedef enum {
|
||||
@@ -35,7 +35,7 @@ typedef enum {
|
||||
|
||||
#include "spk_driver.h"
|
||||
|
@ -1,9 +1,9 @@
|
||||
diff --git a/Bindings/Java/NativeLibrary.java b/Bindings/Java/NativeLibrary.java
|
||||
index 5780e34..8383821 100644
|
||||
--- a/Bindings/Java/NativeLibrary.java
|
||||
+++ b/Bindings/Java/NativeLibrary.java
|
||||
@@ -26,7 +26,15 @@ public class NativeLibrary {
|
||||
}
|
||||
diff --git a/Bindings/Java/NativeComponent.java b/Bindings/Java/NativeComponent.java
|
||||
index 2e6304a..cf6c9b0 100644
|
||||
--- a/Bindings/Java/NativeComponent.java
|
||||
+++ b/Bindings/Java/NativeComponent.java
|
||||
@@ -23,7 +23,15 @@ public class NativeComponent extends Component {
|
||||
private native static void initializeNativeData ();
|
||||
|
||||
static {
|
||||
- System.loadLibrary("brlapi_java");
|
||||
@ -16,6 +16,6 @@ index 5780e34..8383821 100644
|
||||
+ throw new UnsatisfiedLinkError("brlapi_java library load failed");
|
||||
+ }
|
||||
+ }
|
||||
new NativeLibrary().initializeNativeData();
|
||||
initializeNativeData();
|
||||
}
|
||||
}
|
||||
|
60
brltty.spec
60
brltty.spec
@ -1,5 +1,5 @@
|
||||
%define pkg_version 6.1
|
||||
%define api_version 0.8.0
|
||||
%define pkg_version 6.3
|
||||
%define api_version 0.8.2
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
# disable python3 by default
|
||||
@ -33,17 +33,14 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 13%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://brltty.app/
|
||||
Source0: http://brltty.app/archive/%{name}-%{version}.tar.xz
|
||||
Source1: brltty.service
|
||||
Patch1: brltty-6.0-loadLibrary.patch
|
||||
Patch1: brltty-6.3-loadLibrary.patch
|
||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||
Patch2: brltty-5.0-libspeechd.patch
|
||||
# rhbz#1612569
|
||||
# patch sent upstream
|
||||
Patch3: brltty-6.1-man-options.patch
|
||||
Patch2: brltty-6.3-libspeechd.patch
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||
BuildRequires: gettext, at-spi2-core-devel, alsa-lib-devel
|
||||
@ -51,8 +48,17 @@ BuildRequires: gettext, at-spi2-core-devel, alsa-lib-devel
|
||||
BuildRequires: espeak-devel
|
||||
%endif
|
||||
BuildRequires: espeak-ng-devel
|
||||
BuildRequires: /usr/bin/2to3
|
||||
BuildRequires: autoconf automake
|
||||
BuildRequires: autoconf, automake
|
||||
BuildRequires: polkit-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: linuxdoc-tools
|
||||
%if %{with python2}
|
||||
BuildRequires: python2-docutils
|
||||
%endif
|
||||
%if %{with python3}
|
||||
BuildRequires: python3-docutils
|
||||
%endif
|
||||
|
||||
# work around a bug in the install process:
|
||||
Requires(post): coreutils
|
||||
@ -232,7 +238,6 @@ mv %{name}-%{version} python2
|
||||
pushd python2
|
||||
%patch1 -p1 -b .loadLibrary
|
||||
%patch2 -p1 -b .libspeechd
|
||||
%patch3 -p1 -b .man-options
|
||||
|
||||
# remove packaged binary file
|
||||
rm -f Programs/brltty-ktb
|
||||
@ -268,7 +273,7 @@ configure_opts=" \
|
||||
%if ! %{with_espeak}
|
||||
--without-espeak \
|
||||
%endif
|
||||
--with-install-root=$RPM_BUILD_ROOT
|
||||
--with-install-root=$RPM_BUILD_ROOT \
|
||||
JAVA_JAR_DIR=%{_jnidir} \
|
||||
JAVA_JNI_DIR=%{_libdir}/brltty \
|
||||
JAVA_JNI=yes"
|
||||
@ -284,6 +289,12 @@ pushd python2
|
||||
%configure $configure_opts PYTHON=%{__python2}
|
||||
# Parallel build seems broken, thus disabling it
|
||||
make
|
||||
|
||||
# documents
|
||||
pushd Documents
|
||||
make
|
||||
popd
|
||||
|
||||
popd
|
||||
PYTHONS="$PYTHONS python2"
|
||||
%endif
|
||||
@ -294,11 +305,16 @@ pushd python3
|
||||
./autogen
|
||||
%configure $configure_opts PYTHON=%{__python3} CYTHON=%{_bindir}/cython
|
||||
make
|
||||
|
||||
# documents
|
||||
pushd Documents
|
||||
make
|
||||
popd
|
||||
|
||||
popd
|
||||
PYTHONS="$PYTHONS python3"
|
||||
%endif
|
||||
|
||||
|
||||
for python in $PYTHONS
|
||||
do pushd $python
|
||||
find . -name '*.sgml' |
|
||||
@ -354,6 +370,11 @@ pushd python3
|
||||
pushd python2
|
||||
%endif
|
||||
|
||||
# install polkit rules
|
||||
pushd Authorization/Polkit
|
||||
make install
|
||||
popd
|
||||
|
||||
install -d -m 755 "${RPM_BUILD_ROOT}%{_sysconfdir}" "$RPM_BUILD_ROOT%{_mandir}/man5"
|
||||
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
||||
echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
|
||||
@ -388,16 +409,12 @@ chmod 0640 ${RPM_BUILD_ROOT}%{_sysconfdir}/brlapi.key
|
||||
rm -f ${RPM_BUILD_ROOT}%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
|
||||
|
||||
# make brltty-config executable
|
||||
chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/brltty-config
|
||||
chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/brltty-config.sh
|
||||
|
||||
# handle locales
|
||||
%find_lang %{name}
|
||||
cp -p %{name}.lang ../
|
||||
|
||||
#Use python 3 for latex-access, BZ 1465657.
|
||||
/usr/bin/2to3 -wn ${RPM_BUILD_ROOT}/etc/brltty/Contraction/latex-access.ctb
|
||||
sed -i 's|/usr/bin/python|%{__python3}|g' ${RPM_BUILD_ROOT}/etc/brltty/Contraction/latex-access.ctb
|
||||
|
||||
# install dracut module
|
||||
make install-dracut
|
||||
|
||||
@ -449,8 +466,8 @@ fi
|
||||
%license LICENSE-LGPL
|
||||
%doc %{_mandir}/man[15]/brltty.*
|
||||
%{_sysconfdir}/X11/Xsession.d/90xbrlapi
|
||||
#%%{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
|
||||
%{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
|
||||
%{_datadir}/polkit-1/rules.d/org.a11y.brlapi.rules
|
||||
|
||||
|
||||
%if %{with_speech_dispatcher}
|
||||
@ -496,6 +513,7 @@ fi
|
||||
%{_libdir}/libbrlapi.so
|
||||
%{_includedir}/brltty
|
||||
%{_includedir}/brlapi*.h
|
||||
%{_libdir}/pkgconfig/brltty.pc
|
||||
%doc %{_mandir}/man3/brlapi_*.3*
|
||||
%doc Documents/BrlAPIref/BrlAPIref/
|
||||
|
||||
@ -531,6 +549,10 @@ fi
|
||||
%config(noreplace) %verify(not size md5 mtime) %{_sysconfdir}/brltty/Initramfs/cmdline
|
||||
|
||||
%changelog
|
||||
* Mon Feb 1 2021 Jaroslav Škarvada <jskarvad@redhat.com> - 6.3-1
|
||||
- New version
|
||||
Resolves: rhbz#1910328
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (brltty-6.1.tar.xz) = 030ef60ef7a9a60dc2fba2a64ea0a0868395eee6f2f86876b4e4111e804a05b44f798a154a69a8f5e0f6358130993c360a550f7decac0535450f9cf939231eaf
|
||||
SHA512 (brltty-6.3.tar.xz) = 8a15ffcc433f97925252d2355841e50a55179072d4cf294488fe52038b5e053ba688b7745716c49f4a20e0a626ecaf4ecd3ae7ca79527747c84c6e8a4d8d84a1
|
||||
|
Loading…
Reference in New Issue
Block a user