- added the XWindow driver
- build fix for newer byacc
This commit is contained in:
parent
68de005457
commit
b3f626f736
11
brltty-3.7.2-yacc-buildfix.patch
Normal file
11
brltty-3.7.2-yacc-buildfix.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- brltty-3.7.2/BrailleDrivers/Papenmeier/config.y.yacc-buildfix 2005-12-26 13:57:44.000000000 +0100
|
||||||
|
+++ brltty-3.7.2/BrailleDrivers/Papenmeier/config.y 2007-03-05 15:31:27.000000000 +0100
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
#define YYERROR_VERBOSE
|
||||||
|
static int yylex(void);
|
||||||
|
static int yyerror(char*);
|
||||||
|
-static int yyparse();
|
||||||
|
+/*static*/ int yyparse();
|
||||||
|
|
||||||
|
/* to be called: */
|
||||||
|
static int parse (void);
|
27
brltty.spec
27
brltty.spec
@ -1,6 +1,6 @@
|
|||||||
Name: brltty
|
Name: brltty
|
||||||
Version: 3.7.2
|
Version: 3.7.2
|
||||||
Release: 2.1%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
@ -8,6 +8,7 @@ Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
|||||||
Patch0: brltty-3.7.2-linux-compiler-h.patch
|
Patch0: brltty-3.7.2-linux-compiler-h.patch
|
||||||
Patch1: brltty-3.7.2-vt-buildfix.patch
|
Patch1: brltty-3.7.2-vt-buildfix.patch
|
||||||
Patch2: brltty-3.7.2-debuginfo.patch
|
Patch2: brltty-3.7.2-debuginfo.patch
|
||||||
|
Patch3: brltty-3.7.2-yacc-buildfix.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-InstallRoot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-InstallRoot
|
||||||
Summary: Braille display driver for Linux/Unix.
|
Summary: Braille display driver for Linux/Unix.
|
||||||
Requires(post): coreutils
|
Requires(post): coreutils
|
||||||
@ -21,6 +22,14 @@ It drives the braille display,
|
|||||||
and provides complete screen review functionality.
|
and provides complete screen review functionality.
|
||||||
Some speech capability has also been incorporated.
|
Some speech capability has also been incorporated.
|
||||||
|
|
||||||
|
%package xw
|
||||||
|
Requires: %{name}
|
||||||
|
Summary: XWindow driver for BRLTTY.
|
||||||
|
Group: System Environment/Daemons
|
||||||
|
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
|
||||||
|
%description xw
|
||||||
|
This package provides the XWindow driver for BRLTTY.
|
||||||
|
|
||||||
%package -n brlapi
|
%package -n brlapi
|
||||||
Version: 0.4.1
|
Version: 0.4.1
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -57,6 +66,7 @@ which directly accesses a refreshable braille display.
|
|||||||
%patch0 -p1 -b .linux-compiler-h
|
%patch0 -p1 -b .linux-compiler-h
|
||||||
%patch1 -p1 -b .vt-buildfix
|
%patch1 -p1 -b .vt-buildfix
|
||||||
%patch2 -p1 -b .debuginfo
|
%patch2 -p1 -b .debuginfo
|
||||||
|
%patch3 -p1 -b .yacc-buildfix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
||||||
@ -73,6 +83,9 @@ make install #install-programs install-help install-tables install-drivers insta
|
|||||||
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
install -m 644 Documents/brltty.conf "${RPM_BUILD_ROOT}%{_sysconfdir}"
|
||||||
rm -f ${RPM_BUILD_ROOT}/usr/bin/xbrlapi # whatever this is, we exclude it for now
|
rm -f ${RPM_BUILD_ROOT}/usr/bin/xbrlapi # whatever this is, we exclude it for now
|
||||||
|
|
||||||
|
ls ${RPM_BUILD_ROOT}/%{_libdir}/brltty/*.so | grep -v 'libbrlttybxw.so' | \
|
||||||
|
sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -97,12 +110,12 @@ then
|
|||||||
fi
|
fi
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%files
|
%files -f libs.filelist
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%config(noreplace) /etc/brltty.conf
|
%config(noreplace) /etc/brltty.conf
|
||||||
%{_bindir}/brltty
|
%{_bindir}/brltty
|
||||||
%{_bindir}/brltty-*
|
%{_bindir}/brltty-*
|
||||||
%{_libdir}/brltty
|
%dir %{_libdir}/brltty
|
||||||
/etc/brltty
|
/etc/brltty
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
%doc Documents/ChangeLog Documents/TODO
|
%doc Documents/ChangeLog Documents/TODO
|
||||||
@ -110,6 +123,9 @@ exit 0
|
|||||||
%doc doc/*
|
%doc doc/*
|
||||||
%doc /usr/share/man/man1/*
|
%doc /usr/share/man/man1/*
|
||||||
|
|
||||||
|
%files xw
|
||||||
|
%{_libdir}/brltty/libbrlttybxw.so
|
||||||
|
|
||||||
%files -n brlapi
|
%files -n brlapi
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libbrlapi.so.*
|
%{_libdir}/libbrlapi.so.*
|
||||||
@ -124,7 +140,12 @@ exit 0
|
|||||||
%doc %{_mandir}/man3/*
|
%doc %{_mandir}/man3/*
|
||||||
%doc Documents/BrlAPIref-HTML
|
%doc Documents/BrlAPIref-HTML
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
|
||||||
|
- added the XWindow driver
|
||||||
|
- build fix for newer byacc
|
||||||
|
|
||||||
* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
|
* Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
|
||||||
- quiet postinstall scriptlet, really fixes #224570
|
- quiet postinstall scriptlet, really fixes #224570
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user