Fixed XW driver to show Braille characters
Related: rhbz#1324669 - No need to explicitly harden - Added architecture to subpackages requirements - Made brltty main package to explicitly requires specific brlapi version - Renumbered patches
This commit is contained in:
parent
ab3a2f6816
commit
a54e8f333f
13
brltty-5.3-xw-fonts-fix.patch
Normal file
13
brltty-5.3-xw-fonts-fix.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/Drivers/Braille/XWindow/braille.c b/Drivers/Braille/XWindow/braille.c
|
||||||
|
index 26ca705..ccabdcd 100644
|
||||||
|
--- a/Drivers/Braille/XWindow/braille.c
|
||||||
|
+++ b/Drivers/Braille/XWindow/braille.c
|
||||||
|
@@ -211,7 +211,7 @@ typedef enum {
|
||||||
|
static int cols,lines;
|
||||||
|
static int input;
|
||||||
|
static char *model = "simple";
|
||||||
|
-static const char *fontname = "-*-clearlyu-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-unifont-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso8859-1";
|
||||||
|
+static const char *fontname = "-*-clearlyu-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso8859-1";
|
||||||
|
static int xtArgc = 1;
|
||||||
|
static char *xtDefArgv[]= { "brltty", NULL };
|
||||||
|
static char **xtArgv = xtDefArgv;
|
52
brltty.spec
52
brltty.spec
@ -7,9 +7,6 @@
|
|||||||
%global with_python3 0
|
%global with_python3 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# hardened build if not overridden
|
|
||||||
%{!?_hardened_build:%global _hardened_build 1}
|
|
||||||
|
|
||||||
%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
|
%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
|
||||||
%{!?tcl_sitearch: %global tcl_sitearch %{_prefix}/%{_lib}/tcl%{tcl_version}}
|
%{!?tcl_sitearch: %global tcl_sitearch %{_prefix}/%{_lib}/tcl%{tcl_version}}
|
||||||
|
|
||||||
@ -25,18 +22,20 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
Source0: http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
|
Source0: http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
|
||||||
Source1: brltty.service
|
Source1: brltty.service
|
||||||
Patch4: brltty-loadLibrary.patch
|
Patch1: brltty-loadLibrary.patch
|
||||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||||
Patch5: brltty-5.0-libspeechd.patch
|
Patch2: brltty-5.0-libspeechd.patch
|
||||||
|
Patch3: brltty-5.3-xw-fonts-fix.patch
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||||
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
||||||
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
# work around a bug in the install process:
|
# work around a bug in the install process:
|
||||||
Requires(post): coreutils
|
Requires(post): coreutils
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
@ -58,7 +57,7 @@ Summary: Speech Dispatcher driver for BRLTTY
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
BuildRequires: speech-dispatcher-devel
|
BuildRequires: speech-dispatcher-devel
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
%description speech-dispatcher
|
%description speech-dispatcher
|
||||||
This package provides the Speech Dispatcher driver for BRLTTY.
|
This package provides the Speech Dispatcher driver for BRLTTY.
|
||||||
%endif
|
%endif
|
||||||
@ -67,7 +66,7 @@ This package provides the Speech Dispatcher driver for BRLTTY.
|
|||||||
Summary: Documentation for BRLTTY
|
Summary: Documentation for BRLTTY
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%description docs
|
%description docs
|
||||||
This package provides the documentation for BRLTTY.
|
This package provides the documentation for BRLTTY.
|
||||||
@ -77,7 +76,7 @@ Summary: XWindow driver for BRLTTY
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
|
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
%description xw
|
%description xw
|
||||||
This package provides the XWindow driver for BRLTTY.
|
This package provides the XWindow driver for BRLTTY.
|
||||||
|
|
||||||
@ -86,7 +85,7 @@ Summary: AtSpi2 driver for BRLTTY
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
# The data files are licensed under LGPLv2+, see the README file.
|
# The data files are licensed under LGPLv2+, see the README file.
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
%description at-spi2
|
%description at-spi2
|
||||||
This package provides the AtSpi2 driver for BRLTTY.
|
This package provides the AtSpi2 driver for BRLTTY.
|
||||||
|
|
||||||
@ -95,7 +94,7 @@ Summary: eSpeak driver for BRLTTY
|
|||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
# The data files are licensed under LGPLv2+, see the README file.
|
# The data files are licensed under LGPLv2+, see the README file.
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
%description espeak
|
%description espeak
|
||||||
This package provides the eSpeak driver for BRLTTY.
|
This package provides the eSpeak driver for BRLTTY.
|
||||||
|
|
||||||
@ -104,7 +103,7 @@ Version: %{api_version}
|
|||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Summary: Application Programming Interface for BRLTTY
|
Summary: Application Programming Interface for BRLTTY
|
||||||
Requires: %{name} = %{pkg_version}-%{release}
|
Requires: %{name}%{?_isa} = %{pkg_version}-%{release}
|
||||||
Requires(pre): glibc-common, shadow-utils
|
Requires(pre): glibc-common, shadow-utils
|
||||||
Requires(post): coreutils, util-linux
|
Requires(post): coreutils, util-linux
|
||||||
%description -n brlapi
|
%description -n brlapi
|
||||||
@ -118,7 +117,7 @@ a refreshable braille display.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
Summary: Headers, static archive, and documentation for BrlAPI
|
Summary: Headers, static archive, and documentation for BrlAPI
|
||||||
|
|
||||||
%description -n brlapi-devel
|
%description -n brlapi-devel
|
||||||
@ -137,7 +136,7 @@ which directly accesses a refreshable braille display.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
BuildRequires: tcl-devel
|
BuildRequires: tcl-devel
|
||||||
Summary: Tcl binding for BrlAPI
|
Summary: Tcl binding for BrlAPI
|
||||||
%description -n tcl-brlapi
|
%description -n tcl-brlapi
|
||||||
@ -147,7 +146,7 @@ This package provides the Tcl binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
BuildRequires: Cython
|
BuildRequires: Cython
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: python-setuptools
|
BuildRequires: python-setuptools
|
||||||
@ -160,7 +159,7 @@ This package provides the Python binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
BuildRequires: Cython
|
BuildRequires: Cython
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
Summary: Python 3 binding for BrlAPI
|
Summary: Python 3 binding for BrlAPI
|
||||||
@ -172,7 +171,7 @@ This package provides the Python 3 binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
BuildRequires: jpackage-utils
|
BuildRequires: jpackage-utils
|
||||||
BuildRequires: java-devel
|
BuildRequires: java-devel
|
||||||
Summary: Java binding for BrlAPI
|
Summary: Java binding for BrlAPI
|
||||||
@ -184,7 +183,7 @@ This package provides the Java binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}-%{release}
|
Requires: brlapi%{?_isa} = %{api_version}-%{release}
|
||||||
BuildRequires: ocaml
|
BuildRequires: ocaml
|
||||||
Summary: OCaml binding for BrlAPI
|
Summary: OCaml binding for BrlAPI
|
||||||
%description -n ocaml-brlapi
|
%description -n ocaml-brlapi
|
||||||
@ -196,8 +195,9 @@ This package provides the OCaml binding for BrlAPI.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch4 -p1 -b .loadLibrary
|
%patch1 -p1 -b .loadLibrary
|
||||||
%patch5 -p1
|
%patch2 -p1 -b .libspeechd
|
||||||
|
%patch3 -p1 -b .xw-fonts-fix
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
# Make a copy of the source tree for building the Python 3 module
|
# Make a copy of the source tree for building the Python 3 module
|
||||||
@ -234,14 +234,14 @@ configure_opts=" \
|
|||||||
# First build everything with Python 2 support
|
# First build everything with Python 2 support
|
||||||
%configure $configure_opts PYTHON=%{__python2}
|
%configure $configure_opts PYTHON=%{__python2}
|
||||||
# Parallel build seems broken, thus disabling it
|
# Parallel build seems broken, thus disabling it
|
||||||
make LDFLAGS="%{?__global_ldflags} %{?_hardened_build:-fpic -Wl,-z,relro,-z,now}"
|
make
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
# ... and then do it again for the Python 3 module
|
# ... and then do it again for the Python 3 module
|
||||||
pushd %{py3dir}
|
pushd %{py3dir}
|
||||||
%configure $configure_opts PYTHON=%{__python3}
|
%configure $configure_opts PYTHON=%{__python3}
|
||||||
# Parallel build seems broken, thus disabling it
|
# Parallel build seems broken, thus disabling it
|
||||||
make LDFLAGS="%{?__global_ldflags} %{?_hardened_build:-fpic -Wl,-z,relro,-z,now}"
|
make
|
||||||
popd
|
popd
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -412,6 +412,14 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 7 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.3.1-5
|
||||||
|
- Fixed XW driver to show Braille characters
|
||||||
|
Related: rhbz#1324669
|
||||||
|
- No need to explicitly harden
|
||||||
|
- Added architecture to subpackages requirements
|
||||||
|
- Made brltty main package to explicitly requires specific brlapi version
|
||||||
|
- Renumbered patches
|
||||||
|
|
||||||
* Tue Apr 5 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.3.1-4
|
* Tue Apr 5 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.3.1-4
|
||||||
- Dropped man-fix patch (upstreamed)
|
- Dropped man-fix patch (upstreamed)
|
||||||
- Hardened build
|
- Hardened build
|
||||||
|
Loading…
Reference in New Issue
Block a user