Build with distro's LDFLAGS
Related: rhbz#1543490
This commit is contained in:
parent
859c30f8fe
commit
86624e877d
13
brltty-5.6-libs-add-ldflags.patch
Normal file
13
brltty-5.6-libs-add-ldflags.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7d93d8b..d016148 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -459,7 +459,7 @@ in
|
||||
esac
|
||||
if test "${GCC}" = "yes"
|
||||
then
|
||||
- brltty_cv_prog_make_object_shared="\$(CC) ${brltty_mkshr_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkshr_ld_options}]) -o"
|
||||
+ brltty_cv_prog_make_object_shared="\$(CC) ${brltty_mkshr_gcc_make=-shared} ${LDFLAGS_DYNAMIC} BRLTTY_OPTIONS_LD2CC([${brltty_mkshr_ld_options}]) -o"
|
||||
else
|
||||
brltty_cv_prog_make_object_shared="\$(LD) ${brltty_mkshr_ld_make} ${brltty_mkshr_ld_options} -o"
|
||||
fi])
|
@ -33,7 +33,7 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://mielke.cc/brltty/
|
||||
Source0: http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
|
||||
@ -43,6 +43,7 @@ Patch1: brltty-loadLibrary.patch
|
||||
Patch2: brltty-5.0-libspeechd.patch
|
||||
# Upstream patch (commits 9476bc50dc8 and 796fb282e3):
|
||||
Patch3: 0001-Add-support-for-eSpeak-NG.patch
|
||||
Patch4: brltty-5.6-libs-add-ldflags.patch
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||
BuildRequires: gettext, at-spi2-core-devel
|
||||
@ -226,6 +227,7 @@ pushd python2
|
||||
%patch1 -p1 -b .loadLibrary
|
||||
%patch2 -p1 -b .libspeechd
|
||||
%patch3 -p1 -b .espeak-ng
|
||||
%patch4 -p1 -b .libs-add-ldflags
|
||||
|
||||
# remove packaged binary file
|
||||
rm -f Programs/brltty-ktb
|
||||
@ -246,6 +248,7 @@ for i in -I/usr/lib/jvm/java/include{,/linux}; do
|
||||
done
|
||||
export CPPFLAGS="$java_inc"
|
||||
|
||||
export LDFLAGS="%{?build_ldflags}"
|
||||
export CFLAGS="%{optflags} -fno-strict-aliasing $LDFLAGS"
|
||||
export CXXFLAGS="%{optflags} -fno-strict-aliasing $LDFLAGS"
|
||||
|
||||
@ -507,6 +510,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 24 2018 Jaroslav Škarvada <jskarvad@redhat.com> - 5.6-8
|
||||
- Build with distro's LDFLAGS
|
||||
Related: rhbz#1543490
|
||||
|
||||
* Fri Mar 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.6-7
|
||||
- Don't build Python 2 subpackage on EL > 7 and Fedora > 28
|
||||
- Use bconditionals
|
||||
|
Loading…
Reference in New Issue
Block a user