import brltty-6.3-4.el9

This commit is contained in:
CentOS Sources 2022-05-17 05:11:23 -04:00 committed by Stepan Oksanichenko
commit 5e59601b12
8 changed files with 1272 additions and 0 deletions

1
.brltty.metadata Normal file
View File

@ -0,0 +1 @@
3d5b68f2f9b5bfe699a1002887c00bd33c340f7c SOURCES/brltty-6.3.tar.xz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/brltty-6.3.tar.xz

9
SOURCES/brlapi-config.h Normal file
View File

@ -0,0 +1,9 @@
#include <bits/wordsize.h>
#if __WORDSIZE == 32
#include "config-32.h"
#elif __WORDSIZE == 64
#include "config-64.h"
#else
#error "Unknown word size"
#endif

View File

@ -0,0 +1,9 @@
#include <bits/wordsize.h>
#if __WORDSIZE == 32
#include "forbuild-32.h"
#elif __WORDSIZE == 64
#include "forbuild-64.h"
#else
#error "Unknown word size"
#endif

View File

@ -0,0 +1,13 @@
diff --git a/Drivers/Speech/SpeechDispatcher/speech.c b/Drivers/Speech/SpeechDispatcher/speech.c
index cc55007..a2fcc0d 100644
--- a/Drivers/Speech/SpeechDispatcher/speech.c
+++ b/Drivers/Speech/SpeechDispatcher/speech.c
@@ -35,7 +35,7 @@ typedef enum {
#include "spk_driver.h"
-#include <libspeechd.h>
+#include <speech-dispatcher/libspeechd.h>
static SPDConnection *connectionHandle = NULL;
static const char *moduleName;

View File

@ -0,0 +1,21 @@
diff --git a/Bindings/Java/NativeComponent.java b/Bindings/Java/NativeComponent.java
index 2e6304a..cf6c9b0 100644
--- a/Bindings/Java/NativeComponent.java
+++ b/Bindings/Java/NativeComponent.java
@@ -23,7 +23,15 @@ public class NativeComponent extends Component {
private native static void initializeNativeData ();
static {
- System.loadLibrary("brlapi_java");
+ try {
+ System.load( "/usr/lib64/brltty/libbrlapi_java.so" );
+ } catch( UnsatisfiedLinkError e ) {
+ try {
+ System.load( "/usr/lib/brltty/libbrlapi_java.so" );
+ } catch( UnsatisfiedLinkError f ) {
+ throw new UnsatisfiedLinkError("brlapi_java library load failed");
+ }
+ }
initializeNativeData();
}

10
SOURCES/brltty.service Normal file
View File

@ -0,0 +1,10 @@
[Unit]
Description=Braille display driver for Linux/Unix
Before=getty.target display-manager.service
[Service]
Type=forking
ExecStart=/usr/bin/brltty
[Install]
WantedBy=default.target emergency.target rescue.target

1208
SPECS/brltty.spec Normal file

File diff suppressed because it is too large Load Diff