Update to 4.5

This commit is contained in:
Kalev Lember 2013-04-04 14:56:58 +02:00
parent 424e2591fa
commit 452dc0b0ee
7 changed files with 10 additions and 79 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
brltty-4.2.tar.gz
/brltty-4.3.tar.gz
/brltty-4.5.tar.gz

View File

@ -1,11 +0,0 @@
diff -up brltty-4.2/Programs/sys_linux.c.BAD brltty-4.2/Programs/sys_linux.c
--- brltty-4.2/Programs/sys_linux.c.BAD 2010-05-21 09:04:10.003122084 -0400
+++ brltty-4.2/Programs/sys_linux.c 2010-05-21 09:04:19.376198268 -0400
@@ -23,6 +23,7 @@
#include <errno.h>
#include <fcntl.h>
#include <sys/ioctl.h>
+#include <sys/stat.h>
#include <linux/kd.h>
#ifdef HAVE_LINUX_INPUT_H

View File

@ -1,17 +0,0 @@
2009-10-28 Stepan Kasal <skasal@redhat.com>
* aclocal.m4 (BRLTTY_SUMMARY_END): Use single quotes when
passing the value of brltty_summary_lines, so that is not
garbled.
--- brltty-4.1/aclocal.m4.orig 2009-10-08 04:32:49.000000000 +0200
+++ brltty-4.1/aclocal.m4 2009-10-28 14:28:30.000000000 +0100
@@ -396,7 +396,7 @@
AC_DEFUN([BRLTTY_SUMMARY_END], [dnl
AC_CONFIG_COMMANDS([brltty-summary],
[AC_MSG_NOTICE([${brltty_summary_lines}])],
- [brltty_summary_lines="${brltty_summary_lines}"]
+ [brltty_summary_lines='${brltty_summary_lines}']
)])
AC_DEFUN([BRLTTY_SUMMARY_ITEM], [dnl

View File

@ -1,24 +0,0 @@
2009-05-06 Stepan Kasal <skasal@redhat.com>
* Bindings/Java/Makefile.in: Propagate configure-time CPPFLAGS.
--- brltty-3.10/Bindings/Java/Makefile.in.cppflags 2008-07-17 00:19:45.000000000 +0200
+++ brltty-3.10/Bindings/Java/Makefile.in 2009-05-06 17:33:02.000000000 +0200
@@ -36,6 +36,8 @@
JAVA_JNI_FLAGS = @JAVA_JNI_FLAGS@
JAVA_JNI_DESTDIR = $(INSTALL_ROOT)
+CPPFLAGS = @CPPFLAGS@
+
all: jar jni doc
JAVA_SOURCES = $(SRC_DIR)/Brlapi.java \
@@ -56,7 +58,7 @@
$(MKLIB:<name>=$(API_NAME)) $@ bindings.$O $(API_LDFLAGS)
bindings.$O:
- $(CC) $(LIBCFLAGS) $(JAVA_JNI_FLAGS) -o $@ -c $(SRC_DIR)/bindings.c
+ $(CC) $(CPPFLAGS) $(LIBCFLAGS) $(JAVA_JNI_FLAGS) -o $@ -c $(SRC_DIR)/bindings.c
JAVA_JAR_FILE = $(API_NAME).jar
jar: $(JAVA_JAR_FILE)

View File

@ -1,11 +0,0 @@
--- brltty-4.3/Programs/Makefile.in~ 2011-10-07 10:03:28.000000000 -0500
+++ brltty-4.3/Programs/Makefile.in 2011-10-18 12:54:35.000000000 -0500
@@ -526,7 +526,7 @@
###############################################################################
-braille-drivers:
+braille-drivers: api
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver) || exit 1; \
done

View File

@ -1,5 +1,5 @@
%define pkg_version 4.3
%define api_version 0.5.6
%define pkg_version 4.5
%define api_version 0.6.0
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
@ -15,19 +15,14 @@
Name: brltty
Version: %{pkg_version}
Release: 13%{?dist}
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Daemons
URL: http://mielke.cc/brltty/
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
Patch0: brltty-cppflags.patch
Patch1: brltty-autoconf-quote.patch
#Patch2: brltty-4.2-S_ISCHR.patch
Patch3: brltty-parallel.patch
Patch4: brltty-loadLibrary.patch
Summary: Braille display driver for Linux/Unix
BuildRequires: byacc glibc-kernheaders
BuildRequires: autoconf
# work around a bug in the install process:
Requires(post): coreutils
@ -117,7 +112,8 @@ Version: %{api_version}
Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}-%{release}
BuildRequires: Pyrex
BuildRequires: Cython
BuildRequires: python2-devel
Summary: Python binding for BrlAPI
%description -n python-brlapi
This package provides the Python binding for BrlAPI.
@ -150,15 +146,9 @@ This package provides the OCaml binding for BrlAPI.
%prep
%setup -q
%patch0 -p1 -b .cppflags
%patch1 -p1 -b .quote
#%%patch2 -p1 -b .S_ISCHR
%patch3 -p1 -b .parallel
%patch4 -p1 -b .loadLibrary
%build
# Patch6 changes aclocal.m4:
autoconf
for i in -I/usr/lib/jvm/java/include{,/linux}; do
java_inc="$java_inc $i"
done
@ -307,6 +297,9 @@ exit 0
%endif
%changelog
* Thu Apr 04 2013 Kalev Lember <kalevlember@gmail.com> - 4.5-1
- Update to 4.5
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

View File

@ -1 +1 @@
5ada573f88df32b6150db3b9a620e20b brltty-4.3.tar.gz
7b52fa7746fed41ed344a1f75ce55951 brltty-4.5.tar.gz