New version
Resolves: rhbz#1350990 - Dropped xw-fonts-fix and async-wait patches (both upstreamed)
This commit is contained in:
parent
2fce83b5ee
commit
40500d1f00
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ brltty-4.2.tar.gz
|
|||||||
/brltty-5.2.tar.xz
|
/brltty-5.2.tar.xz
|
||||||
/brltty-5.3.tar.xz
|
/brltty-5.3.tar.xz
|
||||||
/brltty-5.3.1.tar.xz
|
/brltty-5.3.1.tar.xz
|
||||||
|
/brltty-5.4.tar.xz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/Drivers/Braille/XWindow/braille.c b/Drivers/Braille/XWindow/braille.c
|
|
||||||
index 26ca705..ccabdcd 100644
|
|
||||||
--- a/Drivers/Braille/XWindow/braille.c
|
|
||||||
+++ b/Drivers/Braille/XWindow/braille.c
|
|
||||||
@@ -211,7 +211,7 @@ typedef enum {
|
|
||||||
static int cols,lines;
|
|
||||||
static int input;
|
|
||||||
static char *model = "simple";
|
|
||||||
-static const char *fontname = "-*-clearlyu-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-unifont-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso8859-1";
|
|
||||||
+static const char *fontname = "-*-clearlyu-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-r-*-*-*-*-*-*-*-*-iso10646-1,-*-unifont-*-r-*-*-17-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso10646-1,-*-fixed-*-*-*-*-*-*-*-*-*-*-iso8859-1";
|
|
||||||
static int xtArgc = 1;
|
|
||||||
static char *xtDefArgv[]= { "brltty", NULL };
|
|
||||||
static char **xtArgv = xtDefArgv;
|
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/Programs/async_wait.c b/Programs/async_wait.c
|
|
||||||
index 231a07c..71b1372 100644
|
|
||||||
--- a/Programs/async_wait.c
|
|
||||||
+++ b/Programs/async_wait.c
|
|
||||||
@@ -142,13 +142,20 @@ awaitAction (long int timeout) {
|
|
||||||
|
|
||||||
int
|
|
||||||
asyncAwaitCondition (int timeout, AsyncConditionTester *testCondition, void *data) {
|
|
||||||
+ int first = 1;
|
|
||||||
TimePeriod period;
|
|
||||||
startTimePeriod(&period, timeout);
|
|
||||||
|
|
||||||
while (!(testCondition && testCondition(data))) {
|
|
||||||
long int elapsed;
|
|
||||||
|
|
||||||
- if (afterTimePeriod(&period, &elapsed)) return 0;
|
|
||||||
+ if (first) {
|
|
||||||
+ first = 0;
|
|
||||||
+ elapsed = 0;
|
|
||||||
+ } else if (afterTimePeriod(&period, &elapsed)) {
|
|
||||||
+ return 0;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
awaitAction(timeout - elapsed);
|
|
||||||
}
|
|
||||||
|
|
19
brltty.spec
19
brltty.spec
@ -1,5 +1,5 @@
|
|||||||
%define pkg_version 5.3.1
|
%define pkg_version 5.4
|
||||||
%define api_version 0.6.4
|
%define api_version 0.6.5
|
||||||
|
|
||||||
%global with_python3 1
|
%global with_python3 1
|
||||||
|
|
||||||
@ -22,7 +22,7 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
@ -31,9 +31,6 @@ Source1: brltty.service
|
|||||||
Patch1: brltty-loadLibrary.patch
|
Patch1: brltty-loadLibrary.patch
|
||||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||||
Patch2: brltty-5.0-libspeechd.patch
|
Patch2: brltty-5.0-libspeechd.patch
|
||||||
Patch3: brltty-5.3-xw-fonts-fix.patch
|
|
||||||
# patch provided by upstream
|
|
||||||
Patch4: brltty-5.3.1-async-wait.patch
|
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||||
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
||||||
@ -200,8 +197,9 @@ This package provides the OCaml binding for BrlAPI.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .loadLibrary
|
%patch1 -p1 -b .loadLibrary
|
||||||
%patch2 -p1 -b .libspeechd
|
%patch2 -p1 -b .libspeechd
|
||||||
%patch3 -p1 -b .xw-fonts-fix
|
|
||||||
%patch4 -p1 -b .async-wait
|
# remove packaged binary file
|
||||||
|
rm -f Programs/brltty-ktb
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
# Make a copy of the source tree for building the Python 3 module
|
# Make a copy of the source tree for building the Python 3 module
|
||||||
@ -419,6 +417,11 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 29 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.4-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1350990
|
||||||
|
- Dropped xw-fonts-fix and async-wait patches (both upstreamed)
|
||||||
|
|
||||||
* Fri May 13 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.3.1-8
|
* Fri May 13 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.3.1-8
|
||||||
- Fixed async wait to handle zero timeouts (by async-wait patch)
|
- Fixed async wait to handle zero timeouts (by async-wait patch)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user