5.5
This commit is contained in:
parent
0b88ce91e4
commit
2cb1453cb3
@ -1,11 +0,0 @@
|
||||
--- configure.orig 2017-03-17 10:38:18.549098316 -0400
|
||||
+++ configure 2017-03-17 10:38:26.499963667 -0400
|
||||
@@ -8673,7 +8673,7 @@
|
||||
|
||||
if test "${GCC}" = "yes"
|
||||
then
|
||||
- CYTHON_CFLAGS="-Wno-parentheses -Wno-unused -Wno-format -fno-strict-aliasing -U_POSIX_C_SOURCE -U_XOPEN_SOURCE"
|
||||
+ CYTHON_CFLAGS="-Wno-parentheses -Wno-unused -fno-strict-aliasing -U_POSIX_C_SOURCE -U_XOPEN_SOURCE"
|
||||
else
|
||||
case "${host_os}"
|
||||
in
|
@ -1,44 +0,0 @@
|
||||
From 05913940aa6c5e3cca9c2468f5fcd2d884ec6ab1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Sh=C3=A9rab?= <Sebastien.Hinderer@ens-lyon.org>
|
||||
Date: Tue, 8 Nov 2016 17:39:14 +0100
|
||||
Subject: [PATCH] Make OCaml API bindings compile with OCaml 4.04.0.
|
||||
|
||||
---
|
||||
Bindings/OCaml/brlapi_stubs.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/Bindings/OCaml/brlapi_stubs.c b/Bindings/OCaml/brlapi_stubs.c
|
||||
index 1e66f9e..aabdc14 100644
|
||||
--- a/Bindings/OCaml/brlapi_stubs.c
|
||||
+++ b/Bindings/OCaml/brlapi_stubs.c
|
||||
@@ -145,12 +145,14 @@ CAMLprim value brlapiml_errorCode_of_error(value camlError)
|
||||
static void raise_brlapi_error(void)
|
||||
{
|
||||
static value *exception = NULL;
|
||||
+ CAMLparam0();
|
||||
CAMLlocal1(res);
|
||||
if (exception==NULL) exception = caml_named_value("Brlapi_error");
|
||||
res = caml_alloc(2,0);
|
||||
Store_field(res, 0, *exception);
|
||||
Store_field(res, 1, constrCamlError(&brlapi_error));
|
||||
caml_raise(res);
|
||||
+ CAMLreturn0;
|
||||
}
|
||||
|
||||
/* Function : raise_brlapi_exception */
|
||||
@@ -159,6 +161,7 @@ static void BRLAPI_STDCALL raise_brlapi_exception(int err, brlapi_packetType_t t
|
||||
{
|
||||
static value *exception = NULL;
|
||||
int i;
|
||||
+ CAMLparam0();
|
||||
CAMLlocal2(str, res);
|
||||
str = caml_alloc_string(size);
|
||||
for (i=0; i<size; i++) Byte(str, i) = ((char *) packet)[i];
|
||||
@@ -169,6 +172,7 @@ static void BRLAPI_STDCALL raise_brlapi_exception(int err, brlapi_packetType_t t
|
||||
Store_field(res, 2, caml_copy_int32(type));
|
||||
Store_field(res, 3, str);
|
||||
caml_raise(res);
|
||||
+ CAMLreturn0;
|
||||
}
|
||||
|
||||
/* function packDots */
|
16
brltty.spec
16
brltty.spec
@ -1,5 +1,5 @@
|
||||
%define pkg_version 5.4
|
||||
%define api_version 0.6.5
|
||||
%define pkg_version 5.5
|
||||
%define api_version 0.6.6
|
||||
|
||||
%global with_python3 1
|
||||
|
||||
@ -22,7 +22,7 @@
|
||||
|
||||
Name: brltty
|
||||
Version: %{pkg_version}
|
||||
Release: 8%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://mielke.cc/brltty/
|
||||
@ -31,11 +31,6 @@ Source1: brltty.service
|
||||
Patch1: brltty-loadLibrary.patch
|
||||
# libspeechd.h moved in latest speech-dispatch (NOT sent upstream)
|
||||
Patch2: brltty-5.0-libspeechd.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1392147
|
||||
Patch3: brltty-ocaml-4-04-fix.patch
|
||||
# Don't pass unnecessary -Wno-format
|
||||
# Submitted to upstream: https://github.com/brltty/brltty/pull/91
|
||||
Patch4: brltty-format-security.patch
|
||||
Summary: Braille display driver for Linux/Unix
|
||||
BuildRequires: byacc, glibc-kernheaders, bluez-libs-devel, systemd
|
||||
BuildRequires: gettext, at-spi2-core-devel, espeak-devel
|
||||
@ -202,8 +197,6 @@ This package provides the OCaml binding for BrlAPI.
|
||||
%setup -q
|
||||
%patch1 -p1 -b .loadLibrary
|
||||
%patch2 -p1 -b .libspeechd
|
||||
%patch3 -p1 -b .ocaml-4-04
|
||||
%patch4 -p0 -b .format-sec
|
||||
|
||||
# remove packaged binary file
|
||||
rm -f Programs/brltty-ktb
|
||||
@ -424,6 +417,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 19 2017 Gwyn Ciesla <limburgher@gmail.com> - 5.5-1
|
||||
- 5.5, BZ 1443262.
|
||||
|
||||
* Fri Mar 17 2017 Stephen Gallagher <sgallagh@redhat.com> - 5.4-8
|
||||
- Don't pass unnecessary -Wno-format to Python bindings
|
||||
- Fixes FTBFS on gcc7
|
||||
|
Loading…
Reference in New Issue
Block a user